"Failed to open Focuslock" error

Hi All,

Just did a clean install on a new PC Stick running Windows 10 Home RDPWrapper (typing this via RDP).

Have installed my ASCOM Drivers - check
SGP latest v3 release - check
PHD2 - check

Have checked:
AZ-EQ6 GT works via ASCOM - check
Moonlight focuser works via ASCOM - check
CCD Works - check
Filter wheel - check
Guidescope - check.

Ran Flats calibration wizard in SGP - check (worked best it ever has).
Ran darks wizard in PHD2 - check (no issues).

Can connect all my gear in a new sequence template - check.

Equipment profile is accurate for my gear - check.
User profile (for what it’s worth) compete - check.

So with all that in mind, I click on Focus Lock Open (have purchased a licence) and get the following error:

Failed to open FocusLock! Exception has been thrown by the target of an invocation.

Tried a reinstall of focuslock (a few times) with no luck.

Any help would be greatly appreciated.


Anyone able to assist with this?

Ok, so I ended up solving this myself so thought I would post it here for someone else who might have run into the same problem.

As with most things, the solution was pretty simple in the end.

I uninstalled focuslock, ran ccleaner to clean my registry, reinstalled focuslock, and used the ‘open’ option twice. The first time the error reappeared, the second and subsequent times it has been fine.

Searched and found this before starting my own related thread.

9 times out of 10, SGP “times out” and complains focus lock won’t open, only to have it open right after the error (without me having done anything).

Clicking “open” again in SGP works, but perhaps the timeout needs to be adjusted?

I have an i7 with SSD so I don’t think it’s the fault of a slow computer.

Thanks FlyingBeagles!

I had the same error and after reading your solution, I cleaned my registry with CCleaner. Problem solved! I really appreciate you updating the thread with your solution!



Wasn’t aware of this issue… I can take a look.

I have made an attempt at improving reliability on opening FocusLock from within SGPro. I am unable to replicate the issue so I am unsure if it will have any effect…

These changes seen in SGPro versions GREATER than