Failure - 'Reference Frame does not exist'


#1

Hi All,

Just downloaded the software and trying to migrate to SG Pro from the normal free software. Looking forward to using it!

I’ve been reading the guides and have everything configured as I think is needed but when I try to plate solve I get an error,
“Plate Solve and Sync to Camera Frame Failed! Failed to plate solve reference frame because it does not exist. C:\Users\Pete\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit”

I have uploaded a screenshot, the logfile & the .sgf file to my onedrive folder; link below:

https://onedrive.live.com/redir?resid=9C0E88F5311F951!3401&authkey=!AAXwVGsIaS-zrok&ithint=folder%2Csgf

The logs were from Saturday night at around 11pm UK time. I have tried looking through the forum but couldn’t find anything that solved the problem, apologies if I’ve missed something obvious.

I am using a Nikon D7100, NEQ6 Pro, PHD2 and local astronomy.net service.

Thanks in advance,
Pete


#2

Hey, This has apparently been fixed in the newer beta.

If you set the camera to download both RAW + FIT or FIT only, it will work.

With the new beta, hopefully just setting NEF files will allow the plate solve to work as having the above setting. I haven’t tested this yet. Sometimes downloading both NEF+FIT can slow things down so it’s probably best to decide which way to go. If you do download FIT you have to do all your calibration files with the FIT files from SGP. If you use NEF you can also take flats/bias/darks with just the camera.


#3

Thanks for your quick reply, I’ve updated that setting. I really should have thought of trying that.

Is there a quality drop associated with using FIT instead of NEF?


#4

No quality difference, just the need to take all calibration files from the SGP if you do use FIT.

If you like you can try the newest beta as well, I haven’t had a chance to test it to see if that’s solved.


#5

I don’t mind shooting in FIT. My library dark & bias are in FIT anyway.

I’ll give this a try once the clouds clear.


#6

if your calibration frames came from SGP then you’re ok, otherwise you’ll need to reacquire your bias/darks in SGP.


#7

Hadnt heard that before, why is that?

I had, wrongly, assumed a master dark/bias would be transferable.


#8

I just set mine for NEF and Fits. So, this gives me the choice depending on what I’m doing with it.


#9

well in the case of canon cameras anyway, SGP is scaling the data coming from the camera from the native 14-bit data to 16-bits when it writes out the fits file. this means that if you have a bunch of CR2s or fits files produced with pixinsight, they will not be compatible as pixinsight does not scale the data. i don’t know what other packages might or might not do.

i’m not sure about NEF files because i’ve never worked with a nikon camera but if they are also 14-bit then you’ll have the same issue.

rob


#10

It’s not just the scaling that can differ. Things that can be “user transparent” but different between formats and even imaging software:

  • Image orientation (essentially the byte layout of the image)
  • Overscan representation (how much and from what sides is overscan removed, or not)
  • Scaling (do we represent 14 bits in 16 or scale 14 bits to 16? most scale FYI)

Probably other things as well but those are likely the big 3. Essentially for calibration to work and work well, you need to use the same format of data, taken with the same capture application. I doubt you’ll find any 2 applications or formats that are compatible.

Thanks,
Jared


#11

Thanks guys. Its been 6 months since I created my library files so might as well redo them.

I have read some interesting debate regarding the effectiveness of master darks with DSLRs. As there seemed to be no clear winner I opted to take mine overnight in the shed to keep the temp down and basically just use my master dark as a bad pixel map.


#12

My next problem, the fit won’t solve :frowning:

SGPro was able to download the image but it reported that it couldn’t solve. This morning I put the .fit file into AstroTortilla and it was able to solve. As said before, I’m using the astronomy.net local service. It is installed and the 127.0.0.1 url loads the config page, screenshot of this has been uplaoded to the link below (along with logs and some other info)

https://onedrive.live.com/?authkey=!AAXwVGsIaS-zrok&id=9C0E88F5311F951!3401&cid=09C0E88F5311F951

I am confident this is simply some config I have gotten wrong so any pointers would be great.


#13

OK so I’ve done more fiddling with this. I manually opened the image in SGP and did the right click ‘Plate Solve’ then clicked ‘Blind Solve’…it failed so no surprise there.

I tried changing to the remote Astronomy.net and it asked for the scale, once input it solved. Local still will not solve


#14

Sounds like an issue with your local ansvr setup. Can you screenshot the ansvr config page?

Thanks,
Jared


#15

Yes I think you’re right. Screenshot of settings in that onedrive folder


#16

As a desperate attempt I installed Plate Solve 2, it won’t solve it either but I do see lots of people having problems with it and DSLR’s.

Dying to get one good run with this using the trial before I fork out for the package plus framing wizard.


#17

I don’t see a screen shot of your ansvr settings. Have you downloaded the proper indexes for solving?

If you want to post your fit image I’ll try to solve it on my computer.


#18

peje1873,

I tried solving your image with ansvr local using the default settings and the correct image scale (0.67) and it solved right away.

I would recommend:

  • remove any ansvr settings other then the default settings
  • confirm that you have the right image scale, 0.67 (SGP Control Panel, Camera tab; and also in your equipment profiles)

Here are the ansvr settings I used:

Andy


#19

P.S. it solved with index 4207-01, so you should also confirm that you have the 4207 indexes installed. Run the ansvr Index Downloader and confirm that your range of indexes includes 4207.

Andy


#20

I installed 4204-4210 originally. I expanded this to 4203-4211 with no effect.

I used your defaults and they worked first time. I changed one setting at a time and discovered that noise level and star sorting each cause a failure.

Over the moon its all working, typically its now sorted just in time for over a week of cloud and rain but hey, still 39 days left on the trial.

One other question, is there a way to have the local service as the primary solver and the remote as the blind? I get this is probably a bit odd.

Thanks for all your help, its greatly appreciated.

Pete


www.mainsequencesoftware.com