Filter suffix


#1

Hi all,
I am running 2.5.1.1 and I noticed that when I choose a filter in the sequence, the filter suffix does not get automatically populated with the suffix correponding to the filter I.e. L R G B. I manually select the suffix which isn’t a big deal but I was wondering if that feature was removed from SGP. I found it very handy to not have to manually choose the suffix for subs.


#2

I forget why but this was an intentional change a few betas ago.


#3

@joelshort I forget too…someone was having problems with the auto fill feature. I did not like the change at the time (and still don’t). I’d love to have it back the way it was but am doubtful that we lazy folk can call a reversal on this one.


#4

The reason is that it was not required. Why would you need to use the suffix to report the filter name when you can just use the token to plug the actual filter name (%fe) into the file name? The suffix field is more for other notes specific to an event… not the filter wheel.


#5

Ah that makes sense. I need to learn how to use all the file name options.


#6

Hey All,
If its not required then remove it from the ‘Event’ line and replace it with a ‘Delay Time in seconds’ at the end after ‘No of exposures’, this way, each event can have it’s own user defined delay between each exposure the event is responsible for taking should they desire it.

That would be really handy !

:grin:

Paul


#7

@Ken I have always just left the file name as it was put up automatically %ft%tn_%el_%bi_%su_%fn In the earlier releases that %su just read off what was also put in automatically i.e. the filters as selected in the filter column showed up in the suffix column.
Since the auto fill was removed I have been putting in the filter designation (in the Suffix column) manually…I guess my error…but I thought that was what that column was for, as the filter names still reside there on the drop down list. (Place the mouse over any one of the blank spaces in the column and see what appears in your (tool tip) explanation…you have probably forgotten about this).

Question: The file name appears to be auto filled in the Target Data of the Sequence window:

Where do I alter this now to show %fe rather than the %su automatically for each new target…or must I alter the default - shown in the screen capture - each time I set things up. (I looked at the help file and it was not clear to me from reading what is there).

I think most of us want a Filter Name (of some description e.g. L, R, Ha etc.) in the file name…but I cannot see now how this is done without changing some entry or other (default file name OR suffix column) each time.


#8

Kinch,
Go to Tools/Options and under the General Options tab there is a field for
"Custom File Naming Pattern". There you can set your default tokens and
that will be the naming pattern for new sequences.


#9

Thanks Joel. I probably saw that way back - but never touched it. Got it
now.

Slán,

Brendan.

www.KinchAstro.com http://www.KinchAstro.com


#10

In addition to what @joelshort indicated, each equipment profile can define its own equipment profile list (if provided, it will override the pattern in the SGPro options dialog).


#11

Thanks Ken. That one was hiding in plain sight …I have been using SGP a long time and never ‘saw’ that…simply because I never felt the need to go looking I suppose. Now I know I am getting old :see_no_evil:


www.mainsequencesoftware.com