Flat Calibration Wizard result not saved to profile


#1

Hello,
I am trying to run the Fat Calibration wizard, and it produces a nice flat exposure time for a given filter/binning.
Then I hit ‘Save’ but the result is not saved in the profile.
Thanks,
Olivier

Exposure results:


After I hit save, the values are still 0 in the profile:


#2

Olivier,

You have selected to save the new flat exposure results to a profile. For those changes to appear in a sequence, you either need to create a new sequence with that profile, or apply that profile to the current sequence.

If you wanted to just change the current sequence, then instead of selecting a profile to alter, choose ‘Current’ at the start at the wizard.

You might also want to try a lower target ADU, 35,000 is a bit high, try 25,000 to 30,000. The exposures will be shorter as well.
Mike


#3

Thanks Mike.

As I said, the profile itself I selected is not updated. So even if I try to apply that profile to the current sequence or a new sequence, the flat exposure created from the wizard are all 0s.

I chose 35,000 as suggested by QSI for my 683 camera.
http://store.qsimaging.com/kb_results.asp?ID=28

Clear and unpolluted skies,
Olivier


#4

Hello all,

As we are on the subject of the Flats Wizard…

I used the ‘Flats Calibration wizard’ last weekend using ‘Current Sequence’, established an exposure time for my chosen ADU and saved it. Then after closing the wizard I then open the ‘Flats Wizard’ and instruct it to ‘Add Flat Events to the selected target (After last event in target)’.

SGP adds the flat event to the target as expected but the exposure time in the event stays as 0.00

SGP used to update the exposure time as I’ve done it loads of times in the past but no more it seems ?

Regards
Paul


#5

Hi I.m having the same issue. How did people solve this?
Thnaks


#6

Rather than start a new thread, I’ll piggyback on this one. I’m finding the same issue with my run of the Flats Calibration Wizard. I did set the flat box brightness. I select my profile for the wizard, run through the routine and click save. Going to the profile flats exposures for the filters I ran with, I find no update for the exposure.

Any help would be appreciated. I’m saving one profile manually, but have several others that I would rather not have to manually enter things in if it can save automatically.

Gabe


#7

I figured it out (partially). When creating a flats sequence and selecting the filter, binning, etc., the exposure time is filled in from the Wizard. This is where the confusion comes in though, it’s not updated in the table in Profile Manage > Filters tab > Set Filters button > Flats button. It would be very helpful if this was filled in from the Wizard to reflect the settings.

Gabe


#8

Perhaps I can bump this topic. I am having the same issue. After running the wizard I save it to my profile (not current sequence) and get a successful message. If I then go into my equipment profile manager and choose filters --> Set filters --> flats. There is no exposure time listed. If I create a new sequence and then run flats wizard, all exposure times =0. Am I doing anything wrong? I’ve watched a Youtube video that shows the steps and I followed them. Although he has exposure times saved when he is complete, mine still say 0.


#9

@sgreiner Can you confirm which SGP version you are using, and your operating system and I’ll try to run some tests to see if I can replicate the issue.


#10

I am using v3.0.2.91. I went as far as to reimage my PC and reinstall SGP. I created a new equipment profile and tried the steps and they didn’t save them in my equipment profile.
After I run the flats calibration wizard and save it and look at the FW settings, the exposure time says 0. But I if create a new sequence and run the flats wizard, I get the exposure times that were calculated. I can go back and double check the FW settings, and they still say 0. If I close SGP and reopen it and start a sequence, run the flats wizard, then it enters 0 as an exposure time. So it seems that the exposure times are calculated and stored in (a buffer, RAM, memory of some type) and they are available when I start a sequence. But only once. A new sequence comes up with 0 exposure time and a restart of SGP gives me 0 exposure time.


#11

That doesn’t sound right. I’ll have a try on a new profile as this information shouldn’t be volatile, it should save the settings in the profile (you may have totally different settings across multiple profiles).

It may be a bug in the latest version so I’ll try with that version and see what I get.


#12

Having now refreshed my memory and had a “oh yeah” moment, once the calibration wizard has been run, the ‘set no filter flats’ information will be blank. To find the stored information for your filters, you need to click on the ‘define filter list’ box, not the ‘set no filter flats’ box. You then need to click the ‘filter’ button for each filter you are using and the information stored should be there.

HTH


#13

Still not working for me. Here is my update as I perform the steps.
I ran the flats calibration wizard for all 7 filters for bin 1x1 and 2x2. target mean 18000 ADU +/- 500.
Calibration was successful. I clicked save. I choose my only hardware profile (SV80ST). Message says flats calibration data saved to profile SV80ST. I closed the wizard.
I open the equipment profile wizard and choose my profile. I clicked the filter tab and clicked Set filters button. I clicked every flats button. Every exposure was 0. I checked every setting in my equipment profile manager. No exposure time listed. I opened the control panel and clicked the filter buttons. No exposure time.
I went into my equipment profile manger and manually entered the exposure time. Now when I create a sequence, the exposure times will populate when I run the flats wizard.
To summarize, the only way I can get exposure times to populate when running the flats wizard is to have manually populated the exposure time. So this works but I’m wondering if I am doing something wrong or if this is indeed a bug with this version.
FYI, the only way I can find a “define filter list” button (as per your last comment) is to open the control panel when I have a sequence open. If I access the filter info from the equipment manager the button says “set filters”. The screens look the same, but either way, exposure time is 0.


#14

Ah, well that definitely isn’t right. As you will see on my video, once the calibration is saved, I can open the set filters dialogue and then review or change all the information saved from the wizard.

Is it worth rolling back to an earlier version just to double check your particular configuration to see if the latest has introduced a bug?

Just to confirm that it definitely hasn’t saved any settings, you can duplicated your main profile, import the data from your filter wheel, to clear all the populated tables and then run the flats calibration wizard. You can then set up a test target with LRGB events, and then run the flats wizard, just to see if it does indeed populate the flats events. At least this way you will then be confident to report it as a bug.


Random brightness issues with SGP and Optech Alnitak Flip-Flat
#15

OK, I guess I have an issue with the Flats Wizard too :frowning: No matter what I do after a successful run using the Flats Wizard the data just will not save to an existing profile or in a new profile. I read all the posts on this and still nothing positive from the Wizard. When I open the equipment profile to look at the filter ‘Flats’ button all there is are ‘0.00’s’. No data was saved from the run. The dialog said it was saved but where? Vaporland?

I had to go back to my other program to create flats. Something I’d rather not do.

Help!

Using version SGP 3.03.140


www.mainsequencesoftware.com