FLI IMG 6303e?

I quit using my equipment in 2005 when we sold the astro shack to build a house and observatory in New Mexico. Had no idea it would take this long, but here we are.

My question is does SGPro support my old USB camera and CFW?
It’s a 2005 FLI IMG 6303e camera.
I hope so, your software looks really good and I like the price too.


I am unsure. Please grab the trial (at no cost) and give it a try.

It’s alive !
It’s alive !
It’s alive !
Got SGPro installed on my new/old Win7 computer and found some FLI software (install kit) off their web pages and got everything working yesterday!

I’m a believer!

1 Like

I tried my first experiment with the camera taking a series of shots just to remind myself of/if everything is working.
I set up a series which was taking 1 second exposures with the “Luminance Filter” and “No Filter” so I could look in to the camera and see if everything is working as I expect it to.
It did this thing that I find strange.

When it changed filters the shutter “Blip-ed”. It did not open all the way but it started to open and then closed.
Change filter…Blip…Expose…Download
Change filter…Blip…Expose…Download
Change filter…Blip…Expose…Download
Change filter…Blip…Expose…Download
You get the idea.
Any idea what is causing the shutter blip?

Also when the image was downloaded it was totally black.
I tried my ancient copy of Maxim DL and the shutter did not blip and the images were full of “noise”.
Is this the way it’s supposed to work?

I’m still trying catch up after 15 years off.
Please be gentle.

It’s hard for us to tell. I know we have a bunch of FLI users that are active with SGPro, BUT, all we can really do is ask the camera to do stuff like “Take an image for 5 sec” and then fetch the data. How the camera goes about doing that is up to the FLI driver. There could be some information in the FLI logs… maybe it’s complaining about how SGPro is talking to it.

If you go to the “Help” menu and click on “Open Log Folder”, there should be a text file called FLI_DEBUG_LOG.txt If you want to reproduce the issue and then send that file, I can take a look.

As it blips it says “Integrating Target: xxxxxxx” it goes by to fast to catch the last part of the line but I think it is describing the image it has just taken.
I’ll have a look and see if I can find the file you described.

I found that text file but it is pretty large.
Can I attached it or send it to you?

You can just delete it and then reproduce the issue. FLI will create a new one and that should be smaller.

I guess it heard you and got scared.
It’s not doing it now and the sequence went much faster.
But the log is not that much smaller.

Now it started it again

ok, you can send it to the support@mainsequencesoftware.com address.

Any luck???

No, sorry. You may have better luck with FLI. There is nothing obviously wrong in the logs and they are not really user readable. I’m not saying there is nothing wrong with SGPro, just that the software to interface with FLI cameras has been around a long while and we haven’t ever seen any reports like this.

Guess I should have looked a little closer before I bought.

No worries… we have no problem refunding. Please send an email to our support address.