Focus Motor position confusion

I’m not sure whether this is an SGP issue or a Celestron Motor Focuser one. A couple of months ago something odd happened. The in-focus position was always about 21,000. Then one night when showing 21,000 the scope was completely out of focus with huge feint donuts.

The focuser has a full travel of 60,000. After a lot of attempting to find a focus point I tried a setting of 39,000 (60,000 - 21,000) and amazingly everything was in focus. For a while good focus has been around 39,000.

Two nights ago I selected an old sequence and the focuser position was reported as 21,000 but the scope was in focus.
I checked a recent sequence and it reported 39,000. Is the current position value saved with the sequence?

All the saved filter focus positions at the moment are around 39,000 so presumably would be useless.

Is there a way of resetting the reported position without actually moving the focuser or do I just have to delete the old sequences and recreate?

Thanks,

Robin

SGPro doesn’t care one bit about absolute focuser positions (at least in 3.1). It only cares about the relative distances between different filters. You can set all these values here:

https://www.mainsequencesoftware.com/Content/SGPHelp/FilterWheels.html

OK I now understand that but I’m still struggling to get my head round the implication of the same physical focus point being reported as different numbers.
Given a full travel of 60,000 and assuming the focus position is reported as 21,000 if the difference between the say the L and Ha filters was +500 the motor would move to 21,500 or put it another way 38,500 from the 60,000 position. Then if the reported position was 39,000 would not a filter difference of +500 cause a move to 39,500 i.e. 1000 from where we should be?
Hope that makes sense,
Still confused,
Robin

Not sure I can help you there. Whatever is going on is specific to your focuser and maybe other users can comment on it. It seems to me that your focuser’s “zero” position was reset at some point, but I can’t be sure.

This is a shot in the dark, but it might be related to the “Reverse focus direction” setting (Control Panel --> Focus Tab). Changing that setting produces the effect you described (this is by design).

Kind regards,
Horia