Focuser Hanging When Directed to Specific Position


#1

Hello,

I am working in the current beta version 2.5.0.18. If I have the backlash compensation turned on, the focuser hangs when I tell it to go to a specific point. I was collimating yesterday and needed to use the focuser a lot to get out of and into focus. When I directed the focuser to go to a position, it did not work and hung. I finally figured out that if I disabled the backlash compensation, everything went back to working correctly.

I looked at other posts and noticed that the focuser compensation was busted in a 2.4 version. Not sure if it was fixed or not but this issue may be similar and related.

Not a big deal. I just turned the focuser compensation off and it works. I use the robofocuser version 3.1.

I don’t think there is a need to send logs or anything unless you want them. I just wanted to post to see if this behavior was showing up with other setups.

I also have one more issue. If I initiate the go to a certain position on the focuser and have frame and focus taking images, the focuser command hangs. If I stop the frame and focus imaging, and then tell the focuser to go to a certain position (with the backlash compensation turned off, see above) and then start the frame and focus repetitive sequence, then everything works and I can see the target collimation star go into and out of focus, which was my needed observation tool to collimate.

If you want the logs I can replicate the behavior and send them up to the mother-ship. If not, then okay, I have found a work around.


#2

@bigeastro I use RoboFocus also and have the backlash compensation set in the RoboFocus driver settings - not SGP - and it works fine. If you need the backlash compensation now, you can try it that way.
I’ll go out to the scope later and try unchecking the compensation in RoboFocus and checking it in SGP…see what I find. I won’t be imaging (due to cloud) but I can hear the focuser making the slight inward move after going out as ‘instructed’.

(If you have it set in both places…might that be the cause of the problem??? Just a thought)


#3

@bigeastro Checked out at the scope: sorry, I gave you slightly incorrect information. I cannot actually turn off the backlash compensation in the Robofocus driver. I put it at zero - but when I opened the Config window again - it had reset itself to 20 (which must be the default compensation setting…you chose OUT or IN).

OK - then went to SGP and set the backlash compensation ON for the RoboFocus from SGP - even though there was, as I said, backlash compensation in action from within RoboFocus already. It quite clearly worked still (using different setting amounts). It was also very evident now on the SGP Control Panel screen (focus slider) what exactly the focuser was doing.

Looks like it is working as it should here. (SGP 2.5.0.17)


#4

I guess a log file is in order. No hurry.

I was able to duplicate the issue. At first it worked and then it hiccupped and then hung.


#5

@bigeastro

To the best of my knowledge, I have not seen reports of this with other focusers (or even any other reports with robofocus)… doesn’t mean that there aren’t… that’s just the status now. I am unable to determine any issues without seeing the corresponding robofocus log. Everyhting on the SGPro looks proper… we modify the position for backlash, that succeeeds, but the movement back to the original position fails. We need to see why RoboFocus is not moving where asked:

[3/17/2016 8:17:43 PM] [DEBUG] [Focuser Thread] Focuser moving to 10000
[3/17/2016 8:17:43 PM] [DEBUG] [Focuser Thread] Focuser backlash active, modified move to 10005
[3/17/2016 8:17:43 PM] [DEBUG] [Focuser Thread] Focuser move call complete
[3/17/2016 8:17:43 PM] [DEBUG] [Focuser Backlash Thread] Focuser backlash thread has started…
[3/17/2016 8:18:39 PM] [DEBUG] [Focuser Backlash Thread] Backlash thread has detected that movement to modified position (10005) is complete…
[3/17/2016 8:18:39 PM] [DEBUG] [Focuser Backlash Thread] Moving focuser to original requested position (10000)…
[3/17/2016 8:18:39 PM] [DEBUG] [Focuser Backlash Thread] Focuser backlash compensation needed. Steps: 5 Direction:IN
[3/17/2016 8:18:39 PM] [DEBUG] [Focuser Backlash Thread] Focuser moving to 10000
[3/17/2016 8:18:39 PM] [DEBUG] [Focuser Backlash Thread] Focuser move call complete
[3/17/2016 8:18:43 PM] [DEBUG] [Focuser Backlash Thread] Backlash thread failed to complete! Timeout!
[3/17/2016 8:18:43 PM] [DEBUG] [Focuser Backlash Thread] Focuser backlash thread has ended…


www.mainsequencesoftware.com