Freeze during Frame and Focus


#1

I would like to bring up again the issue of freezing up when I press Stop while taking a frame (Frame and Focus).
If there is a bug concerning the QHY9 drivers that I am using u should at least take that into account and not permit Stop to be pressed during taking a frame, but rather only when donwloading.
This happened to me last weekend and I had to shut down SGP…plus I had to recool the camera.


#2

This is not the way we want to operate. We cannot add code to accommodate for every bug in every driver (there are lots of them). Drivers must conform to standards or our own code base will quickly become unmaintainable.

If there is a bug in QHY drivers, it needs to be addressed by QHY.

Lastly, even if we were willing to do this, it would not be possible. The ASCOM driver provides no distinction between integration and download… it all looks the same to us. Thus SGPro could not even determine when it would be appropriate to prevent using the stop button (for your or any other camera).


#3

I would love it to be addressed by QHY.
But I am not sure that telling them that their drivers have a bug that cause SGP to freeze would be come a long way to a solution since their drivers work fine during Frame and Focus in Nebulosity, MAxim etc.
If u cannot distinguish between integration and downloading then that is a valid response and I agree there is nothing u can do.


#4

I believe both of these apps use native drivers… not sure?

To be honest with you (I completely believe this issue is occurring for you)… but the QHY9 is a very popular camera and we have many SGPro users that use it without any issues at all. I could be wrong… and if I am, I hope those folks will come forward and lend support to this thread, but we have only had a couple (literally 2) complaints (and even these issue where not identical in nature).

Your best bet is not with detailed descriptions, but with proof. Turn on ASCOM logging for the camera. Reproduce the condition. Correlate the SGPro log with the QHY9 log and look for any clues as to what is going on…

Possibly:

  • Look to re-install drivers at a higher privilege level (the QHY site indicates all their drivers need to be installed as administrator)
  • Check firmware to ensure yours is up to date.
  • Possibly reach out to Bruce Morrell (US QHY Rep) and see if he has any suggestions (there are other reps too… I just forget their names)

#5

I also have a QHY9 camera and do get the occasional freeze when stopping frame and focus. When that happens I abort SGP and restart it. Doesn’t happen a lot but it is annoying. Will try your suggestions.

Cheers

Ian


#6

Me too. I’ve learned by bitter experience to stop my finger twitching for Stop when doing initial focus or locating objects. Sometimes a complete shutdown and restart of everything required to get out of it.

Dimitri, one thing that might save you messing with long frames (and I’m guessing your trying to centre your object) is to use the Mosaic/Framing add-on. Really does work well and saves messing with manual Centering.


#7

Thanks RobF…of course the Mosaic feature is always valuable but some sort of Frame and Focus…either for last minute focusing or tiny adjustments of frame (especially when Pinpoint fails) is always required.


www.mainsequencesoftware.com