Frequent blank images (all black)


Recently upgraded to .457. I have a ZWO 160mm cam. Recently started getting empty, completely black frames. Tonight, it happened every other frame until I aborted the sequence, paused and restarted. I got 3 good frames and then it started happening again.

Aprox time of issue: ~9"15 PDT

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

Seems to be a somewhat known issue with ZWO native driver.

Black images are almost always the result of USB download issues. USB cables do fail over time. The first thing I would try is replacing the USB cable. The second thing I would try is to use a USB 2.0 cable (yes, 2.0) and see what happens. The downloads might be a few seconds slower, but USB 2 is usually much more stable. I used a USB2 cable with my QHY163M camera for 2 years.

Thanks for the tip Joel.

Interestingly, the ASCOM driver works fine that combined with the fact that my cabling is new it’s doubtful that its that. However, it could be my USB3 hub. It’s outdoors (covered) but not made for the outdoors and I’ve already had a port go “bad” on it. Time for a replacement it would seem so at a minimum, I eliminate that possible cause.

The only reason I use the natvie driver is so that I can set gain & offset. I frequently try to image 2 targets a night and when the moon is up-ish, one of those targets is narrow-band. Thus I need to dynamically go from 76 gain, offset 15 to 139 gain 21 offset for the RGB to NB switch.

I know I could just go with the gain changing and not worry about offset - but all my darks and flats are setup for 76/15 and 139/21.

One thing you could try is just plugging the camera directly into the computer and see if the same problem persists. Take new darks (gain 76 offset 21) as a test…then you don’t need to worry about the offset changing :grinning:

If there are no problems downloading the darks when directly connected to the computer then the USB hub is likely the problem. Although, if the hub has already had one port go bad then I would throw it away.

You say the cabling is new, but that doesn’t mean the cable is good for our purposes. Not all cables are made equally. For example, I recently got a new ASI6200MM. I had to buy three new cables before I found one that worked perfectly without any intermittent download issues.

I had the same problem @nightfly with my ASI183MM using the ZWO native driver. Thought it was the USB3 hub so I plugged it directly into the computer and had the same problem. Switched out the cable, still had the same problem. Switched to the ASCOM driver and everything worked again–I could even go back to using the USB hub and original cable.

Yeah, same here. The issue even persisted across reboots. Something changed to cause this issue and for me, that was likely Windows 10- it does updates on its own and they are hard to disable. Horse crap of a policy.

Nothing else has changed. I even went back to the prev version of SGP and that didn’t fix it either. I even found that ZWO had an updated driver - I installed that - same issue. I’ll take a look at my update history and see if some updates hit my astrobox.

If I switch to the ASCOM driver, I have to re-do all my calibration files. Arrgh.

My final followup:

My setup an usage of the ZWO native driver has been flawless these last 4 nights.

Nothing really change except for one key change in my process:

My normal process is to use SharpCap to Polar Align and then platesolve. Then switch over to SGP and let it do it’s thing.

As I was trying to troubleshoot the issue I recalled that in the past, if just shutdown SharpCap and then went into SGP - sometimes I had trouble getting good images and got really dark images - but not black.

A related issue was that on other occasions after doing something with my astro laptop and would just leave and let the laptop sleep then often my ASI1600 or 183 would exhibited similar issues: no image or really dark.

To address the latter issue, I long ago just started shutting down my astro laptop instead of letting it sleep between sessions or usage. I have a bios setting set to power up the laptop after a power off automatically so I just use my remote start switch to apply power to the laptop and it comes up on its own.

To address the former issue, I tried to make sure to disconnect the camera from SharpCap prior to shutting down SharpCap. I hadn’t been doing this recently. Though the resulting issue is different, it’s similar and I’ve updated SharpCap several times over the past few months.

So in the end my theory is that SharpCap can leave the camera (when using SharpCap with the ZWO native driver) in a funky state unless one officially disconnects from the cam prior to exiting. When this happens and I can back into SharpCap and it works ok, but not SGP or other app.

Lastly, in all cases, the only way to resolve the issue once it has occurred is to completely remove all power sources from the cam (no 12v input and no USB input) and then reboot the system. Let the system come back up and then plug everything back it and the camera recovers. Since this is the only fix, the camera is clearly also in a funky state as well.