Frustrated with Frame and Focus zoom function


#1

So here is the scenario…I am trying to achieve critical focus with a bahtinov mask and I am using short exposures in SGP frame and focus on a bright star to do so. Each individual exposure is no where near enlarged enough for me to evaluate focus, so I zoom in using the zoom feature. By the time I do this, another exposure has downloaded and SGP resets my zoom setting. Can SGP be set to maintain the same zoom level as new exposures are downloaded? F&F is useless for the way I focus.


#2

I can’t duplicate this. The zoom level stays constant between frames either using the “Pan and Zoom” module or using the + and - icons on the window.

Can you provide some additional steps to duplicate what you’re seeing?

Thanks,
Jared


#3

Jared,
This same thing happens to me in the main window. I simply start a frame and focus loop and in the main window the image will always fit to screen on successive image downloads regardless of using the zoom in or zoom out buttons. I’ve never tried the pan and zoom module.


#4

I’ve tried 3 machines and Ken has tried at least one. I can’t duplicate this on any of the 3. 2 are windows 8.1 and 1 is Windows 7.

Any other info you all can provide would be helpful. Camera, binning, exposure length…etc…

Thanks,
Jared


#5

Please try to use Frame and Focus with the ASCOM simulator camera and let us know what you see.


#6

Using the camera simulator the image always resets to fit screen. The zoom function does not stick. Interesting.

EDIT: I don’t normally have the pan and zoom module active on the main screen. Without the pan and zoom active the frame and focus image will always reset to fit screen. As soon as I open the pan and zoom module I can zoom in or out and it sticks in the main window. I can repeat this behavior with either scenario.


#7

Excellent find! I can duplicate that now :slight_smile: I’m not sure why it’s behaving like that. I’ll look into it. For the time being just have that module docked…it can even be hidden, it just needs to be active for some reason.

Thanks,
Jared


#8

Just having P&Z docked isn’t enough. The first change in zoom has to happen within the P&Z dock or the setting does not “stick.” I.e. if P&Z is docked, but I use the zoom ("+" magnifying glass) feature in the main screen for F&F, it resets to fit to screen with the next image.

Once I use P&Z slider to adjust zoom, THEN I can use the F&F zoom function and the zoom setting sticks.

I can also get the settings to “stick” without docking P&Z by using the draw rectangle zoom feature in F&F first. Once I do this, the subsequent settings I make with the zoom in and out icons stick as well.


#9

I’m not sure why you are seeing this. SGPro does not work this way. Image
windows properties are “sticky”. If you change zoom on a SGPro image frame
(like the frame and focus frame). Try this out with the ASCOM camera
simulator and notice that you can change zoom values and that this value
sticks between frames.


#10

In my case I’m using an stf-8300m, bin 3x3, 1sec exposure but the exposure time doesn’t matter. Win7 pc.


#11

Even when I use the Pan and Zoom dock, when the next image comes in, the enlargement window defaults to the upper left corner of the image–not the center–where I am trying to focus…


#12

I tried SGpro for the first time recently and had the same problem though I assumed it was my lack of familiarity with the UI. I to discovered that zoom worked fine through the pan and zoom module and steered clear of the zoom button on the image frame as the image would always jump back to fill the frame rather than hold on to the zoom.


#13

Thanks for all the research here. This issue has been corrected and will be out with the next 2.3 maintenance release.


www.mainsequencesoftware.com