Gmail rejects SGP notifications


#1

Setup notifications to smtp.gmail,com on port 587 with Use SSL. Google sends me this…

Sign-in attempt prevented
Hi Kurious,
Someone just tried to sign in to your Google Account xxxxx@gmail.com from an app that doesn’t meet modern security standards.
Details:
Tuesday, September 22, 2015 9:24 PM (Pacific Daylight Time)
California, USA*

We strongly recommend that you use a secure app, like Gmail, to access your account. All apps made by Google meet these security standards. Using a less secure app, on the other hand, could leave your account vulnerable.


Notification setup - epic fail!
#2

We don’t really have much control over this right now (we can attempt to register with gmail as a secure provider, but that will not happen very soon).

This is probably a good idea from Google’s perspective. It’s your choice whether or not you want to enter your credentials for gmail into a 3rd party app or not. We do not store, persist or do anything malicious with your credentials… but we “could”.

Ultimately, it’s up to you whether or not you want to give us that trust: https://www.google.com/settings/security/lesssecureapps

Another option is to create a free gmail account that is used for nothing but SGPro notifications…


#3

Thanks Ken. I will use one of these workarounds.


www.mainsequencesoftware.com