GNS Disconnects


#1

I was using the Good Night System last night and many times the session would close without any apparent cause. I have a strong WiFi signal. Does anyone have any thoughts on what might be causing these disconnects or how to debug the issue?


#2

Hi,

Jaime here, the author of GNS. What do you mean with the session would close? The windows program closed or the smartphone app?

Do you have the session log?
Did it work correctly for past sessions?

Sorry for the bunch of questions, needed to find out what may be going on.


#3

The smart phone app shows “Session Closed”. The windows app continues on. Where do I find the session log - smart phone or windows or both? For the last two nights it has been a reoccurring problem. In the past, as I recall, it has happened but less frequently.


#4

Hi,

proper log is only available in the windows program, it can help. In the smartphone, you should see the latest status messages (5 or so, depending on the phone). A screen capture of the final image would be great.

If you don’t have that list of latest messages please update the app - it will also be more informative.

Thanks,

jaime


#5

I have Android version 1.4 which appears to be the current version. If I go to the listing in the PlayStore one of the screens shows a red button at the top labeled “Session Ended”. That is the screen I has getting but I don’t recall any other status message below the second button.


#6

I ran a test and paid closer attention to what the screen said. On the smart phone, it shows the start of an event under status button. On the bottom of the screen the Timeout button is red - apparently it thinks the operation timed out, however, on the PC things are continuing normally.


#7

Ok I narrowed this down some more. Just before a time out I see the timer on the smart phone is about 40 while the timer on the PC is about 420. Further, the event on the smart phone was event 10 while the PC was doing event 11. It appears the smart phone missed the start of the new event. 11.


#8

Hi,

thanks for the work! Yes, as you said, it all points to a missing packet, but with the comms not “going down” that’s quite strange.

I’ll check the code and be right back


#9

Hello again.

There’s no way a message is lost and the communications does not go down - the status and timeout are sent in every poll from the smartphone.

I didn’t remember but I’m glad I did it this way, safer. :sweat_smile:

So, how about the normal case? The last operation received in the phone expired (timed out) before the next one was received. In the windows program the new operation is received and everything continues. But the timeout should be reflected in the windows log.

I guess one operation is just too tight on time.


#10

Here is a Dropbox link to the SGP log
https://www.dropbox.com/s/dhu9nlevg649krw/sg_logfile_20180911150347.txt?dl=0

At 16:17:07.129 there is a GNS message for the start of frame 10.
At 16:23:30.355 there is a GNS message for the start of frame 11 - the missing one

It appears the messages were sent from the PC.


#11

Yes, seems that’s it. First message sets a timeout for 360 sec, the second one is sent 383 secs later, so the timeout expires in the phone.

You can also enable the GNS log if you want to confirm this, but seems pretty clear for some reason SGP is thinking the flats will take 360 secs but they’re taking 383 secs.

Hope this helps!


#12

I think you are misreading the log. The event was 360 seconds but that is not the time out. Look at my previous post. GNS on the PC was showing image 11 with a time out of about 420 and the smart phone was showing image 10 with a time out of about 40. It clearly seems that the GNS on the PC and GNS on the smart phone were out of sync. The SGP log does not seem help determine why the two GNS apps where out of sync.


#13

Sorry, yes, missed that post. If that’s the case it is more weird.

Any chance you’re activating other apps in the smartphone? To have any warranty of reliability, the GNS must be in the foreground, active, at all times. If you’re using the smartphone for other things it won’t work.
(this limitation is imposed by the operating system, nothing I can do there)

Other than that, please active the GNS windows log - hope that log helps, if not, I can add more detail.

Please let me know.


#14

The phone was otherwise idle. How do I enable the GNS log on windows? I see a configuration item “Enable log” but it is grayed out.


#15

If you have that option grayed out then the version is a bit old; there is this update available: http://www.lunatico.es/GNS/GNS1003.zip - just replace the files in the SGPro install folder (make a backup copy just in case).

By idle you mean the screen was off?


#16

I ran a test of rapid darks. On the PC it was up to frame 5 while the phone was stuck on frame 1. The screen was on the whole time and the communications arrows indicated both directions where working. Here is the log from the PC side https://www.dropbox.com/s/q0wdymiaaasoddz/GNS.log?dl=0

I see a lot of “no communication with remote” messages. So it appears the remote thinks things are ok but the PC is not able to communicate.


#17

Thanks, well, something’s wrong no doubt. As you have android it’ll be easy when (hopefully) I find the problem. Let me check.


#18

Ok, I cannot find a flaw in the code - nor force the same error - but for sure something’s happening.

If I make a version generating a log file in, for instance, the Downloads folder of your phone, do you know how to access it and send it to me?


#19

Sure I can do whatever you need.


#20

Thanks, I’ll try to arrange something hopefully today. Will be right back!


www.mainsequencesoftware.com