Guider Never Reports "Settled"


#1

Hi guys,

Last night, I had a problem where the guider never settled and acquisition never started.

I have an STT-8300 with internal guider and use the SGP API to guide using PHD2. I have been using, with good success, settling settings of <0.5 pixels, option to “settle for” ticked and 6 seconds selected… I often use 4 second guide exposures.

Before last night my settling appeared to worked like this:

  1. PHD would report distance away from being centered after each guiding frame (I often use 0.5 pixels)… this distance generally gets smaller with each report as it heads toward the threshold.
  2. Once the threshold was reached, a countdown would start in the message bar reflecting how long the distance was below the threshold… I assume this is an SGP timer
  3. If the countdown completed, the message bar showed a message “waiting for guider to report it has settled”
  4. image acquisition would start

Last night:

  1. same as above
  2. Upon reaching threshold, nothing happened. Distances less than the threshold were continuously reported, but no countdown started and acquisition never started

I believe that I saw this behavior in all the versions listed below.

Unfortunately, my logs are something of a mishmash as I tried different combinations… I started off with 2.5.2.4. When I had a problem with that, I tried to upgrade to 2.5.2.5. Still no joy. Then I went back to 2.5.2.3 which I had successfully used on a number of nights. I was surprised to see that didn’t work either.

Ultimately, in my late night delirium, I got a sequence to run. Unfortunately, I cannot identify what combination of reinstalls, reboots, power cycles and version changes enabled success, but the successful versions were SGP2.5.2.5 and PHD2.6.2. I also turned off the “settle time” tick box and typed “0” into the seconds field.

I suppose this might be peculiar to my setup, but since it seems like some of the recent betas were related to the SGP API, I wanted to report this in case it is helpful. I was also hoping someone might be able to take a look at the logs and see if they could help me figure what is going on.

Rather than include all the logs I have attached two, the last run that would not settle (which was 2.5.2.3) and the log from the successful run which was 2.5.2.5. If I can help further, I am happy to do that. I can also provide PHD2 logs, if helpful, but it seems like PHD is happily sending distances through all this, and maybe never gets asked to do anything else?

Best regards, and thanks!
Craig

Version info:

OS: Win 10 Pro Anniversary Update

SGP: 2.5.2.3, 2.5.2.4, 2.5.2.5

PHD 2.6.2, 2.6.2dev4

Last Run with no Settling

Successful run


#2

I’m not a developer but something looks really wrong in the log. Tons of the following message:

[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] API Request:
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Endpoint: (POST) - /json/reply/SgGetGuiderImage
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Operation: SgGetGuiderImage
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Body: {“Receipt”:“7676931a-ae44-4893-835c-5bd95246f465”}
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] API Response:
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Endpoint: (POST) - /json/reply/SgGetGuiderImage
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Operation: SgGetGuiderImage
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Body: {“ImageData”:null,“Message”:“No image found for receipt: 7676931a-ae44-4893-835c-5bd95246f465”,“Success”:false}
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] API Request:
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Endpoint: (POST) - /json/reply/SgGetGuiderImage
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Operation: SgGetGuiderImage
[10/24/2016 12:47:07 AM] [DEBUG] [Unknown] * Body: {“Receipt”:“7676931a-ae44-4893-835c-5bd95246f465”}

How did your PHD2 screen look was it capturing frames nicely? Hmm…


#3

that might be normal, it;s a consequence of using the API guider (a necessity when using an STT). i would have to look at my logs.

I’m using the same setup but now it’s raining and i can’t power up my mount to check how i have it configured. i have once or twice seen this problem but it was transient. 99% of the time everything works OK.


#4

Thanks for looking… yes, PHD appeared to be capturing frames and issuing guiding commands. Like I mentioned, fresh distances were coming across the message box in SGP.

Thanks,
Craig


#5

@pfile, I have also had great luck with this setup. I was really surprised when it didn’t work all of the sudden. And even more surprised that it didn’t work when I rolled back to 2.5.2.3, which I have used successfully for several nights.

Craig


#6

hopefully ken or jared can look at it - i really can’t remember now what happened in my system when i saw this. many times if SGP gets into a bad state i end up shutting down, sometimes even rebooting, and starting over again.

rob


#7

@Ken, @Jared,

I have a more clear definition of this issue, I hope.

Running Windows 10 Pro Anniversary
SGP 2.5.2.5
PHD 2.6.2
Camera is STT-8300 using SGP API to run autoguider

Problem is that with settling timer un-ticked and 0 typed in the box, nothing happens when the settling distance reaches and crosses the distance threshold.

I am attaching logs which have only one attempt to run a sequence as I described above. I am also including the matching PHD logs, although my lay-person guess is that PHD is doing what it is asked to do.

SGP Log:

PHD logs


I’m not sure if it is helpful, but I’d like to draw your attention to this section of the log:

[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Guiding
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] {“method”: “guide”, “params”: [{“pixels”: 0.5, “time”: 0, “timeout”: 300}, false ], “id”: 1003}
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “guide”, “params”: [{“pixels”: 0.5, “time”: 0, “timeout”: 300}, false ], “id”: 1003}

[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] Checking PHD2 state…
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Guiding
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Guiding
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] User has elected to skip guider settling over time…
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] Waiting for Auto Guider distance to fall below 0.1
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] PHD2 distance request…
[10/25/2016 9:39:51 PM] [DEBUG] [Sequence Thread] PHD2 distance request returned 0.2…

It says “Waiting for the Autoguider Distance to fall below 0.1” but my setting is 0.5 for this sequence. Maybe you are doing this for another reason, though, because next, a capture occurs and the distance increases. Then the distances come back down. Lower and lower distances are reported, eventually they are lower than the threshold, but nothing ever happens, and I eventually abort the sequence. This excerpt is from the entire log in the link above.

If there is reason to think there is something peculiar about my setup, I am happy to try any suggestions. As I mentioned in my OP, I tried running a couple Beta versions of SGP, but they all exhibited this problem. I have not yet rolled all the way back to the release version, 2.5.1.17.

If you provide any suggestions, I would sure appreciate it!

Thanks,
Craig


#8

@Ken, @Jared,

Not sure if you have looked at this, but as additional info, I was able to run a sequence by changing these settings:

  1. kept the settling time un-ticked
  2. changed pixel threshold to 1.0 from 0.5 (even though I could easily get below 0.5)
  3. un-ticked “pause guiding during autofocus”
  4. disabled dithering, initially, but I really want to dither, so I turned that back on, and it still seems okay.

With these settings, image acquisition is still delayed while until the distance is over the threshold, but starts as soon as the threshold is crossed. I believe this is as expected.

Conditions are projected to be cloudy tonight. If so, I can try to change each of the other settings back to what they were and see if anything repeatedly causes the failure to settle.

Thanks,
Craig


#9

I saw some weird behavior similar to this last night. Not sure where it’s coming from at the moment, but I’ll have a look.


#10

@cgsathome This has been fixed and will be available in the next release. In the meantime, a very easy way to avoid this is to click the up or down arrow on settle value and then return it to its original value.


#11

@Ken,

Thank you!

Craig


#12

@Ken, I had a rare chance to get out with my gear in late November… I am happy to report that the settling problem that I was seeing is resolved with Version 2.5.2.6.

In fact, I ran all night (which is a long time, these days) without a hitch, with a target change, meridian flips, time constraints, and so forth, all with a new (to me) camera. With the new (to me) camera, a QSI690 and a Lodestar guide camera, I am no longer using the SGP API as I was using on the STT8300 with internal guider.

Thanks again,
Craig


#13

@cgsathome Excellent. Thanks for the report.


www.mainsequencesoftware.com