How can I avoid my scope colliding with my observatory roof?


#1

I have my roll-off roof observatory successfully slaved to my telescope. However when the sequence starts the telescope slews as soon as the roof starts to open. Depending on where the target is, I am getting the telescope colliding with the roof before the roof has had time to fully open. Is there any way of delaying the slew until the roof is open?


#2

How do you have the slve settings configured?

Assume as below

If have “Open Roof First” ticked then the roof driver is a suspect as it should not return Open till the roof actually is open.

Logs may help as well as the trace file from the driver.


#3

We’re gonna need a bigger roof. :wink:

Personally, I would never depend on hardware or software safeties as both can fail. I used to have this issue and finally decided a few years ago that I just needed to rebuild with a taller roof. It was a lot of work but I am sure glad I did.


#4

Exactly what I have, roof can open/close with the scope is any position. Still programmed my ASCOM driver so it only reports back to SGP Open when it actually is though.


#5

Interesting. I will have to try those settings and see what happens. Not sure what kind of roof control you or the OP have or if that matters but I likely have different control system (Maxdome) so it may shed some light (or not) depending on what you and the OP are using. Probably not if it is an ASCOM issue. I have never bothered with “Open Roof First” or “Park Mount First” mainly because I did not need to. I will try it next time I image.


#6

I use a Foster Systems controller and it works just fine. Mount won’t slew unless the roof shows open.

Chris


www.mainsequencesoftware.com