Images not autosaving


#1

Hi,

Recently i encountered a problem that a few images would not autosave during a sequence.
About 6 images in the sequence it stopped autosaving. later on i restarted and the problem was over.
But i like to know what happened, and how i can prevent it.

Thanks!
Here’s the log:

[6-5-2016 0:20:00] [DEBUG] [Camera Thread] ASCOM Camera Error : Exception of type ‘System.OutOfMemoryException’ was thrown.
at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 294
at ASCOM.DriverAccess.Camera.get_ImageArray() in c:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 361
at e8.j(c6 A_0, hs& A_1)
[6-5-2016 0:20:00] [DEBUG] [Camera Thread] Error while attempting to capture frame…
[6-5-2016 0:20:03] [DEBUG] [Sequence Thread] TEMP - Current Event17: 0
[6-5-2016 0:20:03] [DEBUG] [Sequence Thread] Image reported as complete. Continuing…
[6-5-2016 0:20:03] [DEBUG] [Camera Thread] Adding sequence level notification: Error attempting to capture image (see logs for more information).
[6-5-2016 0:20:10] [DEBUG] [Sequence Thread] Collecting FITs headers…
[6-5-2016 0:20:10] [DEBUG] [Sequence Thread] DATE-LOC time provided by camera…
[6-5-2016 0:20:11] [DEBUG] [Sequence Thread] GatherFitsHeaders: Writing header info for last solve…
[6-5-2016 0:20:11] [DEBUG] [Sequence Thread] GatherFitsHeaders: Writing header info from UI…
[6-5-2016 0:20:11] [DEBUG] [Sequence Thread] Clearing timed monitoring events…
[6-5-2016 0:20:11] [DEBUG] [Sequence Thread] Error saving ASCOM image. : Object reference not set to an instance of an object.
at e8.a7(d A_0, List`1 A_1)
[6-5-2016 0:20:11] [DEBUG] [Sequence Thread] Save image failed!


#2

@Dutchastrocolors

We cannot properly troubleshoot with partial logs. Please see below and we’ll take a look.

Also, did you use the “navigation arrows (green back and forward arrows)” to go through your images prior to this crash?


www.mainsequencesoftware.com