Images not displaing after long download time


#1

Using SG Pro version 2.4.0.2773 with Win 7. Image takes about a minute to download, then doesn’t display. Here is the log file. https://www.dropbox.com/s/v2pqbi1dsggm6fb/sg_logfile_20150407194405.txt?dl=0

Dean


#2

Dean,

I can’t really say for sure. I am not a Canon expert so maybe others might have some suggestions as to temperment or settings that might be best for your model. I think @Jared might have a D60 also, but I cannot reproduce this issue with our test Canon (Digic III). After complete, your camera doesn’t send SGPro a message that the image is ready for download for more than a full minute. Not sure why it doesn’t display. Have you tried shooting in RAW mode instead of FITS to see if it makes a difference?

[4/7/2015 11:37:17 PM] [DEBUG] [Canon Download Thread] Canon: Directory Item Requested Transfer 

This image ended integration at 11:36:15 PM.


#3

Hi Ken.

Head is spinning and fingers freezing. :slight_smile: Brain must be freezing too. How do I change from FITS to RAW? Can’t find the setting in SG Pro. It is taking one minute and 13 seconds to download the images. Timed it twice. And this camera worked fine with SG Pro last season, although frame and focus download has always been very slow.


#4

[edit} This is actually a reply to the thread about the JNow/J2000 corrections in the new 2.4.1 beta, don’t know why it wandered off and made its home here.

I’ve done a quick indoors test using the Celestron driver with NexRemote running in simulator mode and my DSS Camera and it collects an image, solves and syncs correctly. The previous version didn’t centre, I ended up with a consistent offset of around 11 arc minutes.

The mount reports LocalTopocentric (JNow) and the camera simulator converts the position it reads from the scope to J2000 before retrieving an image from the ESO DSS archive.

This isn’t much to go on because there’s far too much simulation to be comfortable with but better than nothing.

Chris


#5

Hi guys,

The weird thing is, in frame and focus it does display the image. And it plate solves just fine using the local astrometry.net on the laptop. But it won’t display the sequence images that i take. Not even if I go to their saved folder and try to open them. It just gives me a black screen.

edit: Ok…my brain was obviously frozen along with my fingers. They are displaying fine now. I forgot to set auto stretch for the downloaded images, rendering them too dark to see. Sorry for your time wasted Ken!

Dean


#6

Hi Dean,

This happened to me with my Canon and the problem was that I had either long exposure noise correction or high ISO correction enabled on my camera. Once I cleared them, download speeds returned to normal.

Frank Z…


#7

Hi Frank,

And thanks. That is exactly what it turned out to be. I had an “aha!” moment last night after shutting down. Ken’s comment about it taking the camera a minute to tell SG the image is ready for download clued me in. I had recently taken night pics of traffic trails and had turned on the long exposure compensation and forgot to turn it back off when I was finished.

Can you tell me how long it normally takes for SG to download an image from your Canon? Even with this problem now solved, it still takes about 13 seconds, which it always has. This seems painfully long sometimes. I took an hour of 30 second exposures of M31 last fall and it took almost half an hour total download time to download that hour of exposure. And my auto focus runs are a lot more time consuming than they should be as well.


#8

Hi Dean,

I don’t use my Canon with SGPro a lot because it and my QHY5LII guider don’t really like each other. It has a tendency to lock up when the Canon is downloading. I was hoping for a fix in 2.4 to stop PHD2 from reading frames during download,but that didn’t progress. I may try again later to see if any changes in 2.4 or PHD2 help, but I think it’s a driver problem with the QHY5LII. Everything else works great with SGPro. I can usually start a sequence at astronomical twilight and it will image until the morning twilight without a hitch ready for me to close up in the morning. However, I don’t quite trust the Canon/QHY5LII to do that.

I usually use the Canon as a ride along…piggybacked on the main scope taking 2 to 4 minute subs while I’m imaging with SGPro and the main scope. I use an intervalometer for the Canon and in some cases get some good widefield shots. However, it is good to see if any thin clouds came through during imaging so I can seek out problem subs. From what I remember from the last time I used the Canon with the PC, 12 seconds was about right for download. My QHY22 takes 8 for a 1x1 frame, but you can speed things up for focusing with 2x2 binning.

Frank Z…


#9

13 seconds is about right for the 60d. Much better than the 30+ that my STL takes :confused:

Frame and focus should be much faster if you enable the jpg preview.

Jared


#10

Thanks Jared. How about for auto focus runs? Should it be faster than 13 seconds? And would I benefit download speed - wise by cropping the auto focus image? Or is there a downside to that?


#11

Hi Frank,
Yes with my ED100 last year (my first season of AP) SG Pro was just awesome in every way. My only regret was that I had just shelled out over $500 for Maxim DSLR, and SG Pro just blew it out of the water. Autofocus worked great. Once you have drank SG Pro’s auto focus and plate solving Kool - Aid, there is no going back. :slight_smile: Hopefully I will get it working well with my Edge HD too. I use an external Feather Touch Crayford, so I won’t have the mirror problems to deal with that most people do with an SCT.
Most of my first season was spent glued to the laptop, chasing one problem after another. Once I got auto focus and plate solving working properly that all changed, and I had the wonderful problem of boredom to deal with. As you said, it runs all night without a hitch. i recently bought a set of 8x20 binoculars and a Paragon mount, so I will have something to do this season as I image. So nice to be able to look up instead of down at the laptop.


www.mainsequencesoftware.com