Improve downloading time

SGP is great, i have been using it like 1 year now but I find annoying that downloading times for frames are like 30 seconds each, using any other software is like 5 seconds! so I have no idea why SGP uses so much time for downloading and display images. That annoys me huge.

In most cases, SGPro does not actually download from your camera, but rather asks the ASCOM driver to do it. In this case, it’s not in our control how quickly data is downloaded.

I find a difference like this hard to believe. The only way there could be a difference in download time of this magnitude is if other applications use a “fast download speed” mode. SGPro forces this to off because it affects the quality of the image.

You didn’t provide any information on specifics… like actually what kind of camera you are using.

there is any intention to change that? :thinking:

hard to believe it or not it’s totally true and I’m not taking into account the time SGP uses for settle guiding , running dither and everything. Really the downloading time for frames is huge. It makes my short time exposures nearly impossible and unbearable.

I own a QHY16200A ccd , it’s frames are 35 Mb and this camera is USB 2.0 , i absolutly use low downloading time but believe it or not if I try other software the stops between frames are 5-10 seconds tops. I love SGP, I love the plate solving , I love everything but I’m trying to advice PLEASE take a look about it because if you guys fix that it will be perfect. :slightly_smiling_face:

and btw, we are a bunch of people that go out every once in a month to do some astrophotography together, there is at least 3 people who owns SGP , and all of them are experiencing very long downloading time. I don’t have any proof at the moment so you just should trust my word. I’m not here to blame you, I might have something wrong in my SGP’s configuration , I don’t have a clue :thinking: , enable history is unchecked, that improved several seconds but anyways it stills takes at least 20 seconds for downloading frames plus several seconds to do the other stuff. I always have to add one hour at least to the “total reaming time” for being accurate.

To improve remaining time how about you just add the download times into settings so SGP will take it into account?
image

Hello Xplode, Thanks for your help, that totally will help with the accuracy of the “total reaming time”

but as far as I know there is plenty of people experiencing very long downloading time, maybe the point is in what Ken said, download the frames directly from the camera not through the ASCOM driver, I have no idea , i’m no expert about software, anyways I don’t know how difficult it is to take a look into it.

greetings and clear skies

One way SGP could be improved is to start the next image before the last image is saved.
How long does it take SGP to save your file?
[10.07.19 00:07:07.297][DEBUG] [Sequence Thread] =========== Save file took 3869 ms
This is with a QHY163m and a pc with i5-8500T cpu.

SGP does actually process the image before it’s saved which wastes valuable time:
[10.07.19 00:07:06.872][DEBUG] [Main Thread] Find Stars: 2246 found…
[10.07.19 00:07:06.872][DEBUG] [Main Thread] Find stars took: 2901 ms…
[10.07.19 00:07:06.872][DEBUG] [Main Thread] Star list contains 2246 stars…

This processing should be easy to move till after a new image is started.

It would be cool if other people could post their save file time and find stars time too and of course the camera + cpu.

1 Like

Sorry where I can check that exactly?

The log file
Make sure you check for images binned 1x1.

my log files don’t show up any information like that :sweat_smile:

Are you looking at an actual log file where you took images or are you just click “view log file” in SGP?
If you click “view log file” it will load the log file from the current session which was created when SGP was started.

Sequence Generator_201909072130_015252_000.txt (108 Bytes) 2019-09-07 21:30:21.455 LOG_ALARM ----------------- log4z thread started! ----------------------------

That’s all it says !

Which SGP version do you run?

It’s the 3.0.3.169

I’m not sure if there is an option to enable/disable logging in that version?
It’s not in the newest beta, but it might have been removed.

I have “enable APi logging” disabled , it has something to do with it? :thinking:

No API doesn’t have anything to do with this.
Are all the log files that empty?

2018-12-08 19:42:25.778 LOG_ALARM ----------------- log4z thread started! ----------------------------
2018-12-08 21:51:35.290 LOG_FATAL ept->Write (qhycam.cpp):452
2018-12-08 21:51:45.291 LOG_FATAL ept->Write (qhycam.cpp):452
2018-12-08 21:51:55.291 LOG_FATAL ept->Write (qhycam.cpp):452
2018-12-08 21:52:23.532 LOG_FATAL ept->Write (qhycam.cpp):452
2018-12-08 21:52:33.719 LOG_FATAL ept->Write (qhycam.cpp):452
2018-12-08 21:52:43.719 LOG_FATAL ept->Write (qhycam.cpp):452
2018-12-08 21:52:53.720 LOG_FATAL ept->Write (qhycam.cpp):452

I don’t see any place where I can enable the logging :see_no_evil:

You need the log file from the session you are talking about. If you simply opened SGP and then went to “Open log file” it will open the log of your current session, not the session you are talking about in the OP.

It’s not that I don’t believe you, but something isn’t adding up here. The QHY16200A WILL take 25-30s to download in low noise mode with the ASCOM driver no matter what software is being used. My guess is that with other software you are either using the native QHY driver (not ASCOM) or you are downloading in fast mode which is going to have much higher read noise.

www.mainsequencesoftware.com