Increasingly seeing Alert: SBIG Shutter Error


#1

Hi,

I have two issues I am trying to diagnose… One seems similar to this:

although it happens to me even more regularly when attempting to take bias frames.

I posted about that issue in that thread.


But I am starting to see another issue with the camera, an SBIG STT8300.

The second issue most commonly manifests as an alert window: SBIG Shutter Error. In practice the camera seems to be unresponsive, sometimes recoverable by disconnecting and reconnecting, sometimes not. Prior to last night, I have been able to image 6 nights in the last week and a half (first at TSP, now in western NM). This issue has shown up 0, 1, and 2 times on different nights.

Last night after a good run until 2:30, I changed camera configuration (removed reducer) and was unable to restart a sequence. The camera appeared to connect, plate solved okay, but couldn’t get through a focus run without an error. Disconnecting and reconnecting the camera didn’t seem to resolve this. Also, trying to loop with PHD generated the error, but I am using the SGP API.

The log from last night is shared… As a bit of a directory:

  • Initially connected and ran flats until 9:48
  • Started a two-target sequence that included a meridian flip and target change. Concluded around 2:17.
  • Shut down PHD and disconnected camera, removed reducer, tried to restart and recalibrate.
  • Tried disconnects and reconnects. Almost got sequence restarted a few times, but got stuck on focus run.

One observation… the log is littered with “waiting for meridian, mount can’t flip normally…” lines, but they seem to be showing up when the target is not near the meridian. I think they are showing up even during successful imaging periods. Not sure if that matters or not. Also, mount is an AP1100 and can and does flip, not sure what “normally” means. Again maybe not important.

Thus far, this problem has been so unrepeatable (and since I am on an astronomy adventure, anyhow), that I kept plowing through with either disconnect/reconnects or power cycling, if necessary. But I am not sure where I stand, now.

My guess is that this problem is unrelated to the first one list above, but I am not absolutely sure.

To date, I have tried different cables, different ports (on same hub) and verifying sufficient power. Oh, and running the camera on CCDOPS… where it does work. :slight_smile:

SGP Version 2.5.0.23, SBIG drivers up to date, Windows 7 64 bit Pro.

Suggestions or advice are welcome.

Thanks and regards,
Craig Smith


#2

hi - i have the same kind of camera and as i’m sure you know the center power pin in the camera is quite flaky and can easily lose contact. have you done the hack of gently spreading the center pin a little bit? since you’re setting up and breaking down a lot you might be in a situation where the power connection is getting worse and worse.

from time to time i still get a random disconnect, but this is kind of once every 3 months kind of thing, not as bad as what you’re reporting.

rob


#3

Hi Rob,

Thanks for the response. I do know about the high tech power pin repair. I don,t think that’s the problem this time.

I’m still thinking this has to be a hardware/connector/ hub issue… But I’m thrown off a little by the mount diagnostics in the SGP log, since the mount goes directly to the laptop.

I actually setup my spare laptop, last night because I was convinced there was an issue with the laptop controlling my rig. But pretty early on I had a long delay when I requested a filter change, and shortly after my focuser failed to respond. I’m thinking, other than the mount question that I mentioned above that I have a hub issue, now.

I appreciate you suggestion.
Craig


#4

There is a large section of “no errors” followed by a fairly short section that has a fair amount of errors in it. When this happens it’s generally pretty indicative that a cable was pulled tight or something came unplugged/snagged/loose.

I would certainly start there and secure cables and the like. I haven’t really heard of many folks having SBIG errors (those coming from the actual driver like these) for a while…at least not since the dreaded “RX_TIMEOUT” was resolved.

Thanks,
Jared


#5

Thanks for taking a look. My cables are well secured, but there could be an issue with a connector or in the hub. I need to look into that, and think.

Are the numerous lines about waiting for a meridian flip (even though it was not near the meridian) flip just a red herring? I only ask because my mount connect to the laptop directly and doesn’t use any hubs. I would expect to see any issues there.

Best regards,
Craig


#6

I believe so. I can look into that a little more. It did seem odd.

Thanks,
Jared


#7

This is a bug in 2.5.0. A fix has been deployed to 2.5.1 beta (on 4/19).


#8

Just to wrap up this thread… The SBIG shutter error turned out to be… A real Shutter error. It finally became persistent enough to be diagnosed and ultimately repaired.

It was something of a tough error because it kills everything, and can’t be recovered (from).

Thanks again,
Craig


#9

thanks for the followup - was this the guide camera in the filter wheel or the main camera? heard from another STT8300M user that his cooler failed, so i’m starting to get worried.

rob


#10

Rob,

It was an error with the main shutter.

In trouble shooting efforts with Bill at SBIG, I learned that I have an “early version” of the STT8300. He was able to suggest a field repair that seems to have resolved the issue for me (3 successful nights of imaging at OkieTex with no more shutter errors). Apparently, the repair makes mine the same as those that were shipped later.

FWIW, I’ve had good luck with the self guiding filter wheel, and I really enjoy how easy it is to touch up the focus, if needed.

Craig


#11

OK i think i have heard of this; my STT (in theory) is also an early model since it was a preorder. this is something to do with the belt that drives the shutter?

as for the OAG i’ve had to tighten the set screw that holds the shutter open/close mechanism onto the motor shaft a couple of times. eventually it comes loose under the repeated stress of the shutter opening and closing while guiding. thankfully the shutter opens permanently when the main shutter is open (which implies that it has an electronic shutter in the first place, so i wonder why it has a mechanical shutter too.)

rob


#12

Mechanical shutters are good for darks.

I’m about to send my STF8300 off to bill for repair due to the shutter not positioning correctly. What is the field fix?


#13

Rob, that is exactly what is was. Wrapped the belt around the capston and it seems to work well.

@mads0100, Unfortunately, the STT shutter is different from the the STF. For what it’s worth, I had a shutter problem on my STF (that I used to have) when I operated it at the 13.8 volts that my setup uses. I eventually figured out that I could make the problem go away by reducing the input voltage to the 12.6-ish volts of a fully charged battery.

Craig


#14

Craig,

Good to know. Mine is actually on a power supply putting out… 13.8V. The error showed up when I swapped to using it on a bench supply versus the standard supply too!

I wonder if there is some type of electronic device that would limit it to the 12V? Otherwise I can crank down my power supply…

Thank you!
Chris


#15

@mads0100, I think there are step-down devices, but they are more for 12v–>5v… Not sure they can limit voltage for something like 13.8–>12.5. But that’s outside my area! My power supply was/is variable, so I just racheted it down and not too much later, ended up with an STT8300. The STT seems to be quite happy with the higher voltage.

My failures started when I stopped dragging marine batteries to the field and switched to a power supply. I’m embarrassed to admit it took me a couple of night to make the connection, but once I realized, I tested with the variable supply. The voltage where I started to see shutter problems was around 12.7 - 12.8.

Best,
Craig


#16

Nice! Thank you so much Craig. You might’ve saved me a trip to SBIG.

Chris


#17

I hope so!

Craig


#18

Tried it last night. Seems to be working :slight_smile:

Thanks!
Chris


www.mainsequencesoftware.com