iOptron Connection Issues


#1

I have a iOptron IEQ45 mount and when I try to connect, SGP reports that it is not connected. The first connection attempt brings up a dialog from the telescope driver which allows one to choose the connection method. Based on the log file https://www.dropbox.com/s/isqkcggouxt6avw/sg_logfile_20150413230513.txt?dl=0 it appears the mount reports that it is not connected although it is waiting for user input… It is a bit strange to have SGP report the lack of connection when in fact the connection is still pending. When I use the ASCOM diagnostic, a connect command does bring up the driver connect dialog but no error message. I don’t know if there is some status that SGP can query to determine that the mount is in this “waiting to connect” state to avoid the spurious not connected message. Perhaps also a timeout would be appropriate so if the user does not select a connection method in say a minute then a no connection message could be given.


#2

Right now SGPro does not expect to require user input in order to connect to the scope so it times out after 30 seconds. There is no “pending connection” status to query. Hopefully, you can do what you need to do within 30 sec and repeatedly querying you before connection is not part of standard operation.


#3

I get the not connected error immediately after clicking the connect button. A 30 second delay would help a lot but I’m not seeing that it is happening. BTW this is the latest beta version of SGP.


#4

Looks like the second attempt to connect succeeded? Your mount seems to be bypassing the wait period. We tell it to connect, apparently, it throws up a dialog, then we ask it if it’s connected and it says no. Of course there are ways around this, just curious if your mount is still asking you for information prior to connecting.


#5

SGP did connect after OK’ing the driver dialog and a second click on connect button.

After the first connect button click, SGP gives an immediate not connected and the driver displays a dialog that allows connection via COM port or WIFI. They seem to happen simultaneously. There appears to be no 30 second delay. If SGP is supposed to be doing the delay, it is not happening.


#6

Many ascom drivers can be launched directly and establish a connection stand alone. I would recommend going that route if it’s an option. That way you can connect the mount and take whatever actions are necessary and then connect sgp to the ascom driver.

Thanks
Jared


#7

For what it’s worth I did add a real 30 second delay that ASCOM devices cannot skip to allow for initial connections and other things like this…


#8

Great, that should help a lot.


#9

The iOptron driver seems bizarre to me. The setup dialog shows a message saying to do the set up using iOptron Commander and when you try to connect you get a message box asking for the connection type.

This seems barely ASCOM compliant to me. Drivers should only show UI in the Setup Dialog. Doing so elsewhere means that the driver can’t be used remotely because there’s no one to click on buttons on the display - or even read it.

It may be different if you have hardware connected, perhaps it will try to connect and only display the dialog if it can’t find a mount.

Chris


#10

Agreed, the dialog should be part of the setup.


www.mainsequencesoftware.com