Issue with ASCOM 6.4sp1?


#1

The other night I attempted to update my observatory computer to ASCOM 6.4sp1 and SGP 3.0.3.140. I performed a reboot after all the updates were installed. When I started SGP, it immediately reported a problem with a missing ASCOM file and I chose the option to continue anyway. SGP then appeared and showed the setup you see when SGP is run the first time on a computer; that is, all my customization was gone.

To be honest, it was really cold and I was not in the mood to trouble shoot the problem, so I simply uninstalled both updates and returned to the previous versions of both. The previous versions worked just fine. While this could be something specific to my PC (Win10, new v1809), I just wanted to alert anyone planning this same update.

FWIW this is the original release of Win10 1809, not the updated 1809 that was released a couple of days ago.

I brought my observatory PC home with me, so I can install the updated 1809 and try this again in a more comfortable environment :slight_smile:

Charlie


SGPro with AVX Mount - Error connecting to Celestron Telescope Driver
#2

chasmiller, I’ve got an issue with an "unhandled exception warning " click continue to ignore and I’m still frustrated trying to get Sgp running again. Could this be the same issue?


#3

@steppingbeyondcosmo

I saw the exception as soon as I tried to start SGP and a couple of reboots and restarts of SGP did not correct the problem. There was a big issue with the Oct 2nd update to Win10 (v1809) – some users (not all) were reporting random file deletes and Microsoft withdrew the update. This is supposed to be fixed by the Nov 14th update but I have not installed that update, yet. I won’t retry the ASCOM 6.4sp1 update until the new Win10 release is installed. I will re-post when I have done the tests. Since I have not seen others reporting this, it could be some issue with my PC but ASCOM 6.3 and SGP 3.0.2.94 work fine.

Charlie


#4

This is a follow-up to my previous post. This morning I was able to install the re-release of the Win10 “Fall Update” that had been pulled because it was deleting files on some systems.

After the Win10 update (KB4467708) was installed, I re-installed ASCOM 6.4sp1, performed a reboot, and then installed SGP 3.0.3.140 with no problems. So whether the initial problem was the Win10 update or something else is not really determined but both updates now appear to be working as expected.

Charlie


#5

Charlie , I ended up taking it back to 6.3 and everything is OK with SGP . Except for all my modules loading when I start up. Thanks for the heads up.

Mail](https://go.microsoft.com/fwlink/?LinkId=550986) for Windows 10


#6

I had a similar problem when it first came out. Just re-inastallled ASCOM 6.4SP1 and SGP over the top of existing installs. Also re-installed all of my ASCOM drivers again without removing first. Everything is sweet again.


www.mainsequencesoftware.com