Last night crash


#1

logs
Tell me what happened? Crashed 2.5.1.7 at around 10 pm.

Max


#2

In terms of why SGPro crashed… it’s not immediately obvious. Here are a couple notes / questions concerning the log analysis:

  • The camera appears to have failed downloading an image:

[4/28/2016 10:04:32 PM] [DEBUG] [Monitoring System Timed Message Thread] Adding sequence level notification: (flats42816) Failure while integrating ngc3718; Event 1; Frame 5 for 600s. Image has not downloaded in alloted time period.

  • Looks like the mount stopped responding to guiding at 21:51

[4/28/2016 9:51:27 PM] [DEBUG] [PHD2 Listener Thread] Unknown object from PHD2: {“Event”:“Alert”,“Timestamp”:1461905487.532,“Host”:“OBSERVATORY”,“Inst”:1,“Msg”:“PulseGuide command to mount has failed - guiding is likely to be ineffective.”,“Type”:“warning”}

  • Are the mount and the FLI camera connected to the same USB hub?
  • Any chance the mount failure could be a clue as to what happened to the camera?
  • There is a failure to run end of sequence options when the sequence was terminated due to unsafe conditions… this is a known issue and will be corrected in the next beta release.
  • The crash seems to have come from another bug (that has been fixed in 2.5.1.9) that could attempt to restart a frame if the guide star was lost (even if the sequence was in a bad state. This bug still does not explain the crash… it seems like as soon as SGPro tried to talk to the camera (even though it shouldn’t have) some low level exception was thrown and SGPro terminated.

#3

The guiding is ineffective warning happens frequently. However, the mount slide guides perfectly even during cycles when the warning appears. So I just ignore this warning, it is been happening since day 1. I have tried to tweak the ASA DDM85 mount’s guiding parameters to no avail. So far this has never resulted in a crash and the mount continues to work fine. So I don’t think this was the problem.

The camera is on a different USB hub than the mount . So I am guessing the problem started with the camera.

The ASA is doing really nicely at 10 min unguided exposures . Now that I discover how direct guide works, I will be using it for for LRGB a lot more. It ran with out any problems on 1.7 last night.

It looks like the he-cup started with the FLI. I got four prefect images then nothing.
This has not been problem up until now. Hopefully it is a rare event.
It could be a USB event outside of SGP. I will report any more events and will try 1.9

Thanks

Max


#4

Max,

The warning in PHD2 is saying that the mount reported a failure in response to PHD2’s request to issue a guide pulse. This probably means there is a problem with the Mount’s ASCOM driver and the ASCOM driver developers will probably be interested in hearing about it so they can fix it. The exact error message returned by the ASCOM driver will be found in the PHD2 debug log.

Andy


www.mainsequencesoftware.com