Merdian Flip failed to flip


#7

#8

@hfjacinto

Well… the good news is that this issues has nothing to do with meridian flips… SGPro never even attempted one. The bad news is this:

  • Your camera ate it during readout of an AF frame
  • You have identified that SGPro does not protect against a timeout specific to readout

I am not sure how well SGPro can protect against this either. I added a little bit of code to do what we can, but I suspect that we called into the SBIG driver and it did not respond with anything (and blocked the sequence) for 5 hours until we get this:

[9/26/2016 3:25:00 AM] [DEBUG] [Camera Thread] SBIG Error while downloading image: RX_TIMEOUT

As for the error itself:

  • Make sure your SBIG drivers are up to date.
  • Make sure power to the camera is stable
  • Make sure you are using a known good, appropriate USB cable
  • If you are using a USB hub, make sure it is powered

#9

Thanks,

I downloaded the new drivers they were not up to date.
I was using 120 so shouldn’t be an issue.
I have a new USB cable so hopefully that solves the issue.
I am not using a hub.

As protecting against this again, any way you can put in a 5-10 minute time out? for example no reply from a source stop the sequence?

Thanks for your help.


#10

A watchdog timer would be awesome.

Glad you got it sorted.


#11

It’s still happening but I think I know how the time out happens. It’s either changing the cooler temperature or selecting the settings. When I select camera settings I get the time out error right after that. I’m going to bed but I’ll take screen shots showing how I can cause the time out error, but looking through the threads I may have the drivers for an st pro??? I’m going to reload without st and see what happens.


#12

Hi All,

I had technical support from SBIG review my process and also install all the new drivers and he discussed with the other developer and they state that SGP is trying to open the SBIG driver when its already open. SBIG believes it is a bug on SGP. He shadowed me while I recreated the error.

These are steps:

  1. Connect to SBIG camera
  2. Go to Frame and Focus > Press Take one
  3. After Photo Downloads, go to Camera Icon (cheontrol panel on SGP)
  4. On Camera Tab press the Settings Button
  5. Close the Settings Button (press OK)
  6. Go to Frame and Focus > Press Take one
  7. Get the following error message "SBIG ERROR WHILE ENDING EXPOSURE: DRIVER_NOT_OPEN

#13

That’s weird. What camera are you using? I have an STF8300M and it doesn’t have any issues. I use frame and focus all the time. I updated my drivers about a week ago.


#14

I have the Stf 8300-C


#15

That is really strange. I wonder what yours is doing differently from mine. Like you said, you’ve tried the obvious… different USB ports, different cables, etc…

I wonder if my camera is, for whatever reason, handling it differently.


#16

If you shadow me I can recreate it at will. I had the SBIG tech guy shadow me, he read the log and after reviewing the log, he stated SGP sent a command to open the driver for the SBIG camera when it was already open.


#17

What version are you running? I haven’t updated… I’m still on 2.5.16.


#18

Don’t know if this will help, but yesterday I hooked up a second camera (sbig) to a piggy backed FSQ. I was getting similar messages to what you are seeing and found this post which may help: Connect/configure SBIG STT-8300M/FW8G-STT Filter Wheel.


#19

I’m on 2.5.1.17 that was version that was available as a download.


#20

Hi Gunny

Thanks but its a different issue :frowning:


#21

Just tested it on 2.5.1.16 same error when I do the same steps.


#22

@hfjacinto

Thanks for the report. I was able to recreate the issue with the steps you provided and this is fixed (in the next beta release). That said, are you sure this is related to the original issue you reported? Did you open up the camera setting during the sequence? It’s possible… the logs would not show it. The logs seem to indicate that the camera was functioning normally then failed.


#23

Hi Ken,

I don’t honestly remember everything I did. I know I did something because I got driver error messages on Sunday night. Was it this sequence? I’m not sure. On Saturday I did an imaging run and everything was perfect. I do remember getting the error message when doing the frame and focus. I thought to myself I should shut down and restart the sequence but decided not to as the camera came back. Considering I updated all the sbig drivers and am now on the beta version of sgp, I might not have the same issue. It’s cloudy and rainy for the next few days but when it’s clear I’ll try a sequence again. If you could add a feature to kill the sequence if unresponsive I think that would be great. If this happens again or after the fix I’ll start a new post. Please let me know when the latest beta is released and I’ll test.


#24

OK, well the error received in the original report was RX_TIMEOUT. While the DRIVER_NOT_OPEN you reported is certainly valid, I am not sure I am convinced of their relationship.

Not likely in the near future. Moving over to a watchdog system like this will take time.


#25

Ken

Thanks, since I upgraded drivers, cables etc, I’m hoping not to see the time out error. I still think it’s related to the DRIVER_NOT_OPEN error as the time out error only occurs when the the driver error occurs. I’ll let you know if the error occurs again and thanks for fixing the driver error. Please let me know when fixed so I can test.


#26

Ken

Thanks for the BETA release, I just tested the SBIG and the new release and no errors. You ROCK!!!


www.mainsequencesoftware.com