Meridian flips failed again, please help me


#1

Last night I tried v2.5.2.1, it seemed to work well at first, but later meridian flips failed again.
Here is the log file:
sg_logfile_20160920005416.zip (81.9 KB)

[2016-9-20 1:50:09] [DEBUG] [Sequence Thread] Blocking Pier Flip: Failed to meridian flip, aborting sequence (True)
[2016-9-20 1:50:09] [DEBUG] [Sequence Thread] Adding sequence level notification: Failed to meridian flip, aborting sequence.

According to mads0100’s advice, I checked the mount settings that require a ‘window’ around the meridian:

Is there any problem? Please help me.

Meridian flips failed is a problem bothered me for a long time, these are my previously posted topics:



Recovery and meridian flips
#2

So not only do you have to be in the window for your mount, but SGP has to call for it at the right time too. Do your SGP settings happen in this window?

Keep in mind you can test this during the day. Just make a new profile without platesolving, guiding or focusing. Then slew to a star within your window and tell SGP to perform a flip. If your settings are correct when you ask SGP to flip, it’ll work automatically.

On my Gemini, I use my safety limits to tell how close I am to the flip and command the flip within 10 minutes of that number. I don’t know if your mount gives you a read out like that?


#3

It looks like you are using an Iopton mount. I am using the CEM60 and have no problems with the flip, other than centering and plate solve after the flip, but that is my fault because of a poor alignment procedure.
Here is what I do in the settings.

  1. In the control panel under telescope and meridian set. What ever time in minutes you set this too, make sure the Ioptron hand controller meridian settings is longer than the number you set in SGP.
    Example. SGP. 12 minutes ( 3 degrees). Ioptron 8 degrees.
    Hand controller. Anything larger than 3 degrees. Also set meridian behavior to flip at position limit. Logic dictates if SGP has initiated the flip then the mount cannot be flipped after the fact.
    SGP uses minute units while Ioptron uses degrees.
    Looking at the dialogue box from the Ioptron Commander you have it set for 2 degrees. This means that SGP would have to be set at less than 2 degrees for SGP to intimate the flip.
    Also in SGP under meridian set, adjust the settling time to between 30 and 60 seconds.
    Hope this of help.
    Ed Stuckey

#4

Thanks Ed!! :slight_smile:


#5

Thank you very much, Ed~!

You means I should set more degrees (such as 4 degrees) in iOptron mount, to give SGPro more time to execute meridian flips?

In addition, there may be other two reasons:
1, Ken’s reply
(Recovery and meridian flips)
– It’s hard to tell why, but the call to stop and restart your guider failed. I think it is a timing issue related to using the onboard SBIG guide chip through PHD2. I have made the fragile parts of this method a bit more robust by adding retry attempts when this situation is encountered.
This explains my SGPro and PHD collaboration often have a problem–PHD frequent timeout problems.
2, I learned from iOptron developer, the current firmware exists control command bug near the meridian, and they will be fixing this problem.

I suspect this problem may be caused by a combination of factors.


Recovery and meridian flips
#6

mads0100, thank you very much~!
:slight_smile:


www.mainsequencesoftware.com