Moravian G3 16200 very slow download with SGP 55s solved -> Nas issue


#1

Dear all,

I am currently using a G3 16200 with SGP, but the doanload time seems a little bit too long to me : 55s
I expected about 20s, maybe 30s but almost 1min seems abnormal. Moriavaian claim in specs is 19s

I have tested with SIPS (the moravian proprietary software), it takes 24s

So either the ascom driver of SGP iw working slower gas expected. But having took a look to the traces, it look likes SGP is waiting and its time out is over at 19s I gues, so SGP then check the camera temps to verify it is still alive and if yes, enters in a “very dangerous loop” (as stated in the traces) and waits more until the camera responds, which fortunately occurs at the end.

Some of you have been using the G3 16200 for a long time with no such issue it seems, or did you faced the same king of functionning? and how did you solve or improved it

Thank you

Olivier


#2

My download time has always been 30s.


#3

Thanks Joel

Did you tried with SIPS also? was it the same time? or shorter?

I suspect a cable or USB hub issue (it passes through a USB2 hub), but SIPS does not seem to be affected as much as SGP / ascom…so…


#4

I’ve never even installed SIPS. What kind of computer are you using?


#5

OK.
I am using a core I3 6100 @3.7Ghz with 8GB ram, should be good enough.

I am currently capturing, memory usage is about 33% CPU is 3% while guiding, but I will keep an eye on it while downloading

edit : while downloading, the CÜ usage rises to 35%. CCD inspector also automatically analyses the image.

Now the CPU clock is about 800Mhz, due to the very light CPU load. Sometimes, a too low clock or too agressive energy saving settings, could slow down the USB speed, but I never saw that before on USB2 camera, only on USB3 camera and for planetary imaging, whith a huge data flow.

I will try to increase a little bit the minimum cpu clock in windows parameters, lets say from 5% to 10% min

Another thing that I suspect : the USB2 / USB3 compatibility. I don’t know for the G3, but I saw some Atik camera (the 460 for instance) that don’t work well on USB3 ports thought there is not any error in windows. The same camera on the same PC work well on native USB2 ports.

edit 2 : I see 2 ascom driver installed : the 32 bits version and the 64 bit version. Don’t know why both are installed nor it could have an impact (I am a member of a team and the PC is at a remote observatory. I am fine tunning the setup)… We are also using a G1 guide cam.

The PC is running win 10/64, latest moriavian drivers, ascom 6.3, latest SGP


#6

I use an NUC with nearly the same specs (i3 and 8GB RAM). So if you’re
getting 60s downloads something isn’t right with your system, not
necessarily SGP.


#7

Ok thank you very much Joel,

This closes some hypothesis

I updated the previous message FYI.

If I find something, I will tell here

Edit : FOUND, and nothing to do with astro gear. It was due to a Nas access issue. 100M instead of 1G

The images are saved onto a nas, but the ethernet link is working at 100Mbits instead of 1Gbit.

On top of that, I had CCDinspector running which also takes some bandwidth on the network.

saving on the local SSD results in 28s download as expected

:sob:


www.mainsequencesoftware.com