Need help with auto-focus with a Canon T1i


#1

I spent the week reading up on how auto focus works and I used the math provided to determine my focus step is 50. I got my scope set up and using the imagining software I have used in the past I got a nice batinov mask based focus. I then disconnected that program from the camera and started working in SG pro. After fiddling for over an hour I figured out that no matter how long of an exposure I requested the T1i’s shutter was only staying open 1 second (give or take). This was not enough time to get enough stars to run the routine. I tried both the manual auto-focus “run” request and the Frame & Focus 1 capture request. Both resulted in the same thing. I also noticed my focuser was still moving during the exposures, which might be my next problem. I was asking an nStep to make 50 steps between samples. Any suggestions?

Thanks,

Mark


#2

What exposure length did you set SGPro to use for your AF frames? Where did you set it?


#3

I used several settings from between 5 and 16 seconds and various ISOs. I did this in the Auto-Focus “set” area. As well another area. When an image was being captured I did see the software counting down 16 or so seconds of the requested exposure, but the shutter had long since closed. For the longest time I was thinking the program was holding the shutter open and instead of hearing open/close, I thought I was hearing close/open and the shutter was left open until the next exposure. I eventually figured out I was in fact hearing the normal open/close and the exposures were shorter than requested. For the frame and focus I remember exposure values right in the form with the “1 capture” button.

I’m doing this form memory and will check the computer in a few hours, but I have to run somewhere this morning.

Mark


#4

I had this exact problem with my Canon 6D when I first tried to use it with SGP. Always a 1 second exposure.
This will probably be fixed if you disable Mirror Lock and set the Mirror Settle time to 0.


#5

I found the mirror settle time, it was set to 1. I set it to 0. But I don’t see a mirror lock option. Changing that setting alone did not fix the problem.

Any idea on how to get the focuser to complete its movement before the exposure starts? Once I get past the 1 second exposure problem that will be the next challenge.


#6

I think the Mirror Lock is a hardware setting on the camera. Try looking through the menu options.
How long does it take your focuser to move a step size distance? I have never seen any issues related to that.
Also, do you get correct length exposures when you take 1 image in the Frame and Focus dialog? If you do get correct exposures there, then it is not the issue I had. I got 1 second exposures both places.


#7

I checked the camera and mirror lock up is (was) disabled. It did not matter what I shot (AF or 1 shot F&F) I always had a 1 second exposure.


#8

I forgot about the focus travel time question. I use a step of 50 and it seems to be taking the better part of a full second to travel that far. For the initial position that takes several seconds to travel to start the AF sequence. I am using an Rigel Nstep.


#9

I also use a RigelSys Nstep on all three of my telescopes with step size on the SV102mm of 60. I would guess it takes about 1-2 seconds for the initial travel. I never noticed an issue with that but it is possible that SGP is not waiting long enough before starting the exposure. Could be that might be why sometimes the first point is off kilter with the rest. Not having the backlash set correctly will also cause this. Next time I am at the obs I will check this out.

I have a question for you about the focuser. I have a lot of trouble with my RigelSys focusers giving me serial errors and not connecting without a couple of cycles of:

  1. closing the current RigelSys connection dialog that gave me the failure
  2. checking the Task Manager to make sure the RigelSys program is not still running in the background processes. If it is terminate it there.
  3. powering down the USB hub
  4. powering the USB hub back up
  5. running the RigelSys program again
  6. checking the Connect box to connect to the RigelSys hardware. At this point the odds are 50/50 that it will fail again so this cycle usually takes one or two iterations to get successfully connected.

Very annoying. Have you ever seen this and if so how often?
I have spent a lot of time with the RigelSys people trying to resolve this to no avail. There may be a serious problem with the serial connection code here.

About your 1 second exposure problem, I am about out of ideas here. The symptoms are exactly what I have with my 6D if I don’t have those mirror settings set to OFF and 0. You might try ON and 1 second. If that does not fix it then send your logs to Ken. Once you get the exposure time fixed, I don’t think the travel time will matter that much, assuming the exposure starts too soon since you will be taking longer exposures and it will only affect the first one significantly anyway.


#10

I can’t figure this one out. I disconnected the camera and went over all the settings. I did change the power off setting within the camera, but nothing else. I swapped out the battery and went to do some traditional photography. Now things are working. I paid a bit closer attention. My focuser takes the full 8 second exposure to move to the initial location with 9 steps of 50. My "step time on is 50ms and Step Size is 25 microns. For the exposures it seems the focuser starts to move as the shutter opens, after the first shot, since the movement is less, I’m hoping this is only a small problem. How do I request a feature be added to insert a pause in this process?.

I have had not of the problems you are describing with my nStep. I do use a powered USB hub at the scope and connect that directly to my laptop. It seems rock solid. I did have my nFocus chip die once and they sent me a new chip which corrected the problem. My nStep is about 2 years old. But this is only day 3 with SGP so my experiences are based on using other software.


#11

@markcasazza, for a new feature request just add a new topic under the ‘Feature Request’ category.
However, if SGP is not automatically waiting until the focuser has reached the target position before starting the exposure, this does not need a new feature. It needs a bug fix. I’m sure Ken or Jared will take a look at this, as will I to confirm when I get down to my obs.
They are very responsive to suggestions and bug reports on this forum.


#12

We have very stringent positional checking of the focuser’s position before moving on. Furthermore the code to start a new AF image is in the same thread as the focus movement checker… This makes it very unlikely that SGPro does not wait. That said, there are always unexpected combinations of events that can cause unexpected behavior. As always, we would need logs to try and sort it out.


www.mainsequencesoftware.com