New Celestron Focus Motor issues


#1

Just got the new celestron focus motor for my sct.

when i use the app provided by celestron it works great. Can go to a position i specify.

when i try and do the same in sequence generator, the focuser just keep going towards “0” position. it doesn’t stop, nor will it increase its position to one i specify. it just keeps going toward “0”.

i am using the ascom celestron unified driver, contains both mount and focuser driver.

am i doing something wrong? is there support for this focuser in SGP?


#2

Are you connecting using the USB connector on the focuser or have it connected through the Aux port on the mount?

Have you run the calibration routine that’s part ofthe Celestron app?

The separate ASCOM driver is Celestron’s, the combined telescope and focuser driver is mine.

One thing to bear in mind is that the focuser will not go to zero, there’s a software stop at about 1700.


#3

i am connecting the focuser with the aux cable. the using usb-serial to handset.

i have run the calibration.

the focuser doesnt go to zero, it just keep winding down to a lower value, never stopping to return to assigned value as it does with the celestron standalone app.

also, the stand alone app and the mount will not connect at the same time. they both use comm4 and wont let both run simultaneously.

should i run the focuser with usb through another port and assign different comm port?

thank for the help.


#4

I’ll check here but will probably need a driver log. The driver help explains how to get this.

That’s out of my control.

It might but I’d still like to get to the bottom of this.

Chris


#5

I’ve just checked with my focuser and the released driver and everything is fine. The focus position is reported correctly, movements, coarse, fine, in and out and goto position all work.


#6

ok. i keep fiddle around with it and try different ways of connecting. thanks.


#7

It did the same thing for me. Was finally able to fix it by first running the focuser calibration through the hand controller (not the software) and then connecting. Works fine now!


#8

Thinking about getting one of these to use on my Edge Hd8 with a non Celestron mount (iOptron iEQ 45 Pro) and no handset - any problems known with this route. I’d be running via a USB lead?


#9

Worked for me, too. Thank you!


#10

That’s good to hear.

Your comment about having to use the HC focus calibration is strange because the focus motor limits, which is what matter, are stored in the focus motor itself as part of the focuser calibration. All that the external control does is send a command to the focuser to do the calibration and waits until it finishes.


#11

Adding to the conversation - I’ve been trying to connect only the Focus Motor in SGP using a USB cable and the Unified Celestron ASCOM driver. I couldn’t get it to work, but the Celestron Focus Motor Utility connected just fine - on comm 3. After reading Chris’s post that the USB driver is Celestrons I went and downloaded it, uninstalled the Unififed driver, installed the Celestron USB driver and now it works. When I had the Unified driver installed and clicked on the wrench in SGP to set up the focuser it wouldn’t show any comm ports available. I’m using an iOptron CEM60 so don’t need the telescope side of the Unified ASCOM driver. Kind of ironic that it doesn’t work though.


www.mainsequencesoftware.com