New Nikon D5300 not connecting

Hello, I just upgraded myNikon D5200 to a D5300 and am unable to connect to SGP. I’ve used the 5200 for about 18 months with no issues.

The camera is flashing PC / -E- multiple times when connecting then it eventually times out.

It’s seen fine through the PC and I am able to transfer from the camera’s sd card. I do remove the SD card with SGP.

Edit: Perhaps some useful Info:

I found out my camera has Firmware C1.01 a note in the Nikon Download center said an older version of Nikon Camera Control would not be able to connect to the new firmware and need to be updated. Perhaps that is the issue with SGP. I am suggesting maybe the SDK needs to be updated for the new D5300 firmware? ** This firmware is Dated Jan27/16. Relatively new.

Thanks for any help.
sg_logfile_20160427142610.txt (20.1 KB)

PS. More info, I tried a third party app called “digiCamControl” and it connected to the camera fine.

PSS. Tried Nikon’s Camera Control 2, it also connected.

PSSS. I’ve tried this on 3 computers, same results.

Woo Whoo! Fixed!

I got the latest Nikon SDK from the Nikon website and it solved it!!

If you can incorporate the latest SDK in futue this would be much appreciated.

I’m not entirely sure how that fixed it as the SDK files are distributed with SGP. Did you replace the maid files?


Yes I replaced the:


Edit: I checked I am predicting newer D5500 with the same problem as it had a similar note in the firmware. So that one may need to be updated as well ( if that is a different maid file). Just thinking ahead here for all future Nikon users.

OK thanks. It probably has been a bit since we updated the Nikon libs. I’ll add a task to get those straightened out.


1 Like