New User asking help with puzzle


#1

Hello to the SGP community from a relatively new user! SGP has some fabulous features and generally I look forward to using it. I use the QHY168c, Pegasus focus cube with temperature probe, PHD2, and an Atlas Pro mount. I am a newbie, and have a lot to learn.
I recently acquired a used refractor which does not have an autofocuser. I thought that would be no big deal, as I did not have an autofocuser for my original telescope and manual focusing with a Bahtinov mask works well.
I created a new equipment profile for the new-to-me telescope which did not have a focuser nor environmental probe, thinking that when I used the Framing and Mosaic Wizard to create a new sequence, that SGP would not look for an autofocuser or environmental device.
However, when I tried it out for the first time last night, I could not get the sequence to run because it could not connect the autofocuser (which does not exist on this telescope). I could “Center On” just fine, and all of the equipment that was present was connected appropriately. But the sequence would not start because the autofocuser could not be found.

What is going on? I wonder if somehow I have missed something in a profile setting, but I can’t see it. I made the new profile the default profile and re-created the sequence, but the same error occurred and the sequence would not run. Help, please!

Thanks in advance,
David


#2

You likely have a setting that is requiring a auto focuser but SGP isn’t finding one. In this case we don’t really know what to do. However the dialog that pops up should tell you which setting(s) are incorrect to help guide you to fix the problem. If they’re not clear to you feel free to take a screenshot of the message and we can help guide you.

Thanks,
Jared


#3

Jared,
Thank you for your help. I just did not think of taking a screen shot, but I will do so next time. The message did give several possible causes, but the only one that seemed to apply to my very simple sequence was a light frame (which was the only box checked in the Run column). If I remember correctly, the error message said that an autofocuser was required to take light frames. Hopefully the skies will clear sometime this weekend and I will try again.

Thanks again,
David


#4

I decided to simulate the mount and try to run a new sequence. The same error message came up and is attached. I am still mystified
Thanks for the help of Jared and the SGP community!
David


#5

IIRC, I also encountered this puzzling error some time ago. Check whether focuser temperature compensation is enabled. If so, disable it.

This is a bug in SGP.

Bernd


#6

Yes, that is helpful. I checked and focuser temperature compensation was not enabled. Your comment brought back a memory from when I first started using an autofocuser (which was just four months ago). Initially I did not have a problem, but I also did not turn temperature compensation on right away. When I got comfortable with autofocusing V curves, then I wanted to try temperature compensation. The first time I tried that I had forgotten to plug in the temperature probe (I do stuff like that sometimes :slight_smile:) and I got this series of error messages. At that time the errors were resolved by simply plugging in the temperature probe, so I did not think much about it.
I wonder if once turned on the use of an environmental sensor, there is a problem with turning it off when there is no focuser selected… Could that be?

Thanks again for your help. I will keep working. I am not sure how to adapt the Focus Cube to the new-to-me telescope, but it looks like I will be trying to do that unless there is a work around for the absence of the temperature probe.

David



#7

For the last error you can disable that setting as mentioned in this thread:

Thanks,
Jared


#8

Jared,
Thank you for the prompt reply. I still feel like a newbie when it comes to profiles, and so sometimes I think the sequence is set up one way and it is slightly different. So, I created a new profile called “null” which has little equipment - just a camera simulator and a telescope simulator. I made sure there was no autofocuser selected and that temperature focus adjustment was not selected. I then selected the null profile and, using the truly marvelous Framing and Mosaic Wizard, I created a new sequence with one light frame and “slew to” only, since I did not want to deal with plate solving. I did notice that the new-to-me telescope parameters for the camera I use and a rotation angle were already in the Framing and Mosaic Wizard, even though I had not defined them. I don’t know if that is a clue or not…

When “Run Sequence” was selected, the same error returned. I really hate to be so inept, and am surely overlooking something, but I can’t see how to better apply the advice from the Sesto Senso post. Thanks again to everyone for thinking about this puzzle.


#9

Just fyi: Your screen grab is of the Equipment Profile Manger. Can you check the same settings in the Control Panel view?

(Changes in the Equipment Profile only affect current sequences if you explicitly apply the changes to the sequence - to change an existing sequence you need to use the Control Panel).


#10

Steve,
I think your piece of advice might just do the trick!

When I opened up the Control Panel, the several settings were different than the profile settings, including the use of temperature compensation. When I adjusted settings in the control panel, I could run the entire simulated sequence with some warnings (like no autoguider and no plate solver) but no errors about being unable to locate an environmental probe. Now for a clear night to try this under the sky :slight_smile:

Thanks so much for pointing this out! Sometimes I just don’t see what’s in plain sight…

David


#11

I think you can just select AutoFocus Simulator as your focuser. That’s what I do when I produce my flats.


#12

I am writing in follow up to the original question, which was trying to understand why I could not create a sequence without an autofocuser and why I could not turn the autofocuser (and/or environmental device) off once the sequence was created.
I really appreciate all of the help I received and report what I have learned in hope that someone else may benefit.

First, kudos to Jared and Ken for creating such great software! It had worked so well that I had forgotten an early lesson about assuring the correct profile was selected in the Framing and Mosaic Wizard. So, when I added a used telescope, I made a new profile, but did not regularly make sure the correct profile was set in the Wizard and apparently sometimes it was not.

Second, I forgot that the Control Panel was the place that stored the parameters for the sequence that actually was running and where they could be changed. So, when the error messages popped up, I went back to the Equipment Profile Manager and the stored profiles to change things. It is now clear that I was looking in the wrong places. And I did not consider selecting Autofocus Simulator as an option.

So, with the help of Steve, Plane, and Jared, when I focused on the Control Panel, I could change anything and the current sequence immediately implemented those changes. Problem solved… both with simulated equipment and under the night sky.

Many thanks for all the help!

David


#13

As a noobie myself, I experienced the same issues… then I discovered the “control panel” :blush:


www.mainsequencesoftware.com