Nikon cameras crashing SGP (SOLVED!)


#1

I’m hoping you guys can help me out.

For about a year, I’ve been using my Nikon D5200 with SGP, mostly without issue. However, I just upgraded to a new laptop (Lenovo Yoga 370, Windows 10), and I’m no longer able to connect my Nikon to SGP. Windows sees the camera just fine, and I can browse all the images, it seems to just be SGP that’s having an issue. As soon as I click the connect button, SGP immediately crashes (SequenceGenerator has stopped working). I can connect all my other equipment (mount, filter wheel, focuser, starlight xpress ccd), but I just cant get my Nikon to connect. I have tried with both the SD card in and out of the camera.

I can get the camera to connect to DigiCamControl just fine, but I believe that’s because that is using PTP, where SGP is using the Nikon SDK.

I can see in the SGP logs that it
’Failed to load MD3 file: C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0009\Type0009.md3. The file might be corrupted or in use by another process. You can download MD3 files from Nikons website: https://sdk.nikonimaging.com/apply/

I’m using version 2.6.0.25. Any ideas would be very appreciated. Thanks!

Here is the full log file.
sg_logfile_20180410192141.txt (19.9 KB)


SGP Crash with Nikon D850
#2

SOLVED!

It turns out that in order to connect to Nikon cameras, SGP needs to have at least a few of the Microsoft C++ Redistributables installed. Once I installed the 2010, 2013, and 2015 packages from the Microsoft site, I was able to connect to the Nikon. It seems to me though that if SGP needs these to be installed in order to connect to Nikon cameras, that they would be part of the SGP installation, which they are not.

If anyone else is having some connection issues with Nikon cameras (or perhaps any camera), make sure you have the C++ Redistributables installed on your machine.


#3

Interesting. I had thought those were a dependency of ASCOM which is a dependency of SGP. Maybe that is no longer the case? It’s been a while since I’ve installed ASCOM. But you’re right. We’ll add it to our install dependencies.

Thanks,
Jared


#4

Amazing to hear! I was wondering if you could supply a link to the files that are needed to run a Nikon camera with SGP?

Thanks for figuring this out!


#5

Sure thing!

These are the redistributables that I downloaded and installed:
https://www.microsoft.com/en-us/search/result.aspx?q=c%2B%2B+redistributable

I installed the newest updates for 2010, 2013, and 2015, and that seemed to get my Nikon’s to connect. I’m not sure if you actually need all of them, but it doesn’t hurt to have them.

and here is the 2017 if you want to install it also:
64-bit: https://aka.ms/vs/15/release/VC_redist.x64.exe
32-bit: https://aka.ms/vs/15/release/VC_redist.x86.exe

I hope these help you if you are also having connection issues with your camera!


#6

Hey! Thanks a lot for that! I just installed the 2010, 2013, 2015 and 2017 and tried sgp with my d750 and It still crashes when I try to connect. Took out memory card, manual more, auto focus off, and slot empty release lock turned off.

Any idea as to where to go from here? Am I missing something?

Thanks for your help!


#7

any ideas where to go from here?? would be great if i can get a nikon camera running with sgp.

thanks!


#8

Can you attach your log file? I’ll take a look at it to see if I can point you in the right direction.


#9

Also, the D750 uses the file Type0015.md3. Can you verify this folder/file exists in your SGP installation directory under NikonLibs?


#10

Here are the c++ distros that I have installed on my machine, and each version number. I can see that when I select ‘Auto Connect’ next to Nikon in SGP, it correctly loads the Type0015.md3 file. Make sure you have the same c++ distros installed (possibly even the same versions, if you can, since I know these work with the md3 file that you need).

[04/23/18 22:08:03.586][DEBUG] [Camera Thread] Nikon - Loading MD3 files from C:\Program Files (x86)\Sequence Generator\NikonLibs
[04/23/18 22:08:03.586][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0001\Type0001.md3
[04/23/18 22:08:03.660][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0002\Type0002.md3
[04/23/18 22:08:03.718][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0003\Type0003.md3
[04/23/18 22:08:03.776][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0004\Type0004.md3
[04/23/18 22:08:03.830][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0005\Type0005.md3
[04/23/18 22:08:03.883][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0006\Type0006.md3
[04/23/18 22:08:03.936][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0007\Type0007.md3
[04/23/18 22:08:03.993][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0008\Type0008.md3
[04/23/18 22:08:04.047][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0009\Type0009.md3
[04/23/18 22:08:04.053][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0010\Type0010.md3
[04/23/18 22:08:04.106][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0011\Type0011.md3
[04/23/18 22:08:04.159][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0012\Type0012.md3
[04/23/18 22:08:04.216][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0013\Type0013.md3
[04/23/18 22:08:04.269][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0014\Type0014.md3
[04/23/18 22:08:04.324][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0015\Type0015.md3
[04/23/18 22:08:04.379][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0016\Type0016.md3
[04/23/18 22:08:04.432][DEBUG] [Camera Thread] Nikon - Loading C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0017\Type0017.md3


#11

Here are the log files. Thanks again for your help!


#12

Thanks for the logs. I can see that you are getting the exact same error that I was getting before I installed the c++ redistributables. Can you upload a screenshot of your ‘Programs and Features’ window, with searching for c++? (see my attached screenshot from a couple of posts ago).

I believe you just need to find which redistributable the D750 relies on. It is likely a different one that you and I have installed.


#13

Thanks for getting back to me!
I noticed that I was missing 2015, so I installed that and tried connecting
a d750, and a d7200, both times crashed.
here is a dropbox link to the logs, and the screen shot.

Thanks again!


#14

Try some more:

2010 x86 , 2012 x86 , 2013 x86 C++


#15

I don’t see the updated logs or screenshot attached to your post, but I believe you just need to keep installing additional redistributables until you find the right one. Unfortunately, I haven’t found anywhere that Nikon has posted the requirements for their SDK for each camera, so I think it’s just trial and error until you find the right one. Make sure you reboot your machine after you install a new redistributable, then try to connect with SGP.

The D7200 uses the SDK file Type0017.md3, so make sure that folder/file combination is also in your NikonLibs folder within the SGP installation folder (I’m sure it is, just double check).

I will continue to assist you in getting this to work, as I believe you will get it. I also understand your frustration with this, as it took me a couple weeks before I figured out the issue and got it working myself.


#16

sorry, I must have forgotten to paste the link.

I just checked and do have the file Type0017.md3

thank you so much for your help!


#17

Ok, thanks for these again. Can you install the 32-bit versions of the 2013 and 2017 redistributables, reboot, then try again?


#18

@Cancington, were you able to install the 32-bit versions? Did that fix your issue, or are you still having problems?


www.mainsequencesoftware.com