Nikon D3 Unable to Connect using SGP 2.4.3.16 Beta


#1

I installed SGP 2.4.3.16 Beta and my Nikon D3 would no longer connect. There was an error saying to remove SD card and try again. I did that and still no connectivity. I uninstalled and installed SGP 2.4.3.12 and my Nikon D3 was able to connect. Hopefully this is just a bug in the beta and can be easily remedied. I’ve attached my log file for reference.

Hope this report helps.

Ciao,
Mel

sg_logfile_20151115123638.txt (67.4 KB)


#2

Unfortunately not. We’ve made changes to the way Nikon’s connect. The piece of code your camera seems to be choking on is this:

cam.SetUnsigned(eNkMAIDCapability.kNkMAIDCapability_SaveMedia, (uint)eNkMAIDSaveMedia.kNkMAIDSaveMedia_SDRAM);

We cannot remove it, because doing so causes a very large set of Nikon cameras to stop functioning entirely.

Can anyone else with a D3 confirm this behavior?


#3

Is there a firmware update to the D3 that fixes it?


#4

I looked at the camera firmware version and it was 2.02. I downloaded and updated the firmware… the latest version is 2.03. Still no connectivity with v2.4.3.16 Beta.

So with the changes to how the software connects with Nikon cameras, am I SOL with using my Nikon D3? It would be a shame if that’s the case. I really like the improvements, particularly the Plate Solve cancel button.

Thanks for the tip on the firmware!

Ciao,
Mel


#5

No. To be clear… we are stabilizing Nikon, we are not done with it. We are trying to understand why some things are required for some cameras and completely break others (and most importantly a way to tell the difference). From your perspective this is a huge step backward (understandably), but from ours it is a huge step forward because now more Nikon cameras are working than not (including the elusive D810A).

So… I am hoping to find someone else with a D3 so we can isolate the issue and determine if it is environmental or specific to the code.


#6

I can understand and appreciate that. Well if there is anything I can do to help, let me know.

Thanks.

Ciao,
Mel


#7

Mel @hxpi ,

Please try the 2.4.3.17 beta. It is not an elegant solution, but I am curious if, by removing the call to set the media save type, if the D3 suddenly starts working. If it works, we will look for clues as to why the camera hates that call and see if we can find a more elegant solution… Either way, the logs from an attempt to connect using 2.4.3.17 will be useful for further analysis.


#8

I installed 2.4.3.17 beta and the Nikon D3 is now able to connect and works normally. Attached is the log file for reference.

Hope this helps!

Ciao,
Mel

sg_logfile_20151121123049.txt (46.5 KB)


#9

Thanks Mel @hxpi .

The bad news is the requires “blind” special handling… meaning, I don’t know why we have to do this. The next beta 2.4.3.18 might regress for the D3 again, but if it works, I will have come across a real (permanent) solution to this issue that will allow this part of the code to work for all Nikon cameras.

So… to be clear… I will release the 2.4.3.18 tonight. It has no special handling for any type of camera. If the D3 still works, we win. If it fails to connect again, we are back at square 1 and more research is required.


#10

I tried 2.4.3.18 and SGPro works with D810A without any problem.

Thank you.
Donghun


#11

I installed 2.4.3.18 beta and my Nikon D3 will not connect. It’s giving the same error about remove SD card and try again. I reinstalled 2.4.3.17 beta and my Nikon D3 was able to connect and operate as normal. It looks like I’m stuck until a solution is found for the camera to connect with future updates, if possible.

Attached is the log file for reference.

Thanks.

Ciao,
Mel

sg_logfile_20151122001840.txt (72.3 KB)


#12

I compared my log to Mel’s log.
It seems that D3 SDK doesn’t support save media capability.
My log has [2015-11-21 9:06:58 PM] [DEBUG] [NikonScheduler callback thread] Save Media 1 0 1 which is missing from Mel’s log.

Ken, can you call save media set only if save media is supported by the SDK?


#13

Yes. I thought this would work:

cam.GetCapabilityInfo(eNkMAIDCapability.kNkMAIDCapability_SaveMedia).CanSet()

But it does not… I will need to use the method you suggested.


#14

I installed 2.4.3.19 beta and the Nikon D3 is able to connect and work normally. Attached is the log file for reference.

Thanks for your diligent efforts!

Ciao,
Mel

sg_logfile_20151122231039.txt (172.7 KB)


#15

Thx. Now we just need to figure out if the D810A is still working


#16

D810A works well with 2.4.3.19.

Cheers.
Donghun


www.mainsequencesoftware.com