No slewing with connection to telescope in TheSkyX


#1

I bought SGP in Feb of this year and have used it to control my camera for taking dark frames successfully. Everything in the program seems to work, except connection with the MYT mount. I have tried on several nights to automate my imaging routine without success. I cannot slew the mount even though SGP says the mount ‘is connected’. The buttons are green and say 'mount connected, yet under the telescope tab it says ‘mount not connected’. Confusing! Can anyone help me out?

Edit: The mount will home if ‘home the mount on startup’ is selected.


#2

Anyone out there?


#3

I can at least tell you that I use SGP with my MyT without issue, so don’t be discouraged, it will work. As to what the issue is, I’ll leave that to the experts to help figure it out. You may want to upload a log file.


#4

We don’t have any experience with MyT. You can post logs if you want and we can take a look.


#5

Have you tried using ASCOM to move the mount? I’d put a feeler out on Cloudy Nights. I think MADRATTER has a MyT and runs SGP.


#6

Yes. I’m using Ascom in every program to move the mount. Maxim moves it quite easily. SGP shows and says connected, but when you try and move the mount it comes back with the message ‘not connected’. I bought ACP today, it’s been moving the mount for several weeks during my trial period.


#7

As far as I can tell, the MyT shouldn’t be different to the other Paramounts - with my PMX, I did come across a few slew issues, but these were to do with TSX settings, not SGP. Here are a few things to consider.

For instance, I was trying to slew near to the meridian but for some reason the flip setting was blocking the move. (I dragged the line with the little red square on the TSX display back onto the meridian and it freed up.) I would also check the horizon and limit settings, they can block slews too. I know you said that MDL worked but this issue may be object related rather than application and MDL might fail under the same conditions for the same object slew.

The other thing is that the telescope nudge buttons in SGP do not work with the PMX (and I assume the MyT too). I don’t use them very often and found if I really needed something manual, I used the ones in TSX.

hopefully something will click.


#8

AP, you have to post logs to get help. I think we’ve had enough conjecture. Can you turn on logging in ASCOM for your mount as well and post those?

Since the rest of us aren’t having ASCOM issues, my guess is it’s either their driver or your localization. Have you reached out in their forums.

If you’re planning on moving to ACP perhaps the point is moot.


#9

Thanks for the reply, mads0100:
http://forum.mainsequencesoftware.com/users/mads0100

I don’t have any logs to post, unfortunately. I was trying to get help
mainly through this forum and Cloudy Nights. After searching through the
SB site it looks like I hadn’t brought this issue up previously in their
forum, thinking it was perhaps a software issue on SGP’s end. There may
have been a checkbox either in SGP or TheSkyX that prevented things from
somehow connecting, even though SGP did say connected mount connected under
Ascom on the SGP screen.

About suggestions regarding the Ascom driver, I wasn’t sure what was
happening there since during the ACP trial I was able to immediately
connect and move to different targets in ACP in Ascom just fine. Anyway,
not too big an issue at this point in the game since I’ve got ACP up and
running. Thanks again for the replies!

Grant


#10

Ok, guaranteed SGP made a log file. If you look under ‘help’ it has a pull down that tells you where the log folder is. If you can attach that here, we might get something out of it.

Can you setup inside? I’m assuming this isn’t permanent? If you can setup and just do some slews via SGP during the day with ASCOM logging enabled… Maybe we can figure out what’s going on.

My guess is it’s a setting though. We have lots of MyT users here.

Anyone else more familiar with Paramount’s care to chime in? :blush:

Anyways, like you said, it sounds like you’re gonna spend some money anyways on fancier software. If that’s your ultimate goal, I’d just work towards that.


#11

I can look for the log when I get home from work. It would be interesting to know what happened in the setup.
I have a permanent observatory, so it’s not feasible to setup inside.

I cannot slew or move the mount in any manner except for one function. If I tell SGP to park the scope, it will drive the scope all the way Eastward until it hits the pier. (Actually, the software limits in thesky prevent that, but the scope is counterweight high at that point).


#12

APshooter - are you homing the mount after connecting? Your last post strongly suggests to me that you have not homed the mount. When you connect a Paramount, it will not slew until it is homed. I think this must be it. Unless you tell the ASCOM driver to home on connect, although TSX boots up and connects, it will not home automatically. It would be a real shame to miss out on SGP.


#13

Hi Buzz.

Yes, SGP can and will home the mount, especially if the box ‘home on connect’ is checked. After it is homed, however, it seems like it is unable to slew to an object. The SGP controls say ‘connected to mount’ and the button is green.

I’m getting deeper into ACP at this point. I’m able to slew, plate solve and meridian flip with it. I think this is the path I’m going to take. I did go back and try to find my old logs to post, but they were deleted when I uninstalled SGP a month ago.


www.mainsequencesoftware.com