Number of Search Regions Bug


I guess I am getting a bit irritated. How many time have I set the regions to search at 200 and had it devolve to “Max Regions” during a meridian flip. Is this a hard problem to solve? Please relate why it is a hard problem to solve and I will be understanding. But it is a very, very irritating bug in SPG and makes a difference in quality of run when I am doing time series analysis.


This has been around for a very long time and unfortunately I see this all the time too. It has gotten to the point where I always check it before I start a sequence for the night. It seems like if I change the search regions at the start of a sequence then it sticks for the rest of the night.

At one point I thought this was being caused by using older sequences after updating to the latest version of SGP, but that has proven false. This seems to be very random and very hard to reproduce with reliability.


I usually check, just as you do. The problem is unattended meridian flips. That is what happened to me last night. My experience is that if the plate solve is not successful within the first 100-200 attempts it usually is not going to happen and that the blind solve is almost always successful. This I see no reason to have such a high number of tries. It might be easier to simply limit the maximum tries to something more reasonable, like 500 than to try to find and fix the bug.


PS. My selection of a default (100) does not stick through the session. It is usual that it changes from 100 to 3,000 between plate solves. Thus the desire to see the max set much lower if that is possible to do within SGP.



This also happens to me every single night. After discovering that it moved back to Max Regions somehow, I stop, set it again to 200 and it seems to stick for the rest of the night. But it does happens every time…


I’m not sure that we ever knew that it was a problem. At least I don’t recall hearing anything about it. Sounds as if the search region for for PS2 is getting reset randomly?




Perhaps a year ago, one of the SGP updates caused PlateSolve2 to change from its original max regions value of 999 to have a max regions value of 3000. Ever since, PlateSolve2 would randomly revert from whatever the setting was in Control Panel back to Max Regions. It did not make any difference what was in the Equipment Profile, Control Panel would reset to Max Regions. That in turn caused PlateSolve2 to open up with that 3000 regions setting. No matter how many times your changed Control Panel back to some value like 100 or 200, after a couple of uses PlateSolve2 would open up with the max regions reverted back to 3000.

Earlier this week, I finally got to use v3.01 on two nights with about 6 hours of imaging each night. I had Control Panel set to 100 regions and PlateSolve2 stayed at 100 all night – at least I do not remember seeing any other value.



Adding to what Charlie said, this bug was present before the change to 3000 regions. I’ve noticed this since at least 2016.


People don’t trouble to complain I guess, I do remember, that at least a year ago, this bug was mentioned on forums…
Anyways, experience from last night, me and two of my friends had experienced this again…ver. and 2.9.3.
Before running he sequence, I check the plate solve setting and make sure it set to 200 regions. Then I send mount to random place in the sky and do Solve and Sync. After it was completed I go back to plate solve setting to double check and find that that it set back to Max Regions by it self… Put it back to 200 and then it stick’s for the rest of the night.
But, If i do not check it and set it back for 200 and run sequence, it will be set at Max Regions on it’s own.


Thanks for your concern, Yes, it is a problem, as you can see from the responses. Not fatal, just irritating. I have not yet upgraded to V3, perhaps its fixed in that version, to be purchased soon.


Hi, I am planning to get a NUC to be used next to my scope for SGP, PHD2, QSI660 and Mach1 mount and trying to figure out if an I5 based NUC will show any difference with an I3 NUC considering that nothing else will be running.
I am mostly interested in image download time so I will use an SSD disk.
I’ll appreciate any experience that can be shared.


Given our purposes, I doubt you’ll see any difference between an i3 and i5
processor. Certainly the processor doesn’t have much to do with
downloading an image. I’d go for the i3, SSD, and as much RAM as the NUC
will accept (or you can afford).


Thank you Joel,
I was planning to have 8 Gb RAM but may be I should consider 16Gb, and an I3 NUC.


8GB would be more than sufficient. Actually, I didn’t know that NUC’s
could have more than 8GB.



The just now available quad core, Pentium based NUC is more performance than you need to effectively run SGP and all its supporting software:


Put in two, 4 gig memory modules and a 2.5" SSD drive (Samsung 860 EVO).

I have the prior version with a quad core Celeron and it performs great – the Pentium version is about 40% faster.



Good!, I will check this NUC


Here is a good review of the new Pentium based NUC:

YouTube review


I guess the good news for me is my plate solving problem after meridian flips is not all me. I’ve only flipped 3 times and was thrilled each time till the plate solve 2 attempted. Would someone share a screen shot of how they solved this. I created an equipment profile and never changed it. The last time I took a test frame/focus shot and saw my galaxy was still in the shot, just on the corner not the center. I was surprised it would not solve considering I was so close.

I’m using ver 3.0. Current settings I have are Search Max Regions, Binning 2x2, attempt to center 20 times, until error less than 50 pixel, use blind solve fallover is checked. Please tell me if I should change any of this.

Thank you, Amy


Has this been fixed yet? Same problem observed here. In my experience if PlateSolve 2 doesn’t finish after 200 regions, it rarely ever solves, so I waste a ton of time - would be better to just fail over to after 200.

But max regions in Plate Solve 2 seems to always revert to 3000, no matter what I try.



Unfortunately no, it has not been fixed. It’s entirely random for me. Sometimes it will revert back to 3000, other times when I start SGP it will stick with my default of 100. No idea why this happens.