Optec rotator and SGP


#1

i was shocked to find that optec’s ascom driver only supports one client. i noticed in another thread that @Andy wrote his own driver that supports multiple connections, but it seems like it won’t install on Windows 10. for now i’ll have to use optec’s hub in order to get PhD2 and SGP connected to the rotator.

does anyone have tips on using a rotator SGP? the documentation does not explicitly say but i think the angles in the program are sky angles. i’ve set my camera as close as possible to 0 degrees sky angle and then told the driver to reset the 0 position to that angle. does this seem like a reasonable strategy? or does SGP just treat all rotator moves such that making PA == sky angle wouldn’t matter?

also it looks like (from the online documentation) that there’s no filename keyword to indicate what side of the pier the OTA was on, nor are there keywords for the rotator position or sky angle. seems like this could be useful for matching flats. maybe these things are in the FITS header? i’ve never looked… for now i think i don’t care about flipping the camera over after a meridian flip but it would still be nice to see the sky angle at a glance in the filename.

thanks, rob


#2

That is news to me. I will look into it. I can only fix things if people tell me about them.

Andy


#3

There are keys for angle:

%ar = Angle in degrees according to the rotator (#.#)
%as = Angle in degrees relative to the sky (#.#)

There is not a key for Pier Side.

That is correct. Angles in SGP are sky angle since that is what will be used for mosaics and framing. SGP holds an internal offset from the Sky Angle to your rotator’s actual angle so there is no need to have them match up perfectly (or even close) unless you want that behavior. SGP does need to have a solve and sync initiated before the offset is stored.

Thanks,
Jared


#4

thanks, do you need any more info? i get a dialog box which is missing a string substitution (something like “product %s is incompatible…” but i don’t remember the exact words.


#5

thanks, i will add those keywords to my filenames. i suppose you might be able to infer the pier side from the angle? i’d have to play with it to see what happens. hopefully tonight i will actually be able to use the rotaor and see what happens.


#6

I addressed this topic in this thread:

In the case of a rotator used to find an OAG guidestar, the sky angle is secondary and you just want the rotator angle set exactly. You can do this with the optec rotator by using its own sync function to match its angle reading with the PA of the OAG.

Unfortunately I think that after it solves an image once, SGP will from then on use the sky angle to set the rotator for the next image - which is not what you want if the oag angle is slightly off from the image angle - which it often is. SGP figures out the offset of the sky angle from the rotator angle and corrects it for you - even if you just want to set the true rotator angle. So I think that the only way you can accurately set a sequence of images for a particular guidestar angle is if you mechanically match the oag angle with the sky angle - which is hard to do in my case since there is no fine control on setting the image angle - and you would want it to a fraction of a degree.

It is also often the case that for different images you would manually orient the imaging camera to frame the object - while using the rotator to set the guidestar. This would be a manual step for each object. A typical case would be to set the oag angle exactly for the guidestar - and then orient the camera approximately with north up. In all this the idea is that finding the guidestar is critical - but the image orientation doesn’t need to be exact. That isn’t the case for mosaics, but it is the case for a lot of imaging.

As for multiple connections to the rotator - Optec has an ascom hub that should allow this to work. I’m not sure why it isn’t built into the ascom driver - but I think it would work.

http://www.optecinc.com/astronomy/downloads/ascom_server.htm

Frank


#7

Optec’s ASCOM server is no longer necessary to have multiple ASCOM clients connect to its rotators or focusers. Just install the lastest ASCOM software from Optec’s web site for your device and you will have direct support for multiple ASCOM clients.

cm


#8

i think for my purposes i was not going to worry about this - i didn’t want to have to take flats at PA and PA+180, and given that i plan on hitting stuff that’s mostly in the plane of the milky way with 500mm, i figured that i’ll probably find guidestars on both sides of the target. but we’ll see. at long focal length with galaxy targets it could definitely be a problem.

pretty confused about that, since i downloaded the drivers last night. unless they have a double secret page where the new drivers are… this is a pyxis 2" rotator, so maybe that’s the problem - it’s kinda old. or do they have a universal driver that’s on another page? the driver here is what i downloaded: http://www.optecinc.com/astronomy/downloads/pyxis.htm

the pyxis LE driver looks pretty new in comparison. will this work vs. the pyxis 2"?

rob


#9

Rob,

I just tried installing on a Win 10 machine and it installed fine. The only thing I saw was that the anti-virus program thought it was suspicious (due to it being an uncommon download), so I had to explicitly tell the AV prog to accept it. Is it possible your AV is disabling some part of it? Perhaps try re-installing and make sure the AV does not do anything, or temporarily disable the AV while installing it?

Andy


#10

i don’t use any AV for this computer (besides what microsoft supplies) so i’m not sure AV was the cause…

i tried to install it twice last night with the same results. the machine is one of those new atom-based compute sticks with 32-bit W10 installed. i’ll try it again and post a screen capture; is there a log someplace that might shed some light on what went wrong?

i did uninstall it from the Applications control panel and when it was finished it said there were some files that were not removed. the installer itself does not seem to have an “uninstall” option.

thanks

rob


#11

well, i am at a loss, here is the error dialog given while trying to install @Andy’s rotator driver:

attempting to run that program from the file explorer pops up a fullscreen dialog saying that the software is not compatible with my machine. i think the expected behavior would be for it to give a regular dialog saying “this is an ascom driver, not a program for you to run”…

i looked in the Event viewer for logs created around the time i tried to run the executable and while there are some logs, they don’t really say anything about why the program won’t run.

this is 32-bit windows home.

rob


#12

Ok, that has got to be the problem. I have only ever tested it on 64-bit windows. Let me see if I can get it working for 32-bit Windows.

Andy


#13

OK thanks. i thought maybe it might be something like that but i don’t know how to test the architecture of a binary on windows… anyhow no rush, whenever you get to it is OK.


#14

If chasmiller46 is correct - then the optec’s normal ascom driver should allow multiple clients and you don’t need anything else. I didn’t realize this - and it’s great if it works. I’ll give it a try when I can.

Frank


#15

i have to assume @chasmiller46 is actually using the pyxis LE driver because when i tried to connect PHD2 to the rotator, i got an error message stating the com port was in use. that came as kind of a shock since it seems like most ASCOM drivers these days have ‘hub’ capability built in.


#16

Rob,

Here is an updated version that should run on both 32-bit and 64-bit Windows. I do not have a 32-bit machine to test on, so I could only test on a 64-bit windows pc. Let me know if it works for you.

http://adgsoftware.com/ascom/PyxisAG_Setup-0.4.exe

Andy


#17

thank you andy, i will try this out this evening.


#18

this installed fine and seems to work OK! however, i don’t yet have my head around rotator angles and how SGP/PHD2 handles them. rotation of the calibration vectors does not seem to be working - if i rotate after i’ve calibrated, i get runaway RA guiding, E or W depending on whether or not “reverse sign of angle” is checked in PHD2. i didn’t try with the optec server/optec driver so i can’t say if this is related to OptecPyxisAG or is some generic config probem i have in PHD2.

rob


#19

Rob,

Glad to hear the driver installs and runs.

PHD2 should be handling the rotation and guiding properly after the rotation so we’ll need to investigate to see why it is not working for you. Please try the following:

  1. calibrate PHD2
  2. guide for a few guider frames
  3. stop guiding
  4. rotate by some amount, approximately some multiple of 90 degrees (+/- 90 degrees or 180 degrees) to keep the analysis simple
  5. start guiding again

if you see runaway guiding, repeat the steps 1-5 with the “Reverse sign of angle” option checked. If you still see runaway guiding, send me your PHD2 guide log and debug log.

Andy


#20

your steps are exactly what i did. i did a lot last night so it will be hard for me to isolate all the logs. weather permitting i’ll start tonight with these steps and send you the log.

rob


www.mainsequencesoftware.com