PHD (1) is still supported, yes?


#1

“Sequence Generator Pro does not have a built in auto guider. Rather it uses the following 3rd party auto guiding software
•PHD2 (aka Open PHD Guiding) - Website. PHD2 guiding graph is also available in the PHD Graph Module”

I have found PHD2 is not compatible with certain mounts I have yet PHD(1) is good, but in setting up the autoguider within SGP, ‘PHD’ is not listed (but PHD2 is). There is a path within the PHD2 Connection Settings, if this path has PHD(1).exe there it will use PHD(1) and life is good?
Thanks


#2

@Apache-Sitgreaves, could you tell us what mounts you have that are not compatible with PHD2? I am not aware of any mounts that work in PHD1 but not in PHD2. If there is a compatibility problem, we’d like to address it.


#3

Thanks Andy, that is reassuring.
I opened PHD2 and tried to connect to a iOprton CubePro and a pop-up box stated something like this “This mount does not support pulse guiding.” and would not connect. So I posted the inquiry. The mount and Canon 60D, and SSAG are sitting on the kitchen counter as I get everything set up. I did put PHD(1) into the destination folder but no joy. I did drop PHD2 back in there and it did connect, at least no pop-up box, but as it’s on the counter I don’t know yet it actually does something…
Steven


#4

The mount might not support pulseguiding through the ASCOM interface, but you can probably still autoguide using the ST4 connector.


#5

Hi Steven,

Do I understand correctly that it is working now? If in doubt you can upload your PHD2 debug log to the PHD2 forum (PHD2 log file upload instructions) and we can look at it in more detail.

Connection issues aside, I believe the CubePro is an alt-az mount, right? If that is the case then you are going to have field rotation problems trying to use it for imaging (details here), unless you have it on an equatorial wedge.

Andy


#6

The iOptron has a second port said to be used for SSAG, but what concerns me about what you said is ‘mount might not support pulseguide through ASCOM interface’.
The other mount getting an Equipment Profile created is ServoCat with a built-in ST-4 port and there is a ASCOM driver made by Peter Eschman. People have had no issues getting SSAG guiding alt-az using PHD(1), field rotation issues aside. If PHD(1) works for ServoCAT, then 2 should work but what is the pulseguide problem through ASCOM?
Thanks, Steven


#7

Hi Andy, I will hunt for the log, but still on the kitchen counter while things get set up no stars but possibly connection. And, yes, aware of field rotation.

Regarding ASCOM pulseguide issue, ServoCat has a dedicated ST-4 port and an ASCOM driver and people connect PHD(1) and guide alt-az no issues with calibration (only field rotation), but am I going to find there’s a problem with needing ASCOM (for which there is a driver for SC) but pulseguide issues prevent operation? I went to the tab for setting up the telescope, chose generic hub. Within the generic hub there is a ASCOM Telescope Chooser, clicking on Properties it does nothing… Please advise on set up for ServoCat for ASCOM, etc?
The goal is;
Goto, plate-solve, center, set up guiding, image, release guide star, repeat.
I am hopeful this sequence can work in SGPro.


#8

If you want to guide through the mount’s ASCOM driver, then the ASCOM driver would need to provide the pulse guide capability. This is a required for both PHD(1) and PHD2 (and any other guiding app for that matter.) If the ASCOM driver does not provide Pulse Guide capability (and not all of them do) then you can use ST4 guiding as @naavis said. To use ST4 guiding you would connect the ST4 cable that came with your guide camera from the ST4 port on the camera to the ST4 port (aka guide port) on the mount. Select “On-camera” as the mount in PHD2, and you should be good to go. Be sure to re-calibrate periodically since the camera angle on the sky will be rotating, and your guider calibration will slowly go out of sync and guiding will eventually fail if the camera rotates too far from the angle it was at when calibration was done.

HTH,
Andy

P.S. if you have any more PHD2 connection questions or PHD2 equipment compatibility questions, feel free to post in the PHD2 Forum.


#9

Thanks, Andy, if I have specific PHD questions I will join that Google group.
To confirm the above, within SGPro, in the Equipment Manager choosing PHD within the Autoguider tab, this enables PHD and inside the actual PHD software I must set it to On Camera, yes? That both CubePro and ServoCat have a dedicated ST-4 port means no ASCOM driver needed to operate the guiding feature within SGPRo, yes?
Thanks, Steven


www.mainsequencesoftware.com