PHD2 Profiles Problem in beta 2.4.3.0


#1

This is going to a bit vague because I have not locked down the exact sequence of events that causes the problem, however, this is the approximate steps. I have two equipment profiles. I went to the first one and successfully set the PHD2 directory and profile (and saved the equipment profile). Then I went to the second equipment profile and clicked on the PHD2 Set button. It had the PHD2 directory but not the populated profiles. (Shouldn’t they be available from the first usage?) (Might I suggest that the Refresh button should not be necessary. Populate when the Set button is clicked or when the directory is changed with appropriate error checks.) I clicked on Refresh and on some occasions it would time out trying the populate the dropdown. I was eventually able to select and save the second PHD2 profile. I then switched to the first equipment profile and the PHD2 profile was not there, however, on restarting SGP it was in the profile. There seems to be some interaction problem between PHD2 profiles when switching between equipment profiles.


#2

Going to ignore reports on these features for 2.4.3.0 and 2.4.3.1 as the code driving has changed to a degree that invalidates any current complaints. I am not claiming the new methodologies are in perfect working order, just that they are apples and oranges now.


#3

No, I think it is probably useful for those adding new profiles to PHD2 in real time. Other than this condition, it should not be necessary.


#4

I considered that possibility, however, I wonder if a user is going to add a PHD profile while the set dialog is open? If clicking the Set button populated the dropdown, that would cover almost normal usage. The Refresh button is a bit confusing in this context so it is a balance between its usefulness and understandability. Of course, your call.


www.mainsequencesoftware.com