PHD2 receives error downloading after SGP stops and tries to start PHD2


#1

I have been unable to use SGP with PHD2. In almost every instant, PHD has a download error from my SBIG ST-i after being stopped and started by SGP.

The problem process is:

  1. Slew to the target.
  2. Start PHD2 and calibrate (this is successful)
  3. Start a sequence.
  4. SGP stops PHD2 for the plate solve.
  5. Successful plate solve and SGP attempts to start guiding
  6. PHD2 fails to start
  7. I go to PHD2, which has a download error and disconnected the camera. At this point the camera will properly connect. I remove the USB cable and reconnect.

This happens each time.

I finally give up and use PHD, Nebulosity and Astrotortilla to get the image data. PHD works without errors. However, if I do not disconnect and reconnect the USB, PHD also has download errors. It seems as if the commands are causing the ST-i to go into a strange state.

I don’t know if this is a PHD2 or SGP problem. I was using the latest version of PHD2 and even tried the beta version. I remember that SGP required a minimum of 2.4.1e and the SGP log shows that this is tested for. Should I revert to 2.4.1.e?

Regards,

Charlie


#2

Hi Charlie,

Both SGP and PHD2 produce comprehensive debug logs. Instructions for getting the PHD2 debug log are here. Instructions for the SGP logs are here.

Without seeing the debug logs we can only speculate, so please post your debug logs.

Andy


#3

PHD2_DebugLog_2015-08-16_204152.txt (370.8 KB) sg_logfile_20150816203539.txt (196.3 KB)

Sorry! I forgot to upload.

Charlie


#4

Hi Charlie,

Thanks for the logs. The PHD2 log shows that the SBIG driver is returning an error when PHD2 tries to download the frame from the camera. The error shows up intermittently.

I’m not sure what could be causing this or why you only see the error with SGP/PHD2 and not with Nebulosity/PHD (PHD2?). Is it possible that there is a loose connection on the USB cable? Have you tried using a different USB cable or tried using a different USB port on the PC? You could also try eliminating any USB extension cable or USB hub between the camera and the PC.

On the PHD2 forum we frequently get reports of cables that stop working and problems being solved when the cable is replaced. This has happened to me too when I had a USB port on my laptop that would disconnect if the cable wiggled even the tiniest amount. Also, I fasten my USB cable to the body of my guide cam (Lodestar) with a loop of velcro so that the connector cannot wiggle as the scope slews.

Hope that helps.

Andy


#5

I tried all of the above. New cable, different ports and no extension. Same happened each time. Even tried rubber banding the cable. Why would a cable work fine with PHD and not PHD2?

Charlie


#6

Don’t forget about removing any usb hubs in between the camera and computer.

Also, when I had an SBIG camera I would sometimes get these kinds of download errors on older drivers. I never could determien what caused it or triggered it, but after trouble shooting with the SBIG driver author it had something to do with timeout errors. Updating the driver fixed it for me…but a short time later I sold the camera. :smile: Make sure your camera driver is up to date.


#7

It’s not likely to be a difference between PHD and PHD2 since the code that interfaces with the SBIG driver is essentially identical between PHD1 and PHD2. I would rather suspect that the problem is sensitive to the amount of USB traffic, and perhaps there is more USB traffic when using the SGP/PHD2 combination.

Just curious, have you tried the Nebulosity + PHD2 combination? That should give us some more data about whether the issue is related to some PHD1/PHD2 difference.

Also, have you tried updating to the latest SBIG drivers? The release notes for the 6/25/2015 version mentions something about stability fixes for USB though it’s hard to tell if that is at all relevant.

Andy


#8

I did a driver update recently, which showed that the drivers were up to date, but I will try another. However, I did not try Neb and PHD2. I normally use a powered hub, but I tried a direct connect and got the same problem. It’s cloudy now and I may have to wait a few days to try other methods. Thanks for the ideas.

Charlie


#9

I double checked the drivers and they were up to date. However, the second tab, check firmware, showed that my firmware was not up to date. It is now and I hope this solves the problem.

Regards,

Charlie


www.mainsequencesoftware.com