Plate Solve Aborts after "Solve & Sync"


I have been careful to get all my settings correct in the equipment profile (saved and applied to sequence).

Everything looks great, but when I slew to a bright star to get started and try to “Solve and Sync”, the Plate Solve process aborts after taking the image.

I am using ASTAP and I have the (local) environment all set up for blind solving as a backup.

I am sure I still have some setting incorrect … any ideas of where I should look? Or should I use a shorter exposure time (this image was 30 sec @ 1600 ISO).

Approx time of issue: 20:12

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

What do the stars look like ?? Even when I use a Canon DSLR, I shoot much shorter exposures, 10~15 @ iso 400…

Have you tried loading an image into SGPro, right clicking on it & selecting Plate Solve ?

Thank you Dr …

I work from a Bortle 8 site (my backyard in Scottsdale, AZ, USA) and have had no luck with shorter exposures. Here is an image of M45 shot at ISO 1600 for 30 sec.


I have loaded this image into SGP and ASTAP failed, but was able to blind solve with Astrometry.Net (Local). My troubles have been with using the “Frame and Focus” and “Solve and Sync” routines.

As for the length of the exposure I can’t imagine 30 seconds would be a problem. These plate solvers works with fully integrated images at 10, 15 and 20 minutes all the time with no problem. That said, you can probably get away with 10 (for broadband or OSC).

In terms of the failure here, what is happening is that there is a failure with ASTAP (likely due to hints being too far away from actual location), then the blind solver kicks in and immediately fails due to having no internet connection. If your intent is to use the local Astrometry.NET (ANSVR), your sequence is not set up that way.

The position from the image header and send as command to ASTAP and the solution are too different. In RA 8 hours and in DEC 24 degrees. See attached screenshot.

ASTAP can solve it but it requires maybe 2 to 3 minutes to reach this position. It searches in a spiral around the start point. In this case the startpoint is RA=11.983, DEC=0.112 and it has to reach RA=3:47 and DEC=24:05 before it can find a solution.


ASTAP can do blind solve but 2000 regions is too short. You should set in SGP the regions to maximum. ASTAP will reach then 40 maybe 50 degrees from the start pointRA=11.983, DEC=0.112 before SGP will stop it on a timeout, so increase the number of regions will not help with this huge offset.

So the problem is the initial position in the image. Try to set the mount position correctly before taking an image.

Here a link to the solve images at


Thank you Ken,

I have been fiddling with several of the settings while working through this. I originally had blind solve for “Local” but changed it while testing. I have set it back to “Local” in all equipment profiles and have also reset the search to “Maximum”

What I have been trying is using my AVX mount’s hand controller, or the CPWI app to slew to a target (assuming it would get fairly close). Then using SGP to “Solve and Sync” that location. I then load the coordinates for my target in the sequence and have a go at it.

Lastly, I have successfully run the “Framing & Mosaic Wizard” … capturing a single frame.

I very much appreciate the support from both you and the community. It looks more and more like SGP will become one of my key imaging tools.