Plate solve on image centre does not correctly wait for frame download if camera not at temperature


#1

Hi,

I just ran into this. If the main camera is not at temperature then the plate solve fails because no image was downloaded. It should wait till the camera is within limits of the set point then take a frame to solve rather than hoping that the image was downloaded.

This seems to be another issue with not waiting for a successful image download. Is SGPro using timing to detect that an image has been successfully captured or using a camera status message ?

Thanks
Robert


#2

This is not normal behavior. It is beyond me how those 2 things could be connected in any way unless, for some reason, your camera does not want to deliver image data while it’s cooling. This would be driver dependent (I can assure you that most cameras do not have a restriction like this). If it is a restriction for you, you will need to wait for your cooling period to end or contact your driver’s author.

Either way, it’s all just speculation without logs.


#3

I’ve never seen it get past the cooling stage when it wasn’t supposed to.


#4

Yes strange I agree, perhaps it is an error from the camera API.

Note the Camera temperature is correctly shown on the Cooler Panel.

I believe this log extract shows the problem happening:

[18/02/2016 19:59:58] [DEBUG] [Telescope Thread] Adjust focuser pos per filter: Moving focsuer to focus position (2804)…
[18/02/2016 19:59:58] [DEBUG] [Telescope Thread] Focuser moving to 2804
[18/02/2016 19:59:58] [DEBUG] [Telescope Thread] Focuser move call complete
[18/02/2016 19:59:59] [DEBUG] [Telescope Thread] Focuser position matches requested position (2804), continuing…
[18/02/2016 19:59:59] [DEBUG] [Telescope Thread] focuser move is complete…
[18/02/2016 19:59:59] [DEBUG] [Telescope Thread] Moving filter wheel, isMoving, check 2…
[18/02/2016 19:59:59] [DEBUG] [Telescope Thread] Moving filter wheel, isMoving, check 2 complete…
[18/02/2016 20:00:00] [DEBUG] [Telescope Thread] Performing auto center step 1…
[18/02/2016 20:00:00] [DEBUG] [Telescope Thread] Skipping step 1…
[18/02/2016 20:00:00] [DEBUG] [Telescope Thread] Auto center reference frame solved successfully…
[18/02/2016 20:00:00] [DEBUG] [Telescope Thread] Performing auto center step 2…
[18/02/2016 20:00:00] [DEBUG] [Telescope Thread] Created full file name (file does not exist): C:\Users\robert\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[18/02/2016 20:00:00] [DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE message received…
[18/02/2016 20:00:00] [DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame…
[18/02/2016 20:00:00] [DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame…
[18/02/2016 20:00:00] [DEBUG] [Camera Thread] ASCOM (QSI) Camera: setting gain to HIGH…
[18/02/2016 20:00:00] [DEBUG] [Camera Thread] ASCOM (QSI) camera: setting normal speed readout…
[18/02/2016 20:00:01] [DEBUG] [Camera Thread] ASCOM (QSI) Camera capture. : Cannot Start Exposure
at QSICameraLib.CCDCameraClass.StartExposure(Double Duration, Boolean Light)
at p3.au(cx A_0, hn& A_1)
[18/02/2016 20:00:01] [DEBUG] [CP Update Thread] ASCOM (QSI) Camera: Error in GetCoolerTemp. : Camera Error
at QSICameraLib.CCDCameraClass.get_CCDTemperature()
at p3.fb()
[18/02/2016 20:00:01] [DEBUG] [Camera Thread] ASCOM (QSI) Camera: Attempting to abort exposure…
[18/02/2016 20:00:01] [DEBUG] [Camera Thread] ASCOM (QSI) Camera: Error when trying to abort exposure. : Camera Error
at QSICameraLib.CCDCameraClass.get_CanAbortExposure()
at p3.av()
[18/02/2016 20:00:01] [DEBUG] [CP Update Thread] ASCOM (QSI) Camera: Error in GetCoolerPower. : Camera Error
at QSICameraLib.CCDCameraClass.get_CoolerPower()
at p3.fc()
[18/02/2016 20:00:01] [DEBUG] [Camera Thread] Error saving QSI image. : Camera Error
at QSICameraLib.CCDCameraClass.get_MaxADU()
at p3.a1(b A_0, List`1 A_1)
[18/02/2016 20:00:01] [DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE complete…
[18/02/2016 20:00:02] [DEBUG] [CP Update Thread] ASCOM (QSI) Camera: Error in GetCoolerTemp. : Camera Error
at QSICameraLib.CCDCameraClass.get_CCDTemperature()
at p3.fb()
[18/02/2016 20:00:05] [DEBUG] [Telescope Thread] Capture complete, attempting to plate solve image C:\Users\robert\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[18/02/2016 20:00:40] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[18/02/2016 20:00:40] [DEBUG] [MF Update Thread] Performing serialize…
[18/02/2016 20:00:59] [DEBUG] [PHD2 Listener Thread] PHD2 - No messages received from PHD2 for 1 minute, checking socket with status…
[18/02/2016 20:00:59] [DEBUG] [PHD2 Listener Thread] Checking PHD2 state…
[18/02/2016 20:00:59] [DEBUG] [PHD2 Listener Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[18/02/2016 20:00:59] [DEBUG] [PHD2 Listener Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[18/02/2016 20:00:59] [DEBUG] [PHD2 Listener Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[18/02/2016 20:01:05] [DEBUG] [Telescope Thread] Failed to plate solve reference frame because it does not exist. C:\Users\robert\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[18/02/2016 20:01:12] [DEBUG] [Sequence Thread] Recovering the sequence (when centering the target)
[18/02/2016 20:01:12] [DEBUG] [Sequence Thread] Handling monitoring event (Good Night System, Warning): (NGC2023_NB) Something has gone wrong when centering the target
[18/02/2016 20:01:12] [DEBUG] [Sequence Thread] GNS: Sent warning message to GNS ((NGC2023_NB) Something has gone wrong when centering the target)…
[18/02/2016 20:01:15] [DEBUG] [Sequence Thread] Sequence recovery failed (Centering)!
[18/02/2016 20:01:15] [DEBUG] [Sequence Thread] Handling monitoring event (Good Night System, Error): (NGC2023_NB) Sequence recovery failed (Centering)!
[18/02/2016 20:01:15] [DEBUG] [Sequence Thread] GNS: Sent error message to GNS ((NGC2023_NB) Sequence recovery failed (Centering)!)…
[18/02/2016 20:01:15] [DEBUG] [Sequence Thread] Error on auto center, aborting sequence!
[18/02/2016 20:01:18] [DEBUG] [Sequence Thread] DoEventGroupChange: Error in auto center (False)
[18/02/2016 20:01:18] [DEBUG] [Sequence Thread] DoEventGroupChange: Complete
[18/02/2016 20:01:18] [DEBUG] [Sequence Thread] Cannot start seqeunce. EventGroupChange failed.
[18/02/2016 20:01:18] [DEBUG] [Sequence Thread] Clearing timed monitoring events…
[18/02/2016 20:01:18] [DEBUG] [Sequence Thread] Checking RunEndOfSequenceEquipmentOptions, force = False
[18/02/2016 20:01:18] [DEBUG] [Sequence Thread] Sequence was aborted, skipping end of sequence options…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Aborting sequence timer thread…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Aborting recovery thread…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Sending sequence end notification…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Handling monitoring event (Good Night System, Status): (NGC2023_NB) Sequence has ended
[18/02/2016 20:01:18] [DEBUG] [Main Thread] GNS: Sent status message to GNS ((NGC2023_NB) Sequence has ended)…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Resetting UI elements…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Checking if sequence has work left…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Work left…
[18/02/2016 20:01:18] [DEBUG] [Recovery Killer Thread] Closing recovery dialog…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Updating big status…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Enabling menu items…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Set target icons…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Removing camera protection…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] Monitoring system shutdown…
[18/02/2016 20:01:18] [DEBUG] [Main Thread] SequenceEnds complete…


www.mainsequencesoftware.com