Plate Solve stopped working abruptly


#1

Plate solve has become unavailable on my system. I was using images taken with SharpCap and opening them from the Plate Solve dialog and entering the proper scale and approximate position. I am curious as to why the image context menu has plate solve disabled, yet slew here is not – even though my mount is not even connected.

I have plate solved many times with no equipment connected and the plate solve dialog just closes when I am trying to load an image. Also, I don’t know why I get no logging for plate solving. There is only one log file and that was from a week ago.

I see no changes to the date on any files in the SGP folder, and yet – I cannot plate solve any more at all.

What am I missing, here?

For some reason, the second image is not uploading, however – the Open Image menu selection in Plate Solve never brings up the dialog any more – it just closes abruptly, now. That – is new.

See image #2 in reply below

This image is a successful plate solve of the same image – M44.


#2


#3

Okay, I have taken the next step in solving this myself. I used the debugger in VS2017 and attached it to PlateSolve2.exe…tried to open an image and – caught an exception. It is not much because PS2 is a release build and there is no PDB to help the debugger. However – given programmer’s warped sense of humor – it seems as if the Java runtime might be causing the issue.

Is SGP written in Java? Is PS2 written in Java? DEADCAFE seems to point to the Java Runtime to me.

Would someone please assist me, here? I am doing my due diligence and simply asking for help.


#4

Plate Solve 2 works when I use .NET to run it from within a WinForms app. I suppose that next, I will comb my registry for SGPro settings. I have also opened a ticket at Plane Wave Instruments, although that seems to be a dead end, since Plate Solve 2 works outside of SGPro.


#5

You say PS2 runs outside of SGP, but If you are running PS2 outside SGP then you probably have the application downloaded, but you shouldn’t have this, and should be running the version built in to SGP, only then downloading the catalogues from Planewave.


#6

Ray,
Sorry for the confusion. I have all of that configured. I was running PS from within SGP until two weeks ago. I also have it working fine on a Windows 7 machine. I am suspecting Windows 10 to be the issue. When I attempt to open an image within SGP…using the PS open file menu option, the open file dialog never appears on the Windows 10 machine now. It worked fine before.

Thanks for responding. I appreciate that a lot. Still troubleshooting…I’ll get it sussed out eventually.

⁣Sent from BlueMail ​


#7

No problem. That is odd as I run W10 on 3 machines with varying levels of updates, and all work fine with PS2. I can only assume it is something specific to your setup, but not something I’ve seen or heard of.


#8

It might also have something to do with the fact that the OCX control SGP uses is 20 years old and written for Windows98 era machines.

I suppose I will use my Lenovo for SGP and find another sequencer for the Asus.


www.mainsequencesoftware.com