Plate Solve won't stop

I’ve been a subscriber for numerous versions, and never posted. I came and did some searches - I don’t see a thread on this.

Why is it so difficult to stop a plate solve? Occaisionaly I see I erred in some way (for instance I accidentally have the wrong filter in), and I just want plate solving to stop - but it won’t. Even when I select ‘abort solve’ (in plate solve tab on control panel) or ‘done’ (when centering) it ignores my selection and keeps going.

It is a source of endless pain using SGP. This is one of those small annoyances that totally distracts and makes using the product distasteful.

Is there some option, setting, anything that will get SGP to stop when I tell it to stop?

I can’t get it to start! I wanted to check my camera angle so I did a 2 second exposure and went to right click/ plate solve and the option was ghosted out. I tried everything I could think of. Went back to previous build and it worked fine.


What version are you using? What plate solver are you using? If it’s PlateSolve2, there can be some issues with that as that plate solver is not meant to be “used” by another application.

I have seen this on every version I have tried - it has been an issue for a very long time. Once it starts to solve and fails, it goes to blind solve and if you try to stop it it seems to lock up and will not respond to a cancel. I have had to go to task manager more than once and kill SGP and start over. It appears to me that it will not cancel once it starts a blind solve failover.

So… We’re talking about aborting ansvr or maybe During a sequence? Manually?

Hi Ken! Thanks for replying.

As CCDMan mentions, usually this is what I end up doing also - just killing the entire SGP process. This is a major bummer because I lose the cooler on my camera and have to restart my processes including slow cooling the camera over many minutes (usually 20) to avoid any condensation.

I use PlaneWave PlateSolve 2 solver primary and Ansvr/ locally for blind as backup. Yes, this would mean basically killing only those threads if possible but keeping SGP main thread/process going. Anytime in the UI the user selects to end a process, it should be immediate. I see this behaviour in the core plate solving options from within the control panel, and also in the centering functionality driven from the sequence.

Well sure… this is not intended behavior.

We’ll meet in the middle here and say “as fast as possible”.

I will take a look. Some changes have been made to PlateSolve2 recently in order to produce more reliable solves… not sure about ANSVR.

@cfichter @CCDMan

With SGPro 3.1 beta, both manually and as part of the sequence centering routine, I have allowed PS2 and ANSVR to start solves they could not succeed with or that would take a really long time. In all 4 attempts there was no problem aborting. I did not test this in 3.0. So… if you are seeing this in 3.1, I am hoping for very detailed reproduction steps (because we are doing something differently).

Is it possible that you are attempting to stop the solve by clicking “Stop Search” in the PlateSolve2 application? This won’t actually work to abort what SGPro is doing.


In order to stop a manual solve, you will need to click “Abort Solve” in the Image Toolbar:

In order to stop a solve that is part of a centering routine, you will need to click “Abort” on the centering dialog.