Plate solve wont work after re-install and ports misshape


#1

Hi! So here’s the thing. Platesolving was working just fine, but I misunderstood something regarding the offline plate solving. So eventually I re-installed everything and change the port number from the default 8080 to 8081 since i wrongly understood that the port had something to do with my offline solving cappabilities… The thing is, when I tried plate solving again it didin’t work. It did capture the plate solve image but when it starting solving it it failed everytime. It did have enought stars in the region, and just in case you wonder, the object is M83.
So I went into the config file for the blind solve failover and it didn’t load (http://127.0.0.1:8080/api/config) . The address on the URL that pops up was not 8081, but 8080. Tried changing the URL to see if that would load the config page, and it did. But still didn’t solve. Tried re-installing it again and going back to 8080 port but still doesnt work. How do I go about it?
Thanks in advance! I’m really stuck

The camera is an ASI1600 MM and the software is SGPRO 2.6

Here are my logs from last night. I’m attaching the whole log and here’s the part where i tried solving

[02-11-18 21:46:32.645][DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE complete…
[02-11-18 21:46:32.746][DEBUG] [Telescope Thread] Auto center verification frame complete. Plate solving image C:\Users\Guillo\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[02-11-18 21:46:32.852][DEBUG] [Telescope Thread] ************* SOLVE HINTS ****************
[02-11-18 21:46:32.852][DEBUG] [Telescope Thread] SOLVER: PlateSolve2
[02-11-18 21:46:32.852][DEBUG] [Telescope Thread] BLIND: False
[02-11-18 21:46:32.852][DEBUG] [Telescope Thread] METHOD: 100 Regions
[02-11-18 21:46:32.852][DEBUG] [Telescope Thread] RA: 5.68534008434385
[02-11-18 21:46:32.852][DEBUG] [Telescope Thread] DEC: -2.19457816694192
[02-11-18 21:46:32.854][DEBUG] [Telescope Thread] SCALE: 2.07993
[02-11-18 21:46:32.854][DEBUG] [Telescope Thread] ******************************************
[02-11-18 21:46:34.270][DEBUG] [Telescope Thread] FitsFileHeaderData: Angle - 0
[02-11-18 21:46:34.270][DEBUG] [Telescope Thread] FitsFileHeaderData: Scale - 0
[02-11-18 21:46:34.285][DEBUG] [Telescope Thread] FitsFileHeaderData: RA - 5.68534151695866
[02-11-18 21:46:34.301][DEBUG] [Telescope Thread] FitsFileHeaderData: DEC - -2.19459958734691
[02-11-18 21:46:34.312][DEBUG] [Telescope Thread] PlateSove2 Param: RA (RAD) - 1.48841855351118
[02-11-18 21:46:34.312][DEBUG] [Telescope Thread] PlateSove2 Param: DEC (RAD) - -0.0383026147055183
[02-11-18 21:46:34.312][DEBUG] [Telescope Thread] PlateSove2 Param: Width - 2328
[02-11-18 21:46:34.312][DEBUG] [Telescope Thread] PlateSove2 Param: Height - 1760
[02-11-18 21:46:34.312][DEBUG] [Telescope Thread] PlateSolve2 Command Line:
[02-11-18 21:46:34.312][DEBUG] [Telescope Thread] C:\Users\Guillo\AppData\Local\SequenceGenerator\PlateSolve2.exe 1.48841855351118,-0.03830261470552,0.02347505193978,0.01774746194760,100,C:\Users\Guillo\AppData\Local\SequenceGenerator\Temp\psXSolve_0.fit
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] *********** SUCCESSFUL SOLVE *************
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] SOLVER: False
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] SUCCESS: False
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] CONF: 0
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] BLIND: False
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] RA: 0
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] DEC: 0
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] SCALE: 0
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] FLIPPED: False
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] ANGLE (EON): -500
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] MSG: PlateSolve 2 failed! No APM file found.
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] ******************************************
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] Auto center validation frame failed to solve. PlateSolve 2 failed! No APM file found.
[02-11-18 21:46:49.879][DEBUG] [Telescope Thread] Auto center validation frame solve failed, invoking blind failover…
[02-11-18 21:46:49.880][DEBUG] [Telescope Thread] Astrometry.NET: Sequence endpoint data: Astrometry.NET (Remote)
[02-11-18 21:46:49.881][DEBUG] [Telescope Thread] Astrometry.NET: Sequence endpoint data: Astrometry.NET (Remote)
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] ************* SOLVE HINTS ****************
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] SOLVER: Astrometry.NET
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] BLIND: True
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] METHOD: 100 Regions
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] RA: 5.68534008434385
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] DEC: -2.19457816694192
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] SCALE: 2.07993
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] ******************************************
[02-11-18 21:46:49.907][DEBUG] [Telescope Thread] Astrometry.NET: Sequence endpoint data: ANSVR (Local Astrometry.NET)
[02-11-18 21:46:50.056][DEBUG] [Telescope Thread] Astrometry.NET convertedAstrometry.fits path: C:\Users\Guillo\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[02-11-18 21:46:50.056][DEBUG] [Telescope Thread] Astrometry.NET - File is too large, resizing
[02-11-18 21:46:50.086][DEBUG] [Telescope Thread] Astrometry.NET - Saving file
[02-11-18 21:46:50.086][DEBUG] [Telescope Thread] SaveFileBmp16: Locking bitmap for disk write…
[02-11-18 21:46:50.086][DEBUG] [Telescope Thread] SaveFileBmp16: Opening file stream…
[02-11-18 21:46:50.086][DEBUG] [Telescope Thread] SaveFileBmp16: Writing FITS headers…
[02-11-18 21:46:50.087][DEBUG] [Telescope Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[02-11-18 21:46:50.181][DEBUG] [Telescope Thread] SaveFileBmp16: FITS block fill…
[02-11-18 21:46:50.181][DEBUG] [Telescope Thread] SaveFileBmp16: Unlocking bitmap…
[02-11-18 21:46:50.181][DEBUG] [Telescope Thread] SaveFileBmp16: Closing file stream
[02-11-18 21:46:50.185][DEBUG] [Telescope Thread] Astrometry.NET using endpoint: http://127.0.0.1:8080/api/
[02-11-18 21:46:50.185][DEBUG] [Telescope Thread] Astrometry.NET - Calling Async Solve
[02-11-18 21:46:51.240][DEBUG] [Unknown] Exception in Astrometry.NET Solver: No es posible conectar con el servidor remoto
[02-11-18 21:46:51.241][DEBUG] [Unknown] Astrometry.NET solve done in 0 seconds.
[02-11-18 21:46:52.187][DEBUG] [Telescope Thread] Astrometry.NET - Solve Completed
[02-11-18 21:46:52.187][DEBUG] [Telescope Thread] Astrometry.NET - Failed to solve image.

sg_logfile_20180211214415.txt (141.4 KB)


#2

If I understand correctly and you were able to get to the config page using port 8081 (http://127.0.0.1:8081/api/config), then we know for sure ansvr is listening on port 8081. The key thing now is to get SGP to send its requests to port 8081. The log fragment shows SGP sending to port 8080.

You’ll need to copy and paste the following value into the Astrometry.net End Point Setting in SGP:

http://127.0.0.1:8081/api

like this:

image


Can't Get ANSVR to Blind Solve - "Can't Set Up Server"
#3

Hey, I don’t get the Other Plate Solve Options menu anywhere! Still, what I did was to re-install it all over again and asign the port 8080, so now it does load up the URL. Still cant be sure if it works since the simulator doesnt work for me (gives me a wrong tracking state error) so I’ll have to wait to get back out there to try it out. Thanks for your reply!!


#4

Actually, you can test it any time by loading any old sub (menu File > Open Image), right-click on the image, select Plate Solve, then Blind Solve.


#5

Didn’t know that. I tried it. Still doesn’t work. No match and it takes really long to try the solve. Before it was a couple of seconds. Now it’s taking longer. Neither the normal plate solve nor the blind worked. BUT, I did try it on a different target and did work. Thats extremely odd, since I’ve been able to resolve m83 lots of times before. Those images, the ones from previous nights on m83 are able to solve without issues but the newer one, does not. They’re almost identical contrast wise. Exposure times where the same and the angle of the target in the sky is almost the same between the different pictures i tried to solve.

I’m attaching the log. Keep in mind that this last tests were done today, on the 14 of Feb.
Thanks in advance!!
sg_logfile_20180213170451.txt (78.6 KB)


#6

I can take a look at it if you send me the original fits file. Please email it to andy.galasso@gmail.com.


#7

Sending it right now! Thank youuuuuuu


#8

Thanks to Andy’s help I manage to fix the blind fail solver, but the PlateSolve2 still doesnt work! Don’t know what to do


www.mainsequencesoftware.com