Plate solving bug report - 2.5.0.11


#1

I am pretty sure this is a bug report on the latest versions of SGP. I am presently using 2.5.0.11

With PS2 doing such a good job I rarely have to fall back to a blind solve - but it is necessary at times. For that I use Astrometry.net. I have a local install which up until recently (can’t say for sure which Beta) worked no problem. Not so now.

Now we have two choices in the settings: “Astrometry.NET (Remote)” or “ANSVR (Local Astrometry.NET)”…[I actually miss Elbrus sometimes - but that is not the point here…I am talking about Blind Solving]!

Tonight I did an experiment on my home computer (not obs computer). In the target settings, I browsed and picked an image on the computer. Called for a blind solve with Local Astrometry Net. It worked fine - about 20 seconds. Could not figure out why the obs computer (with everything similar - other than internet connection) would not do the same local blind solve… Idea! … Disconnected my phone line from the modem - and tried again on the home computer. NO SOLVE. Maybe the choice of solvers were somehow mixed…so tried the Remote solve (phone line still disconnected) - NO SOLVE. So as far as I can see, either choice (Remote or Ansvr) will still call for the remote solve.
To double check…connected the phone line again…called for an Ansvr (local) solve…and it worked as did a subsequent Remote solve. As I said above - pretty sure both selections are calling for REMOTE solve.


#2

Kinch, you can tell for sure if a solve is local or remote by opening Start Menu => Astrometry.net Local Solver => Watch ansvr log. If the solve is local you’ll see lots of stuff scrolling by. If remote, then nothing will happen in the ansvr log.
Andy


#3

The particular solver instance you reported this bug through no longer exists in 2.5.0.12 so, if a bug was there, we can lo longer fix it… If you can produce these results from other areas in SGPro like right click to solve, that will be a different story.


#4

Andy:
Thanks Andy - just did that this morning. Plate solve worked (as last night) using Local Astrometry Net -computer connected to the internet - but NO activity in the ansvr log. (This was done on the right hand side of the Target Settings window).

Ken:
Opened an image and asked for a blind solve via right click. Local astrometry net solved it AND this time the activity was evident in the ansvr log.

So when 2.5.0.12 is released to us I guess I will be changing the way I normally ask for a blind solve - I presume this is all linked to the right side of the Target Setting window now being dropped.

What I will have to check though is where I really need the blind solve: on a blind sync & solve out at the scope. This is where I was having the practical problems e.g. if I worked on the scope/mount during the day then PS2 (really the mount) had no idea where the scope was pointing when I wanted to sync it. I don’t think the fail to blind solve worked correctly (due I would say to what was outlined above - no local ansvr activity)…BUT I’ll have to check that. (On those occasions, I pointed to a bright star and synced the scope in The Sky X…then did another sync via PS2 when the pointing coordinates for the mount were very close to true).
I will test that part further when I get a chance - and when I have 2.5.0.12


#5

Just to close this thread - I had no problem doing a blind solve with local Astometry.net (no internet connection) out at the scope last night. SGP 2.5.0.12


www.mainsequencesoftware.com