Plate solving is failing

Description
I have created a target using the Framing and Mosaic Wizard. When I go to my sequence window, right click on the target and choose the option to center on the target, the telescope slews but then plate solving fails. If I give it enough time, it will go into blind solving mode and find the target, but it takes forever. In fact, the first time on the second night, it slewed, SOLVED and then when it tried to center the object more precisely, it failed. Any ideas?
Thanks
Alan

Aprox time of issue:

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
Ver: 3.1.0.457
.NET: 4.8

I’m not proficient in looking at logs. What plate solver are you using? For years I used PlateSolve2 which worked 95% of the time, but there was always a certain part of the sky that wouldn’t solve. Since I switched to ASTAP I haven’t noticed anything like that and solves are even faster. I suggest trying a different solver just to see what happens.

How does one go about switching to ASTAP? If it’s faster I’m all for it!

https://www.hnsky.org/astap.htm

Install ASTAP and the G17 catalog as described and then choose ASTAP in the SGP control panel.

I have switched to ASTAP too. One thing though. I had to go from 3X3 binning on my very slow-to-download SBIG STL to 2X2 binning or ASTAP refused to solve. It’s still a win for me but some of the additional speed of ASTAP is lost to the longer download of 2X2 binning.

Are there any settings you have to change other than setting ASTAP as the plate solving interface in SGP? When I click on Settings on the Plate Solve tab of the Equipment Profile Manager, it opens ASTAP and I don’t know where to go from there.
Thanks!

Alan