Plate solving window


#1

With reference to SGPro’s excellent YouTube video Live:A Demonstration Of Sequence Generator Pro.

It showed plate solving with Pinpoint.
This video showed a right hand side options window in the plate solver that does not display with Platesolve2 or with the Trial Pinpoint in SGpro that I am testing.
It seems you have to type the co-ordinates in manually and do not change when Stellarium selects a target. There is no options to import co-ordinates. The missing option are circled in red.
Have I setup plate solving incorrectly.


#2

The right side of the Target Settings dialog has since been removed. It’s only purpose was to populate the coordinates under “Location” on the left side. As such it was a bit redundant and confusing to some.

Instead, the new left side has an option "Populate from web link (Astrobin, Flickr).

I’m not exactly sure what your reference to Stellarium means. I believe that you can copy and paste the coordinates from Stellarium into the SGP “Location” fields.

Also, if you have an image on your hard drive that you want to use as the reference, simply open the image in SGP, right click on it and select plate solve. After the plate solve completes successfully there is an option to “Use these results for target xxx” and it will fill in the coordinates for you from the solve.


#3

Thank you that explain the missing panel.
With regards to Stellarium which I usually use to select targets.
I had assumed these co-ordinates would have been picked up from ASCOM and displayed in SGPro as both are connected to my CEM60CE mount via ASCOM. This is how it worked with BYEOS and AstroTortilla.

Sorry if this seems a bit basic. I am not new to plate solving but totally new to automation.

I have tried selecting an this image from Astrobin 114959 and it has been accepted as a valid target but the RA and DEC are still at 00-00 do I have to enter a approximate entry first? I am using the simulator and it says plate solving failed.


#4

To my knowledge the coordinates won’t just be automatically picked up from
Stellarium in the way you describe.

The Astrobin image has to have plate solve info attached to it (on
Astrobin). I couldn’t find the specific image by that reference number.
What link did you use in the SGP field? If the image on Astrobin does not
have coordinate info with it then it will not work in SGP.


#5

I have tried a number of images and provided I have manually loaded the equipment profile I have setup they are now populating the co-ordinates. I have set this profile to be the default but probably need to study this further.

Thank you.


#6

Take a look at the framing and mosaic wizard. I don’t use planetarium software other than to determine rise/set times.


#7

Ref to using Stellarium with SGP’s F & M wizard…

There are 2 ways you can do this.

Here’s No 1

  1. Select your chosen object inside Stellarium so you see it’s designated name in the top left corner

  2. Do a Ctrl ‘C’ which will copy ‘ALL’ of the selected objects data

  3. Have the F & M wizard open and click in the ‘Object’ box

  4. Ctrl ‘V’ will paste the name line of the object in the box

  5. Hit ‘Fetch’

example:
Copying & pasting the ‘M34’ object will paste the following:

Spiral cluster (M 34 - NGC 1039 - Cr 31 - Mel 17)

This will fail as it is, you have to delete what you don’t need, Use only M34 or NGC1039, Wont work
with an objects common name, also wont do anything beginning with either Cr, B, C or Mel

What does work well is any object beginning with M, IC, LBN, NGC or HIP (for stars), just remember
to delete everything else. Once object has been identified, the RA and DEC boxes will be populated
with objects coordinates and so will the sequencer on target creation.

Option 2

  1. Copy your selected object in Stellarium

  2. In F & M wizard, change the ‘Dot’ selector from ‘Object’ to the one with RA next to it

  3. Double click in the RA coordinates box so the contents is selected

  4. Ctrl ‘V’ to paste

On paste, the RA and DEC boxes will be populated with the coordinates from Stellarium for
your object, just click ‘Fetch’ - Be aware that this method will not populate the ‘Object’ box
with a name so you will be prompted for a name when hitting the ‘Create Sequence’ button.

Hope this helps
Paul


#8

Thank you for this comprehensive reply.
It is a shame that we cannot simply slew the mount to object with Ctr 1 in stellarium and then have a fetch button to get the co-ordinates from ASCOM. This is what AstroTortilla does. Perhaps a feature to add in the future.

Thanks again


#9

It seems like this is actually more steps than Ctrl+C the object in Stellarium then in SGPro Ctrl+V in the RA box (or if it isn’t it should only be one more step? Not sure…). Maybe I am not understanding something key to this conversation (likely because I am not very familiar with Stellarium).


#10

Thank you will give it a try.

Peter


#11

Ken,
If using Stellarium with an NEQ6 Pro mount for example then you need to use a utility called Stellariumscope which bridges the gap to ASCOM as Stellarium doesn’t support the mount directly. This utility provides x3 keyboard shortcuts as follows:

Ctrl ‘1’ = This shortcut is the equivalent of 'Slew to selected object, it will send the mount to whatever object you have selected at that time

Ctrl ‘2’ = This one provides a ‘Synch’ function through ASCOM

Ctrl ‘3’ = This is the equivalent of an emergency stop

Tis true that ASCOM will hold the current coordinates after a Ctrl ‘1’ was performed and the mount has reached the target which was selected by the user in Stellarium’s interface. I assume ‘PeterF’ is referring to a kind of ‘Fetch’ button like the one in the F & M wizard which would just read the RA and DEC from ASCOM.

I see the point of this but not to populate the RA and DEC in the Target Settings box via the sequencer, this gives an SGP user no option to frame/rotate the object of interest viewed in Stellarium. In the F & M wizard there are currently ‘Fetching’ options for a written object designation (Object), Coordinates from an image which holds RA & DEC coordinates (Image) and of course the RA and DEC direct coordinates. Is there any reason why SGP could not read ASCOM’s current coordinates into the RA & DEC fields and ‘Fetch’ would then bring up the image so framing can be performed ?

I think it would be quite a good little addition to F & M personally…More options are always good.

Regards
Paul


#12

No, no good reason really… just that the MFW was designed for use primarily not out in the field (or really for daytime use in the planning stages) so I never really thought the mount would be connected or pointing at anything of value.

Because it took all of 3 minutes and is non-invasive… here it is:


#13

That’s awesome…


#14

LOL

Well I’ll be God Damned…Looks like PeterF got his wish…Nice one Ken !

I already know how I’ll use this :grin:

Thank you Ken

Paul


#15

That exactly what I wanted. I am currently using the evaluation version. How will this update be applied?

This makes SGP much more attractive to me.

Well done.


#16

Peter,

Without making assumptions, I would imaging in the next Beta


www.mainsequencesoftware.com