Please Help! No contact with Local Astrometry.NET


#1

I have downloaded and installed ansvr-setup-0.20.exe to SGPro
I did not work at port 8080 so I changed the port to 7900.
Then everything worked well until I restarted my computer. Then I got no contact with
Astrometry.Net local solver
I reinstalled the software with another port number and everything worked until I restarted my computer. Then it did not work and I have now installed the program with different port numbers without any positive result
I’m running Windows10 on an HP laptop
What should I do?
Here is the log for the latest attempt
Thanks/Goran


#2

Forgot to send with the log
Here it comes

01-22-18 14:56:45.228][DEBUG] [Main Thread] Licensing: Machine ID found…
[01-22-18 14:56:45.243][DEBUG] [Main Thread] Checking for valid internet connection…
[01-22-18 14:56:45.447][DEBUG] [Main Thread] Valid internet connection detected…
[01-22-18 14:56:46.540][DEBUG] [Main Thread] Licensing: Request for licenses successful, writing cookie…
[01-22-18 14:56:46.556][DEBUG] [Main Thread] Licensing: Applying licenses…
[01-22-18 14:56:46.556][DEBUG] [Main Thread] Licensing: Licenses applied…
[01-22-18 14:56:46.556][DEBUG] [Main Thread] SGPro retail license…
[01-22-18 14:56:47.575][DEBUG] [Main Thread] API successfully started on port 59590…
[01-22-18 14:56:48.363][DEBUG] [Main Thread] Error loading notification settings! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\notifications.sgd.
[01-22-18 14:56:48.367][DEBUG] [Main Thread] Error loading GNS endpoint settings! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\gnsSettings.sgd.
[01-22-18 14:56:48.368][DEBUG] [Main Thread] Error loading email endpoint addresses! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\1-emailEndpointAddresses.sgd.
[01-22-18 14:56:48.368][DEBUG] [Main Thread] Error loading email endpoint addresses! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\2-emailEndpointAddresses.sgd.
[01-22-18 14:56:48.368][DEBUG] [Main Thread] Error loading email endpoint addresses! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\3-emailEndpointAddresses.sgd.

[01-22-18 14:56:48.369][DEBUG] [Main Thread] Error loading text file endpoint data! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\1-textFileEndpointSettings.sgd.
[01-22-18 14:56:48.369][DEBUG] [Main Thread] Error loading text file endpoint data! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\2-textFileEndpointSettings.sgd.
[01-22-18 14:56:48.369][DEBUG] [Main Thread] Error loading text file endpoint data! Det gick inte att hitta filen C:\Users\Admin\AppData\Local\SequenceGenerator\Sequence Generator Pro\3-textFileEndpointSettings.sgd.
[01-22-18 14:56:48.529][DEBUG] [Main Thread] ===== S E Q U E N C E G E N E R A T O R (v2.6.0.25) =====
[01-22-18 14:56:48.656][DEBUG] [Main Thread] OS: Microsoft Windows 10 Pro
/Goran


#3

I don’t think Astrometry.Net local runs automatically on re-boot/start-up. Have you confirmed it is running?

DaveNL


#4

Hi
I enter the start menu and click StartAnsvr
Then I click Ansvr Settings, and only gets the message that
The website can not be reached
If I try to make a plateolve on a picture in SGPro, I get after 1sek error message:
Failed two plate solve image! and in the status bar it says: (Wating on http://127.0.0.1:7909/api) and it generates the log above


#5

in the log it says: Error Unable to connect to remote server. Here is the right Log

01-22-18 14:57:21.141][DEBUG] [Main Thread] Creating bitmap (5496,3670)…
[01-22-18 14:57:21.149][DEBUG] [Main Thread] Locking bitmap for write
[01-22-18 14:57:21.149][DEBUG] [Main Thread] RAW bith depth: 16
[01-22-18 14:57:21.221][DEBUG] [Main Thread] Display image preview using asynch task…
[01-22-18 14:57:37.931][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Locking bitmap for disk write…
[01-22-18 14:57:37.943][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Opening file stream…
[01-22-18 14:57:37.944][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Writing FITS headers…
[01-22-18 14:57:37.953][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[01-22-18 14:57:38.219][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: FITS block fill…
[01-22-18 14:57:38.219][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Unlocking bitmap…
[01-22-18 14:57:38.219][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Closing file stream
[01-22-18 14:57:38.227][DEBUG] [Image Plate Solve Thread] Astrometry.NET: Sequence endpoint data: Astrometry.NET (Remote)
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] ************* SOLVE HINTS ****************
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] SOLVER: Astrometry.NET
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] BLIND: True
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] METHOD: Max Regions
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] RA: 0
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] DEC: 0
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] SCALE: 1,12
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] ******************************************
[01-22-18 14:57:38.229][DEBUG] [Image Plate Solve Thread] Astrometry.NET: Sequence endpoint data: http://127.0.0.1:7908/api
[01-22-18 14:57:38.787][DEBUG] [Image Plate Solve Thread] Astrometry.NET convertedAstrometry.fits path: C:\Users\Admin\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[01-22-18 14:57:38.787][DEBUG] [Image Plate Solve Thread] Astrometry.NET - File is too large, resizing
[01-22-18 14:57:38.808][DEBUG] [Image Plate Solve Thread] Astrometry.NET - Saving file
[01-22-18 14:57:38.808][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Locking bitmap for disk write…
[01-22-18 14:57:38.808][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Opening file stream…
[01-22-18 14:57:38.809][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Writing FITS headers…
[01-22-18 14:57:38.809][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[01-22-18 14:57:38.820][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: FITS block fill…
[01-22-18 14:57:38.820][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Unlocking bitmap…
[01-22-18 14:57:38.820][DEBUG] [Image Plate Solve Thread] SaveFileBmp16: Closing file stream
[01-22-18 14:57:38.821][DEBUG] [Image Plate Solve Thread] Astrometry.NET using endpoint: http://127.0.0.1:7908/api/
[01-22-18 14:57:38.821][DEBUG] [Image Plate Solve Thread] Astrometry.NET - Calling Async Solve
[01-22-18 14:57:39.856][DEBUG] [Unknown] Exception in Astrometry.NET Solver: Det går inte att ansluta till fjärrservern
[01-22-18 14:57:39.856][DEBUG] [Unknown] Astrometry.NET solve done in 0 seconds.
[01-22-18 14:57:40.825][DEBUG] [Image Plate Solve Thread] Astrometry.NET - Solve Completed
[01-22-18 14:57:40.825][DEBUG] [Image Plate Solve Thread] Astrometry.NET - Failed to solve image.
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] *********** SUCCESSFUL SOLVE *************
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] SOLVER: True
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] SUCCESS: False
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] CONF: 0
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] BLIND: True
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] RA: 0
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] DEC: 0
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] SCALE: 0
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] FLIPPED: False
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] ANGLE (EON): -500
[01-22-18 14:57:40.826][DEBUG] [Image Plate Solve Thread] MSG: Failed to solve image
/Goran


#6

@gorang:
Others here are more knowledgeable on ANSVR than I am so perhaps they can provide better insight.

If you select “Ansvr Settings” from the Windows Start menu and get website not reachable, then ANSVR is either not running or is trying to access on wrong port. No point trying to Platesolve in SGP if ANSVR is not running properly.

If you are confident that ANSVR is running on port 7908 you could try opening up this in a web page directly (should not get error message):
http://127.0.0.1:7908/api/config

DaveNL


#7

If Ansvr Settings can’t find the Ansvr website then there’s probably something about how Ansvr is set up and it isn’t starting correctly.

Try the Watch ANSVR Log option in the Astromotery.NET Local Solver section of the start menu. That will tell you if Ansvr is running and what port it is listening on.

My guess is that there’s something up with how you have set a different port number but I’ve never tried changing the port.


#8

@gorang are you still having trouble with this? Have you tried the things that Chris suggested?
If you still need help you can contact me privately at andy.agalasso@gmail.com


#9

I uninstalled the program and restarted it again and downloaded the index files again. Now it appears to work on port no. 8075
Do not dare to test 8080 in case it will stop working again.
It may be all updates on Windows10 that made it not work
I’ll hear from me again if it stops working again
Thank you for all the answers!
Greetings
Goran


www.mainsequencesoftware.com