Problem getting images from Nikon D750

I’m having problems using my Nikon D750 with SGP (trial version of 3.1.0.432 on Win10). The problem behavior is that while it seems to connect OK, I can’t take images reliably. In Frame & Focus, a Take One of 1s will appear to take the image and then show “Downloading” in the message area. But then nothing happens - no image appears and can’t abort/stop. I have to quit SGP altogether.

Sample log file is https://www.dropbox.com/s/j3ojezbh6uw5t1g/sg_logfile_20200110105428.log?dl=0. At 10:55:19 it starts the capture and then nothing until I quit SGP well over a minute later.

I’ve tried two different cables (both of which work outside of SGP) and connecting either via a powered USB hub or direct to the laptop - no difference. Also read through other D750 issues here and tried a few things but nothing helped.

Hoping you can help me … thanks.

  • Tom

Is the camera in “Bulb” mode?

Hey Ken -
I’ve set the camera to Bulb mode before connecting and tried it without as well. No difference - looks like SGP has no problem setting exp and ISO as configured in the F&F panel and it retains what SGP set after disconnecting.

I’ve tried a large number of connection permutations. The only thing that works for an extended period of time (SGP keeps happily snapping and downloading) is when the D750 is the only USB device and it’s directly connected to the laptop. If I add on other devices (mount controller via EQMOD) and/or my guide scope (ZWO ASI290mm Mini) and/or go through the powered USB hub, it eventually hangs on a download. I thought bypassing the hub and connecting the 3 devices directly might work but it would still hang. Some configs seemed to work better than others (at least for a while) but all eventually hung except the direct, camera-only configuration.

Checking the log, I often see the following when it hangs:

Nikon: Failure in Capture image! [kNkMAIDResult_NoMedia] (kNkMAIDCommand_CapStart, 17, kNkMAIDDataType_Null, 0)

Any ideas? Thanks -
Tom

Sorry, I don’t have a great answer here… This issue seems like it might be beyond the scope of SGPro… maybe? I don’t know. We do have lots of Nikon users with a vast array of astro-equipment, so it doesn’t seem to be a common issue. I’m not sure if you have access to a different machine (even to borrow), but it would be a good data point to see if your USB buses are being mismanaged by the windows drivers… well, I guess that’s an idea too. Whoever made your motherboard or laptop will also have sprayed out a bunch of driver updates over time. You should check those out and ensure that all of your machine’s USB drivers are up to date (especially of Windows 10 just installed its default USB drivers).

Yeah - poking around elsewhere turns up no end of USB pain regardless of equipment and software. I think I need to do a deep dive into that world. Appears to be a necessary part of building a setup and a rite of passage.

Thanks Ken - appreciate you taking the time to respond. Might need to extend my SGP trial depending on when I get a stable setup :wink:

Tom

That’s fine. You can do this via the “Help” menu.

I was having this problem on my travel rig with my D750. After a ton of tries and cable changes I switched laptops and it went away. Seems like windows learns those ports on my Hub and gets stubborn. Same thing happens when I switch to another scope and connect to a different Moonlight controller. I have to delete the port and let it relearn and then it works. It all seems to be how windows learns those ports. I’d keep looking at your hub and ports.