Problem QHY10 with Last 2 beta version

Hi,

I have problem with the last 2 beta version when take the photo, the problem arrived with the version Sequence Generator Pro Beta v3.1.0.390

After upgrade the last version yesterday, all the photo display black or white vertical line.

I downgrade at the version Sequence Generator Pro Beta v3.1.0.388 was fine for me and arrived at the same problem. :roll_eyes:

To solve the global problem I installed the version Sequence Generator Pro v3.0.3.169, it was fine.

Please, if you have other users QHY10 with the same problem or the solution.

Best Regards,

Leandro

Please include logs and I will take a look. There have been no significant changes that I can think of that would affect your camera like that, but I can take a look.

Hello Ken,

I will send the log file at the email forums@mainsequencesoftware.com

The Saturday 11/26/19 I worked with fine all the week end, I upgraded the last version yesterday in the morning and when start the session to take photo in the Saturday night start the problem.

To solve I load different beta version but not arrive at the good solution. finally uninstall all SGP by my computer and load the last official version.

Also, I attach the example photo with the test today.

Regards,

Leandro

Summary

This text will be hidden

@RAPALA

Please see here for help with support requests: New methods to open a support request

I don’t think that email address is monitored. The template above lists the correct address.

Hi Ken,

Here is the link to download the logs fieles.

Regards,

Leandro

https://1drv.ms/u/s!Apuq84ULdsyEgr9K-jKmdgDj60rKNg

There are lots of log files in that download. Please let me know which one(s) show the issue you describe.

Hi,

The log have date 11/30/19 you can see the problem, tris saturado I installed different versión beta to arrive Atlas the solución.

Regards

Leandro

Your camera is never reporting that the image is ready. When you abort the exposure, the camera says it is still downloading. Please ensure that you are not using a USB hub for testing. You will likely want to turn camera logging on and reproduce the issue so we can see what the camera is doing. According to SGPro, everything is ok, but the camera gets into a bad state.

So far, no other reports of this (for any ASCOM camera). Have you made sure that both your native and ASCOM drivers up to date?

RAPALA,
Take a look at the following QHY Forum thread:

https://www.qhyccd.com/bbs/index.php?topic=7495.0

Load up the drivers llsong posts half way up the thread.

I have had the same kind of issue with my QHY8L, the image you posted above
looks more or less identical to the image I got too. I was also getting a full blown
crash in SGP when the second image began downloading.

I managed a quick test with the ASCOM driver this morn and the image looked
the way it should do. I will test more intensely later.

Give it a try

Paul

1 Like

Hi,

The actual configuration I use a Long time, ir you see my inicial report the problem start when upgrade at the version the day 11/30/19.

The ASCOM drive is the last a few year ago, you can see the log of the day 11/24/19. version v3.1.0.213, all was fine all the night.

The upgrade of version v3.1.0.213 arrive the problem, I have other friend with QHY10 with the same problem.

I hope you discovery the “problem”.

Regards,

Leandro

Hi,

I will try the Test.

Please, you can send me link to download the versión v3.1.0.213.

Regards,

LV

It’s the same issue happening with ASI cameras, when using a usb hub, mine is 12v powered hub, the ascom driver reports downloading.

Even if I use the Native Driver, it will get random black image.

Old version seems fine.

[12/03/19 19:56:16.763][DEBUG] [PHD2 Listener Thread] PHD2: Settle done received: GOOD
[12/03/19 19:56:17.005][DEBUG] [Sequence Thread] Auto guider has settled…
[12/03/19 19:56:17.089][DEBUG] [Sequence Thread] Handling monitoring event (Good Night System, Status): (1600default) Auto guider has settled.
[12/03/19 19:56:17.089][DEBUG] [Sequence Thread] GNS: Sent status message to GNS ((1600default) Auto guider has settled.)…
[12/03/19 19:56:17.090][DEBUG] [Sequence Thread] EventMarker(8) - t:IC1805-HSO (3); e:1; f:3; o:
[12/03/19 19:56:17.090][DEBUG] [Sequence Thread] BlockUntilFocuserMovementDone: Focuser reports it is done moving, continuing…
[12/03/19 19:56:17.090][DEBUG] [Sequence Thread] Set start frame data -> Pos: 10181; Temp: -2 …
[12/03/19 19:56:17.093][DEBUG] [Sequence Thread] Created base name for frame capture: IC1805-HSO_ZWO Camera_Ha-7nm_0004_600sec_0.0deg_sop-west
[12/03/19 19:56:17.093][DEBUG] [Sequence Thread] Created directory for frame capture: C:\Users\Maple\OneDrive\Astro\IC1805-HSO\2019-12-03\Light\HA
[12/03/19 19:56:17.093][DEBUG] [Sequence Thread] EventMarker(9) - t:IC1805-HSO (3); e:1; f:3; o:
[12/03/19 19:56:17.093][DEBUG] [Sequence Thread] EventMarker(10) - t:IC1805-HSO (3); e:1; f:3; o:
[12/03/19 19:56:17.093][DEBUG] [Sequence Thread] Finished sending frame capture. Entering wait mode…
[12/03/19 19:56:17.093][DEBUG] [Sequence Thread] EventMarker(11) - t:IC1805-HSO (3); e:1; f:3; o:
[12/03/19 19:56:17.094][DEBUG] [Sequence Thread] EventMarker(12) - t:IC1805-HSO (3); e:1; f:3; o:
[12/03/19 19:56:17.097][DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE message received…
[12/03/19 19:56:17.097][DEBUG] [Camera Thread] Starting ZWO Capture for 600.00 Seconds
[12/03/19 19:56:17.111][DEBUG] [Camera Thread] GlobalExceptionHandler caught: Error ‘ASI_ERROR_GENERAL_ERROR’ from call to
ASIa(A_0=0, A_1=f, A_2=50, A_3=False)
[12/03/19 19:56:17.111][DEBUG] [Camera Thread] InnerException: Empty
[12/03/19 19:56:17.111][DEBUG] [Camera Thread] Call stack: at jb.a(ASI_ERROR_CODE A_0, MethodBase A_1, Object[] A_2)
at jb.a(Int32 A_0, a A_1, Int32 A_2, Boolean A_3)
at je.ae(Int32 A_0)
at sz.hx(qe A_0, sf& A_1, sf[] A_2)
at rw.u6()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
[12/03/19 19:56:17.111][DEBUG] [Camera Thread] Runtime terminating: True
[12/03/19 19:56:17.176][DEBUG] [Sequence Thread] Handling monitoring event (Good Night System, Status): (1600default) Starting integration of IC1805-HSO; Event 2; Frame 4 for 600s…
[12/03/19 19:56:17.176][DEBUG] [Sequence Thread] GNS: Sent status message to GNS ((1600default) Starting integration of IC1805-HSO; Event 2; Frame 4 for 600s…)…
[12/03/19 19:56:17.176][DEBUG] [Sequence Thread] Handling monitoring event (THIS IS NOT AN ACTUAL ERROR) (Good Night System, TimedError): (1600default) Failure while integrating IC1805-HSO; Event 2; Frame 4 for 600s. Image has not downloaded in alloted time period.
[12/03/19 19:56:17.176][DEBUG] [Sequence Thread] GNS: Sent timed event to GNS…
[12/03/19 19:56:17.186][DEBUG] [Sequence Thread] EventMarker(13) - t:IC1805-HSO (3); e:1; f:3; o:

To add another log stack, this img turns out to be a black one with 0 data, but the FIT header is okay.

[12/04/19 00:59:58.400][DEBUG] [Sequence Thread] EventMarker(8) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 00:59:58.400][DEBUG] [Sequence Thread] BlockUntilFocuserMovementDone: Focuser reports it is done moving, continuing…
[12/04/19 00:59:58.400][DEBUG] [Sequence Thread] Set start frame data -> Pos: 10177; Temp: 0 …
[12/04/19 00:59:58.407][DEBUG] [Sequence Thread] Created base name for frame capture: NGC2244-HSO_ZWO Camera_O3-7nm_0011_600sec_0.0deg_sop-west
[12/04/19 00:59:58.407][DEBUG] [Sequence Thread] Created directory for frame capture: C:\Users\Maple\OneDrive\Astro\NGC2244-HSO\2019-12-03\Light\O3
[12/04/19 00:59:58.407][DEBUG] [Sequence Thread] EventMarker(9) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 00:59:58.407][DEBUG] [Sequence Thread] EventMarker(10) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 00:59:58.407][DEBUG] [Sequence Thread] Finished sending frame capture. Entering wait mode…
[12/04/19 00:59:58.407][DEBUG] [Sequence Thread] EventMarker(11) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 00:59:58.414][DEBUG] [Sequence Thread] EventMarker(12) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 00:59:58.416][DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE message received…
[12/04/19 00:59:58.416][DEBUG] [Camera Thread] Starting ZWO Capture for 600.00 Seconds
[12/04/19 00:59:58.490][DEBUG] [Sequence Thread] Handling monitoring event (Good Night System, Status): (1600default) Starting integration of NGC2244-HSO; Event 2; Frame 11 for 600s…
[12/04/19 00:59:58.491][DEBUG] [Sequence Thread] GNS: Sent status message to GNS ((1600default) Starting integration of NGC2244-HSO; Event 2; Frame 11 for 600s…)…
[12/04/19 00:59:58.491][DEBUG] [Sequence Thread] Handling monitoring event (THIS IS NOT AN ACTUAL ERROR) (Good Night System, TimedError): (1600default) Failure while integrating NGC2244-HSO; Event 2; Frame 11 for 600s. Image has not downloaded in alloted time period.
[12/04/19 00:59:58.491][DEBUG] [Sequence Thread] GNS: Sent timed event to GNS…
[12/04/19 00:59:58.497][DEBUG] [Sequence Thread] EventMarker(13) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 01:01:07.496][DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[12/04/19 01:01:07.515][DEBUG] [MF Update Thread] Performing serialize…
[12/04/19 01:09:58.592][DEBUG] [Sequence Thread] EventMarker(15) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 01:09:58.595][DEBUG] [Sequence Thread] Waking from exposure time sleep period…
[12/04/19 01:09:58.596][DEBUG] [Sequence Thread] Checking to see if the CCD has a temp…
[12/04/19 01:09:58.596][DEBUG] [Sequence Thread] Saving the CCD temp…
[12/04/19 01:09:58.601][DEBUG] [Sequence Thread] Entering super dangerous loop to await image completion…
[12/04/19 01:09:58.605][DEBUG] [Sequence Thread] EventMarker(16) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 01:10:00.752][DEBUG] [Camera Thread] ZWO Capture completed in 602302 mS
[12/04/19 01:10:00.964][DEBUG] [Camera Thread] ZWO Download Completed in 212 mS
[12/04/19 01:10:00.964][DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE complete…
[12/04/19 01:10:00.964][DEBUG] [Camera Thread] Camera thread is IDLE…
[12/04/19 01:10:01.110][DEBUG] [Sequence Thread] EventMarker(17) - t:NGC2244-HSO (4); e:1; f:10; o:
[12/04/19 01:10:01.110][DEBUG] [Sequence Thread] Image reported as complete. Continuing…
[12/04/19 01:10:01.111][DEBUG] [Sequence Thread] Disable driver temp comp. Driver temp comp was on -> False
[12/04/19 01:10:01.113][DEBUG] [Sequence Thread] Collecting FITs headers…
[12/04/19 01:10:01.113][DEBUG] [Sequence Thread] DATE-LOC time provided by SGPro (failed to retrieve valid entry from camera)…
[12/04/19 01:10:01.121][DEBUG] [Sequence Thread] GatherFitsHeaders: Writing header info for last solve…
[12/04/19 01:10:01.121][DEBUG] [Sequence Thread] GatherFitsHeaders: Writing header info from UI…
[12/04/19 01:10:01.122][DEBUG] [Sequence Thread] Clearing timed monitoring events…
[12/04/19 01:10:01.123][DEBUG] [Sequence Thread] Created full file name (file does not exist): C:\Users\Maple\OneDrive\Astro\NGC2244-HSO\2019-12-03\Light\O3\NGC2244-HSO_ZWO Camera_O3-7nm_0011_600sec_0.0deg_sop-west.fit
[12/04/19 01:10:01.123][DEBUG] [Sequence Thread] SaveFileAscom: Start…
[12/04/19 01:10:01.123][DEBUG] [Sequence Thread] SaveFileAscom: Checking image data…
[12/04/19 01:10:01.123][DEBUG] [Sequence Thread] SaveFileAscom: Create normal preview bitmap…
[12/04/19 01:10:01.131][DEBUG] [Sequence Thread] SaveFileAscom: Locking preview bits…
[12/04/19 01:10:01.131][DEBUG] [Sequence Thread] SaveFileAscom: Validating file name…
[12/04/19 01:10:01.131][DEBUG] [Sequence Thread] SaveFileAscom: Starting byte traversal…
[12/04/19 01:10:01.266][DEBUG] [Sequence Thread] SaveFileAscom: Unlocking preview bits…
[12/04/19 01:10:01.266][DEBUG] [Sequence Thread] SaveFileAscom: Saving preview bitmap to disk…
[12/04/19 01:10:01.266][DEBUG] [Sequence Thread] SaveFileBmp16: Locking bitmap for disk write…
[12/04/19 01:10:01.266][DEBUG] [Sequence Thread] SaveFileBmp16: Opening file stream…
[12/04/19 01:10:01.267][DEBUG] [Sequence Thread] SaveFileBmp16: Writing FITS headers…
[12/04/19 01:10:01.267][DEBUG] [Sequence Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[12/04/19 01:10:01.446][DEBUG] [Sequence Thread] SaveFileBmp16: FITS block fill…
[12/04/19 01:10:01.446][DEBUG] [Sequence Thread] SaveFileBmp16: Unlocking bitmap…
[12/04/19 01:10:01.446][DEBUG] [Sequence Thread] SaveFileBmp16: Closing file stream
[12/04/19 01:10:01.451][DEBUG] [Sequence Thread] SaveFileAscom: Displaying image preview in UI…
[12/04/19 01:10:01.451][DEBUG] [Sequence Thread] Internal Interface: Set Preview…
[12/04/19 01:10:01.451][DEBUG] [Sequence Thread] Display image preview using asynch task…
[12/04/19 01:10:02.175][DEBUG] [Image History Worker] Image analysis (async) START
[12/04/19 01:10:02.175][DEBUG] [Image History Worker] --> Find stars (normal)
[12/04/19 01:10:02.180][DEBUG] [Sequence Thread] SaveFileAscom: Done

Hi,

Please, send me one link where I can download the version in my previas email.

Regards,

Leandro