Proifile will not apply to sequence

Downloaded latest version of SGP last night. I am trying to take my flats and cant get the software to apply a profile to the sequence. When I try to connect to the camera it does not provide a choice of cameras like it always did before. The profile once selected is no longer listed in the title bar of the sequence as it has been (it just says "Untitled* ") . Cant get any function at all since I cant mount a profile. Absolutely none of the user defined profile information will load. SGP seems to be defaulting back to some internal settings.

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

I’m not sure about this… how does that apply to the profile issue you are seeing?

This has been removed from SGPro in 3.1 because it falsely reinforces the notion that the profile has something to do with the sequence after it applied. After a profile is applied, it has no relation at all with a profile. We will look at options in the future to track the history of profile application, but the profile name in the title bar was causing us lots of grief.

Seems like maybe there was an issue migrating your old equipment profiles. Can you go to the directory where you store profiles, zip and then send any files that end in SGP or BAK?

To be clear though… the names of your profiles appear in the list, but the values seem to be “reset” or even the names are gone?

SGP is still not giving us a choice between cameras when I go to connect. How can I know if the correct camera is being used for a sequence? When I go and check the control panel it randomly shows either the ZWO ASI 120 or the ZWO ASI 071. There is no way to switch other than to close SGP and restart it hoping it grabs the correct camera. I will find requested files and email to you

Ah ok. SGPro is no longer supporting the native ZWO drivers, but their ASCOM drivers have provision for multiple camera selection.

I am using Ascom Drivers. I have had no issues until today. All of the profiles are still there. They just will not load

The logs show that you are not using the ASCOM drivers (unless you change to the ASCOM camera before starting the sequence).

I think maybe we are both describing different things. Can you be specific when you write “will not load”? All your profiles are in perfect shape so I’m unsure what issue you are seeing. Is it that you are not able to apply a profile to a sequence (as the title implies) or is it that the profile manager does not have the values you expect (as the body of the post seems to imply)? Or something else entirely?

Perhaps I am attributing the difficulties to the wrong source i.e profile not being loaded. As far as I know I am using ASCOM drivers. and not the ASI drivers. We have not changed anything since the update. All problems began following the update. I had no issues prior to that. First answer to your first question is yes, I am not able to apply the profile to the sequence. The profile manager has the values I expect that is not the problem. another symptom is that when we change the auto close time settings for the auto focus and the meridian flip from 30 sec to 8 sec this change is not being accepted or used by the software. This is also a new problem starting with the update. Can you send me the portion of the log that says I am not using ASCOM drivers? I am selecting “ZWO Camera” not the ASI choice

If we could set up a Go to Meeting, I could show you exactly what I am talking about

The one that starts with ASI is the ASCOM driver. The one with ZWO is the native driver. The latest version makes this more obvious.

If you can record or detail the steps you are taking, that would be ideal.

I tried changing the drivers to the ASI. Looks like things are working now. Thanks for your help