QHYCFW3 causes SGP to close


#1

I am using the latest generation of QHY filter wheels, CFW3. I have two. The filter wheels can be used via serial cable connected to a QHY camera, or via USB. The USB connection actually uses a serial COM port.

I have identified a repeatable problem with the USB/RS232 connection that causes SGP to simply close with no warning. Here are the steps:

  1. Open SGP
  2. Choose filter wheel (QHYFWRS232 FilterWheel)
  3. SGP then asks to import the filter names - choose YES
  4. The filter wheel is connected
  5. If I then try to open the filter wheel settings (ASCOM driver) SGP closes.

If I disconnect the filter wheel first, I can open the ASCOM driver settings. So basically, any time the filter wheel is connected in SGP if I try to open the settings it will cause SGP to close without warning.

This isn’t a bid deal since the filter wheel works properly, but I thought I’d mention it since SGP doesn’t even give a warning dialog. LOG FILE


#2

Not all hardware supports opening the settings while the device is connected…and we have no way of knowing if they allow it or not other than trying it. However it shouldn’t cause SGP to completely quit. We have protection around the settings dialog for this case but maybe it’s putting the focuser into a bad state?

Thanks,
Jared


#3

As far as I can tell the filter wheel is fine after this happens. I can immediately restart SGP and connect again. It’s not a big deal as long as I remember not to go to settings while connected.


#4

I have had to deal with this bug (not sure if it’s the QHY driver, SGP, or interaction between the two) as well.

I have found a way to prevent SGP from shutting down on filter wheel operation: before connecting the filter wheel (QHYCFW3 via USB cable), I open the driver settings and without changing anything (it has already been properly configured), I click OK. Once that’s done, I can connect the filter wheel to SGP and execute filter change commands without any problems.

It is a mild inconvenience but the workaround has performed reliably.


#5

Thanks for the tip lucam. I will keep this in mind and see if it works.


#6

This sounds like something in the ASCOM driver is not being saved correctly between runs. May be worth reporting this to QHY as well if you haven’t already.

Thoughts @bmorrelltx?

Thanks,
Jared


#7

Just forwarded the thread to QHY… If you want something like this tracked, you need to open a ticket or post on the QHY forum. …… Bruce

Regards
Bruce Morrell

www.astrofactors.com

www.springcreekacademy.com

SpringCreekObservatory

214-557-5979


#8

I opened a ticket regarding this problem with QHY and there doesn’t seem to be any real resolution. Here is the reply I received from QHY:

Hi, My colleague tested it, and he tell me you should disconnect filter wheel, then open the setting. You can refer to the FAQ, it is Chinese version, but the image can reflect the issue. http://www.qhyccd.cn/index.php?m=content&c=index&a=show&catid=18&id=298 I will tell it to software colleague, maybe he will fix it later.

Most of the time this does work for me. Sometimes I have to disconnect and open the settings more than one time before it works properly. It’s a little unsettling that there could be this kind of instability, but so far I have always gotten the FW to work and it has worked fine all night long. Hopefully QHY will figure this out with a future driver update.

I specifically asked QHY about Jared’s suggestion about something in the ASCOM driver not being saved properly between runs, but that was never addressed.


#9

Thank you, Joel.

I agree, if it doesn’t work it’s right at the beginning of the session and a couple of tries usually takes care of it. It’s not how I like my software but it doesn’t look like it’s a high priority for QHY.

The filter wheel is a beautiful piece of hardware but the driver really leaves a lot to be desired in terms of stability and consistency.


www.mainsequencesoftware.com