Questions from a Trial User


#1

Hello all,

I have been testing the software out today while its cloudy, so my questions to this point are not necessarily related to any real imaging runs, just general questions.

  1. Framing and Mosaic - I have looked at the video and run through some samples of framing. I am perplexed though, as this seems to be a $39 add-on. Am I misunderstanding something? Is the add-on different somehow than what I have here in the trial? Also, when I attempt to frame a single target (in my test, I used the Horsehead Nebula) using my Canon 6D and Takahashi TOA130, when I right clicked and chose “Center Here” the image shifted and my rectangle went away. Did I do something wrong?

  2. PHD Dithering - The UI shows these values of Small, Medium, High, etc. What do these mean? The dithering settings in another application seemed to work well (Backyard EOS) and I would like to replicate the same settings. How would I achieve this in SGP?

  3. Image Grading. How exactly does this work? What is it using to determine the “grade” and what have folks used this for in practice?

That is about it for now, I am sure I will have more later…


#2

During the trial you are trialing the ENTIRE application, so the Framing and Mosaic Wizard is part of that. After the 45 day trial that will go away. However we also allow you to create a specific trial just for the addons so if you happened to miss them during the initial trial you can start up a fresh one by using the Licensing option in the menus.

These values correspond to the “Old” phd values so in pixels:
Small - 0.5
Medium - 1
High - 2
Very High - 3
Extreme - 5

See here:
http://mainsequencesoftware.com/Content/SGPHelp/ImageGrader.html

Thanks,
Jared


#3

Thanks Jared. This is helpful.

My next question is about WiFi connected cameras and the level of support in SGP. My Canon 6D has WiFi and I can get SGP to find it and connect to the camera fine. However, it seems that the software and the camera aren’t always on the same page, in terms of what the camera is up to. For example, if I run through a sequence, it succeeds, although much slower than I would expect. A sequence of 10 0 sec subs took 5 minutes and 17 seconds to complete. Then if I try to use Live View, the software attempts to do so, but then just sits there attempting to acquire the image, which never occurs. Then I have to restart the camera and the software to get it working again.

I am guessing that this is just a product of SGP not being optimized for WiFi.


#4

Yes wifi is not supported yet.


#5

I use the grading a lot. Simple to use but effective. Usually in a series of subs there will be a few that are of distinctly inferior quality to the others. If this is the case it helps your final integration if you remove those. The grader makes this easy. Don’t just remove the worst few. All the scores relate only to the current set so are completely relative. They may all be quite good do none should be removed.

I have a Canon 6D also and it takes about 9 seconds to download each image on my setup which would total 1.5 minutes for 10, a lot quicker that you are seeing. Did you check the “Use high speed download” on the Camera tab of the Control Panel? You can find a lot of info about the run in the log file found in this directory:
C:\Users\jerry\AppData\Local\SequenceGenerator
It includes info on the time some processes take.

I never tried to use the wifi and it is apparently not supported, and I have not tried to use liveview, but will be doing so shortly.


#6

I posted on cloudy nights as well but I’m not seeing this slow behavior with USB. Image download time is around 7 seconds with defaults. The only way I can get it slower is to use FITS + RAW and that’s about 12 seconds total. Which isn’t too surprising as we have to convert and write out an additional file.

But if you’re using defaults then you should just be getting a single FITS image. You can check to see what file type you’re using under the settings for the Canon camera.

Thanks,
Jared


#7

For those following along, I had the notification system enabled in my test, which was adding time to the subs. With it disabled I got great performance. Also, the Live View issue persists on the current non-beta build, but seems to not exist at all (via WiFi or USB) in the beta release.


#8

Do you mean by this that with the beta release Live View works perfectly, or does not work at all?


#9

My download time with the 6d is about 19 seconds for CR2 only. It seems that the image gets downloaded quickly but then there is a lag before its displayed. I attributed that to a slow processor.


#10

Edit: Live View has problems in the beta as well.

I did get the failure condition to happen again. I took a sequence, and attempted to switch to live view after it finished and it failed again. The log shows this:

[5/17/2016 12:18:14 PM] [DEBUG] [Camera Thread] SGM_FRAME_AND_FOCUS message received…
[5/17/2016 12:18:14 PM] [DEBUG] [Camera Thread] EOS camera: frame and focus…
[5/17/2016 12:18:14 PM] [DEBUG] [Camera Thread] Canon: Setting ISO to: 25600
[5/17/2016 12:18:14 PM] [DEBUG] [Camera Thread] Canon: ISO look val: 136
[5/17/2016 12:18:16 PM] [DEBUG] [Camera Thread] Error in Frame and Focus (Canon): Value cannot be null.
Parameter name: source

Now, I cannot even use live view when I freshly open SGP, even after a reboot, except for when I am on WiFi, then it seems to work provided I do not attempt to run a sequence before I use Live View.

As for image download time, the notification system was where mine was lagging. Once I disabled that, I got speeds comparable to other software programs. The notification system is not something I would personally use, so I do not plan to buy that module. The framing and mosaic wizard on the other hand, has me interested. I am going to try and use the normal plate solving though, via the control panel, to see how well it works compared to Astrotortilla.

I tested CR2 mode and RAW mode and there was no difference in the two in terms of speed. I am seeing 8-9 second downloads over WiFi based on what the log says, like:

[5/17/2016 12:05:19 PM] [DEBUG] [Canon Download Thread] --------------> getCapturedItem time: 8827 ms

USB tests show 2000-2500 ms download times.


#11

Ya, we’ve been tracking down LV issues with the 6D for a bit, unfortunately. No real ETA on it. Works with every other camera I know of and the 6D works occasionally too.

Thanks,
Jared


#12

What is the log saying about a null value?


#13

Nothing helpful. It’s likely a timing issue or an SDK issue.

Thanks,
Jared


#14

Timing could be the issue, and why it seems to work with more success on WiFi than USB.


www.mainsequencesoftware.com